[RELEASE] Lock User Management (LUM)

Yes that’s a bug with the ST Android App . It works fine with the iOS app. Please report it to ST and let them know it’s an Android specific issue. If they want more details from you can point them to this page How to pass parameters in href?

Reported, thanks. Now I just need to see if I can get my hands on an iOS device to get things set up until it’s fixed. I wish they gave us a way to modify installed SmartApp parameters directly through the IDE…

EDIT: As a workaround I changed number of users to 1, and set up the user overrides for user1, then opened the SmartApp again and set users to 2, then set up the user overrides for user2, etc. Looking in the SmartApp info in the IDE, this appears to have worked, but I won’t know for sure until I get home after work.

1 Like

That’s absolutely correct, Android’s bug is when you click the link it passes the details of the last user on the page, so that’s an awesome work around.

1 Like

I wanted to use this for work with a few employees. Is there a way to schedule certain codes to only work m-f 9 to 5?

Yes, see the first post.

just sent payment, can’t wait to try your apps. Looks like you do good work around here!

Got the lock management and custom device type all setup with ease and working great, very cool!

1 Like

Is anyone else having an issue where the app loses all settings each time you open it?

I am using a first gen ST hub, a Kwickset 99140, and version 4.1.1 of @RBoy 's multi user code app.

I can go in and program a few lock codes, they will write to the lock and work for a bit, but when I go back into the smartapp to add a new code or anything else all the settings I’d input are gone and I have to start from scratch.

I’d report it to ST support. There was another thread with similar issues users were facing where the internal variables in the app were wiped clean. Try deleting the app and reinstalling it (code too and start over), see if that may fix the issue.
What phone are you using? Unlikely it’s a phone app issue otherwise you might see it all over the forum.

I’m using an iPhone 6S.

And by deleting and reinstalling the app you mean deleting the multi user smartapp, right?

Yes, delete the code too and start over just incase.

What is the logic for the lock jam/stuck alert? I’m getting this notification when the lock is fine.

As mentioned earlier none. It’s done by the lock the app just reports it.

1 Like

###Multi User Lock Code Management - Version 4.2.0

  • Added a heartbeat system to improve the reliability of the scheduled codes to workaround for the issues folks are seeing with the broken ST platform timers
1 Like

Hi, My lock (yale keyfree) is reporting code 1 or code 2 used in the recent activity section but the user lock manager shows 0 usage for both codes and never fires of the routine I have associated to each of those codes either. I tried the standard device handler and the one given here neither fixes this. Any ideas?

You’re not using this app, it doesnt’ track usage. Wrong thread :slight_smile:

I could of sworn it was this app! Sorry!

Has this update been tested? I just tried to install the app for the first time, and I am getting a litany of red “Unexpected error” messages during initial configuration. I doubt it has much to do with the device itself since I can’t install the app in the first place. I have tried various combinations of settings hoping not to hit the error, but so far I have failed to click “Next” enough times to get the app installed.

It seems that as long as I don’t go back during the setup, everything is fine until I enter a code. Then no matter what, it seems to result in an error. (I can seem to get errors at any time by going back to a previous menu.)

Simulator also barfs during setup. Javascript on RBoy Smartthings web site (seemingly serving very little purpose) also buggy.

Yes,and just now again and no issues. Hundreds of folks are actively using it.

It’s likely your ST cloud instance having trouble. It’s not specific to this app, I get it sometimes randomly. Just wait for a while and hopefully the cloud will fix/load balance itself and it should work.
If it doesn’t contact ST support, also open IDE Live Logging and look for any errors there while trying to setup the app. If you see any report it back or to support, if there are no errors it’s just the platform.

Maybe ST issue but I noticed an issue with the auto lock feature. If you leave the door open for ~5 minutes it will not autolock. I’ve left the door closed to see if some timer kicks in but nothing happens. Not sure if some timers expired or something might fixable in the app. This wasn’t introduced in the new version, I experienced it for a while.

Okay will check it out, so to replicate, select door sensor, turn on AutoLock feature in SmartApp (not native device). Leave door open for 5 minutes and then close it. Is that right?