[RELEASE] Lock User Management (LUM)

Sure, we have a Yale YRD256 with Z-Wave Plus in the lab and it works just fine using these steps:

Thanks, will try with Virtual Switches.

Please excuse this question, but does anyone worry about the security risks of allowing a closed source app access to the smart lock on your house? Plus, since everything is connected to Wi-Fi I’m assuming it’s pretty trivial to determine your location/address if someone really wanted to. I’d like to purchase Rboy apps but I’m a little wary… I see this thread is at least 7 years old, so obviously people have been using it without issue for a long time.

No Im not concerned.

  1. the lock is ZWave not Wifi - you’d have to successfully bridge into the ZWave stack of the ST hub (edit: or another WiFi device also joined to my zwave network, in my case none) - no trivial task. Not impossible, but it would take a targeted attack. I don’t have anything that valuable worth that kind of effort.
  2. RBoy’s code is visible if you pay - I’ve read the whole thing.
  3. the weak point in the whole chain security wise is your SmartThings authentication - Use 2-factor auth there.
6 Likes

Ditto to what @nathancu said.

1 Like

Thank you for the explanation and putting my mind at ease.

1 Like

I have to warn everyone who might be willing to purchase LUM from RBOY. I have a sign in issue with my account, and contacted them for assistance. Their response to me was: “You need to buy another license…” WTH! No customer service what so ever. Not saying that LUM is bad, I wouldn’t actually know since I can’t log in to it!

Are you sure, I dont know @RBoy personally but that does not sound like him. Hes very very helpful. I just logged in with no issues on the website.

5 Likes

My experience with rBoy has been great. When I had questions they responded promptly, both before and after making payment.

4 Likes

I’m very glad that you have nothing but good experiences with rboy. However, that does not change the fact that I have not. No customer service what so ever. My LUM license appears to be hung up, it shows logged in at Home location, even though it isn’t. I don’t know if it got hung up on my old HTC phone that no longer works, or the old Samsung app, which also no longer works, or if maybe someone else some how got a hold of it. All I know is, I can’t use it in the new app on my new phone. When I reached out for assistance, their response was I needed to buy another license. I don’t know about you, but I can’t justify spending $40 for something that I’ve already bought and paid for. Now you tell me: is this a good experience?

Todd, I’m sorry that you’re having trouble with your license. I see that @Maddie sent you a detailed explanation over email. It looks like you purchased the license and installed LUM last year. Now when trying to install LUM at a new location using the same license (it’s not a website login issue) it’s prompting you to purchase a separate license.
If you have any questions feel free to reply to her email and we’ll do our best to help.

5 Likes

I installed a new Schlage BE469ZP lock on my front door. Everything works fine, but it keep reporting “Master Code” use when we are NOT using the master code. It also reports “Master Code” when we lock the door using the “single touch lock” feature on the keypad (pressing the SCHLAGE) logo. It doesn’t do this all the time in a consistent fashion - but it happens at least a couple times a day.

I deleted and repaired the lock, but it is still doing the same thing. I also installed the exact same lock in another location and it is NOT behaving the same way.

Any thoughts on how to troubleshoot?

1 Like

RB,

Just wanted to say thanks for this code and for the handler. This is wonderful :slight_smile: The tech support is also amazing !

2 Likes

Hi @RBoy and @maddie , quick question?

I’ve been using LUM for a while with my Iris 3405-L keypad (using your Enhanced ZigBee Keypad Lock DTH), but I just noticed that the code I’ve always used now doesn’t work and I get the error “Invalid user code detected…”.

I deleted all users and codes, and kept just the one we’ve used in the past, and while watching Live Logging after tapping Done in LUM, I saw this message:

Found attribute ‘invalidCode’ on ST Home Monitor Keypad, enabled support for invalid code detection

What does that mean and how do I get this working again?

I just checked and it’s working fine here. That attribute is to support legacy device handlers and is only used to log (or not) messages. If it was working and then stopped then it’s either a device or usage issue. Assuming that you’re pressing the buttons in the right order (each keypad is different, for the 3405-L it’s enter the 4 digit code followed by the On or Off button), likely one of the buttons isn’t being registered or is being registered multiple times (bouncing) causing the device to send an invalid code.

I set up a second user and that one works fine. It’s just the user code in entry #1 causing issues. I’ll try changing the code to a different number to see if that helps since I didn’t try that last night. Also, is there a way to clear this attribute value or will that reset?

image

Hi, new to all of this but have 3 Schlage Zwave locks and cannot get them connected into SmartThings ! tried resetting, repairing, etc etc and nothing works.
maybe a stupid question, but does this lock device handler make it easier or make it defiantly connect ?

Device handlers come into effect after the pairing is complete. However if you have old unused device handlers installed it could cause issues due to a bug in the platform where it marks unused device handlers stale. See this topic for details. You should try to exclude your locks (resetting them is not the same as exclusion) before trying to pair them as explained on this post.

@RBoy / @maddie I’m seeing the same issue now as well. New Schlage Locks @ new location. Had these same locks at previous location, and never saw this.

Anyone find a solution here? I get a double notification for xxx door opened with yyy UserName, followed by opened with Master Code. Which it certainly wasn’t, as I have no clue what it even is.

I tried setting all locks to max users, and running clear codes, and then adding the set of users back. Same thing seems to occur.