[RELEASE] Lock User Management (LUM)

I have Schalge Connect. I disabled AutoLock in The LUM, and disabling used to work for 3 years. Now, it seems LUM Autlock after 255 seconds even I disabled AutoLock in LUM “after” I updated the latest handler and SmartApp from your Website, and it is not working. Is there a bug in the LUM? or something else?

@rboy team curious since echospeaks is no longer used is it possible to update the notification section to incorporate the use to toggle a switch or sensor when a door is left open. As of now the text does work but would like to get annoucements back I’m now using virtual contact sensors when triggered signal alexa to run a routine to send an announcement on all my echos. I use webcore and that does work and I can build others just figured since your app has a trigger type notification maybe that would work. Just a thought.

Recently my Schlage lock has been locking when the door is open, this is THE MOST ANNOYING thing in the world. I’ve never had this issue before. Now im in the LUM app and I don’t see where it even knows about my open/close sensor. I thought before you used to have to tell it it had one, and it would use that to detect if the door was open and NOT lock it.

1 Like

I have exact same problem too! It’s extremely annoying! I have Schalge Connect. I disabled AutoLock in The LUM, and disabling used to work for 3 years. Now, it seems LUM Autlock after 255 seconds even I disabled AutoLock in LUM “after” I updated the latest handler and SmartApp from Rboys Website, and it is not working. Is there a bug in the LUM? or something else?

I answered your question on the other topic. LUM doesn’t configure auto relock in seconds, only minutes. It’s something else that’s interfering with your lock.

It’s in the Door Open/Close Actions page. On popular request from users we’ve made the door sensor optional. If you’ve selected it then it will check the status before relocking, if you haven’t selected it then it’ll relock after X minutes as configured.

LUM works as configured by the user. I would recommend checking your setup and reading this post for more details:

1 Like

I remember seeing “Door Open/Close Action” page in Classic App. But I no longer can see this in New App even I updated the latest SmartApp code. Where can I find it in New App? TIA

I think I found it, when I arrived on the "Door Open/Close page nothing was selected here for sensor. Selecting that item it sees three sensors, but wouldn’t let me select the one I needed. However when I backed out it populated the right sensor on its own without selecting one. So, haven’t tested but it will probably work now since it show the right sensor.

I thought it used to be possible to run a routine based on the user code entered. I’m not seeing that as an option, only the option to change the mode, turn on switches, etc. Were routines removed?

Thanks.

Routines dont exist anymore, only Automations and Scenes… Bith of yhose, like STHM are not natively accessible by the Groovy IDE. Im sure that something that will take a total rewrite.

1 Like

Been happily using LUM to control Schlage FE469NX for last few years. Notifications are working fine and are listed in “messages” within the ST app. But under History, it shows “no Activities” within the last 7 days. Any idea why the app is not displaying device history ?

Add me to the list - same issue. Latest ST App, LUM, DH. IDE Event log and messaging working fine. Nothing showing in History in new app.

SmartApps don’t interact with device history. See this post for a detailed write up about how the new app works:

Thanks, very helpful. I can narrow down the missing History details.

In Device Event history, 3 of our 4 devices happily show Historic activity. Only the Schlage smart lock shows “No History”.

In History Page (Device events), there is no historic data shown for any of our devices. It says “No Activities”. I have tried reinstalling the App and toggling the filters as suggested in the other threat to no effect.

Should I be taking this up with ST Customer Service ?

RBoy, I wanted to say ‘thank you’ for your Lock User Management smartapp, and the extensive support you’ve written up here and elsewhere…

After struggling (for months) trying to get my Schlage BE468 to send me user-unlock notifications reliably, your suggestion finally seems to have solved it.

I migrated from the Wink Hub, (b/c they were sounding like they were about to fold), to the SmartThings hub (large base, and wide community support). However, this one lock of mine wouldn’t play nice (although my 2 other Schlage locks worked fine) with SmartThings.

Your apps package / device handlers almost solved the problem, but I still had unreliable results at getting notifications.

I installed the Aeotec Repeater/Extender V6 which didn’t help.
I installed the Aeotec Repeater/Extender V7 which didn’t help!
Edit: I also tried the HomeSeer FlexSensor with no joy.

I expected to need to add an electrical receptacle to get the repeater closer to the lock, but first I tried the repeater that you recommended, the Remotec ZRP-120NA. … and It works!

Maybe someone can tell me why it would be different from the others…

It fixed the unreliable ‘add/delete users’ problem I was having, as well as the ‘lack of notifications’ problem.

No need for an additional receptacle, thank goodness.

I don’t have any idea why the Aeotec would not correctly buffer the messages, nor do I have time to figure it out. I now have two unneeded Aeotec Range Extenders… Bah.

So, Remotec, yes. Aeotec, no.

At any rate, thanks!

1 Like

@RBoy I think I am seeing a similar issue with LUM, which I think coincides with ST pulling some of the history from the IDE or maybe some other root cause I can’t think of…

My Front Door lock is managed by LUM (and has been for many many years), and is set to auto re-lock through LUM after it has been closed for 30 min. This has never created a conflict with my then routines and now automations that unlock the door when someone arrives. However as of a couple of months ago, when my arrival unlock automation runs and unlocks the door, a few seconds later LUM relooks the door. I know it is the relock function of LUM doing it, as I have since disabled it and no longer have the issue.

Only things I can think of is something changed in the Nov update to LUM that altered the logic on how and when to check if door is closed and when to relock, or ST pulling history from the IDE in some cases screwed up whatever logic you were using.

I have LUM configured to trigger the STHM Simulated Switch, but it is not working. If I manually trigger the STHM switch, the ST automate is correctly changing the STHM status.

Anyone else have this issue…I am stumped :frowning:

Hello,
How can I sync the iris v3 keypad from STHM to show the state ON when STHM is set to Away and PARTIAL when STHM is set to Stay?

@RBoy installed a IDLock 150 with a Zigbee module.
Then I added the zigbee module with the QR code + add device in smartthings.
And now I added the LUM smartapp, and it says “no lock found”.

Then I even tried adding the RBOY device handler for Z-wave lock & alarm to the paired zigbee module in smartthings.
Now it shows up as a lock, but nothing works.

Do I need another device handler for the IDLock 150 Zigbee module?

Hi everyone,

I tried searching smartthings forums, but hoping to find results by showing specific posts does not seem to work.

Anyhow, on to my problem:

A few weeks ago, my Schlage BE469 locking mechanism broke down. Under lifetime warranty, Schlage sent another BE469.

I believe I deleted the original handler and smart apps before I installed my new Schlage.

I don’t think I changed the programming code for the new Schlage. I went straight ahead to install a new device handler and the rest of the associated smart apps.

Now here is weird part: I have 3 permanent users set on my LUM (v07.15.03)

The person who uses the keypad everday the most is a custodian. But my SMS text tells me that the “FRONT DOOR was unlocked by Master Code via keypad.”

"Master Code"?

I don’t think I ever saw this phrasing before.

Should I have changed the programming code? Did my lock get hacked?

hbs

@RBoy – I’ve been a user of this LUM for about a year now and love it. I’ve seen a lot of talk about Groovy IDE support going away as Samsung Smartthings transitions. What does that mean for this smartapp and other RBoy smartapps in the catalog?

I also hear a new hub feature will be local code execution, does that play into anything here?

Thanks
Chris

1 Like