[RELEASE] Lock User Management (LUM)

So just a note for users (thanks to @Tyler for the clarification). If you’re on the v2 hubs please use the custom device handler for now. The bugfixes to the ST Stock Handler will only be pushed to folks on the v1 hub automatically (since they run on the cloud). v2 hub users will get the patch with the next firmware update (the device handlers are bundled into the firmware so cloud patches aren’t automatically pushed) (not sure when the next firmware will be pushed yet), until the next v2 firmware update please use the custom device handler or manually install the Stock ST Device handler from the ST github page.

Thanks, this makes sense and glad we figured it out. So far so good. Although, I am not home to do any testing.

1 Like

I’ve just installed the Door lock user code management SmartApp for the first time and it errors when I run it at the 2 lines ‘log.trace “The date/time on the hub now is ${(new Date(now())).format(“EEE MMM dd yyyy HH:mm z”, location.timeZone)}”’ (these are lines 892 and 1049 in the code). The error is “java.lang.NullPointerException”.

If I comment out the 2 lines, the code runs ok and i can install the SmartApp on a Schlage lock… Presumably it’s a problem with the date or timeZone functions.

Running on a V2 hub.

Very odd and yes I would agree, maybe it a temporary glitch in the platform. Try again after a while and it’s still showing the error I would report it to ST support (with the line of code).
It’s working fine with the v1 hub here.

I just installed the multi-user version and custom device handler yesterday, and I have one issue. I didn’t find any reports of it from searching, so I apologize if it’s been covered.

I have four users set up. When I select “Click here to define unlock actions for {User1,2,3,4}” it shows “Setup unlock actions for each door for user {4}” and “Define specific unlock actions for {User4}”. Basically, no matter which user I select to define unlock actions for, in the define screen it always populates with user 4. Furthermore, it seems that the settings for the user unlock actions are only being applied to user 4, so when users 1,2,3 unlock the actions are not taken. Hopefully this makes sense, let me know if more explanation is needed.

Yes that’s a bug with the ST Android App . It works fine with the iOS app. Please report it to ST and let them know it’s an Android specific issue. If they want more details from you can point them to this page How to pass parameters in href?

Reported, thanks. Now I just need to see if I can get my hands on an iOS device to get things set up until it’s fixed. I wish they gave us a way to modify installed SmartApp parameters directly through the IDE…

EDIT: As a workaround I changed number of users to 1, and set up the user overrides for user1, then opened the SmartApp again and set users to 2, then set up the user overrides for user2, etc. Looking in the SmartApp info in the IDE, this appears to have worked, but I won’t know for sure until I get home after work.

1 Like

That’s absolutely correct, Android’s bug is when you click the link it passes the details of the last user on the page, so that’s an awesome work around.

1 Like

I wanted to use this for work with a few employees. Is there a way to schedule certain codes to only work m-f 9 to 5?

Yes, see the first post.

just sent payment, can’t wait to try your apps. Looks like you do good work around here!

Got the lock management and custom device type all setup with ease and working great, very cool!

1 Like

Is anyone else having an issue where the app loses all settings each time you open it?

I am using a first gen ST hub, a Kwickset 99140, and version 4.1.1 of @RBoy 's multi user code app.

I can go in and program a few lock codes, they will write to the lock and work for a bit, but when I go back into the smartapp to add a new code or anything else all the settings I’d input are gone and I have to start from scratch.

I’d report it to ST support. There was another thread with similar issues users were facing where the internal variables in the app were wiped clean. Try deleting the app and reinstalling it (code too and start over), see if that may fix the issue.
What phone are you using? Unlikely it’s a phone app issue otherwise you might see it all over the forum.

I’m using an iPhone 6S.

And by deleting and reinstalling the app you mean deleting the multi user smartapp, right?

Yes, delete the code too and start over just incase.

What is the logic for the lock jam/stuck alert? I’m getting this notification when the lock is fine.

As mentioned earlier none. It’s done by the lock the app just reports it.

1 Like

###Multi User Lock Code Management - Version 4.2.0

  • Added a heartbeat system to improve the reliability of the scheduled codes to workaround for the issues folks are seeing with the broken ST platform timers
1 Like

Hi, My lock (yale keyfree) is reporting code 1 or code 2 used in the recent activity section but the user lock manager shows 0 usage for both codes and never fires of the routine I have associated to each of those codes either. I tried the standard device handler and the one given here neither fixes this. Any ideas?

You’re not using this app, it doesnt’ track usage. Wrong thread :slight_smile: