[RELEASE] Lock User Management (LUM)

The re-locking immediately feature is still not working. If you could give me the option of inputting seconds instead of minutes I think I could get it working.

I read the whole thread and don’t think i saw an answer- couple general questions-

First, from experimentation it SEEMS if i edit one code or setting that it wipes all the codes and rewrites them all. Am i following correctly? Is there anyway to set it up so it only messes with the slot that has changed and doesn’t do anything to the other slots? That would at least make it safer to fiddle with a pin code(s) remotely. I could delete/edit/whatever to slot X without effecting the other 6 codes. At worst i’d lock out one person and not my whole family or a random subset thereof.

Second, Is the app supposed to be confirming that codes got properly set up? It doesn’t appear to as at times it misses a random one of the 7 codes i have set. Pretty big issue since every time i make a change i’d need to be home to test all 7 codes to be sure none got fubared. Can things get updated anyway to confirm things? Seems it is possible from at least one other lock code app which does confirm and retry the faulty codes to correct any issues. It requires a few lines of codes to get added to the device type and then having the app ask for the codes to ‘get read back’ or something like that. I think reading this thread there’s a mention of no ability to read back but seems some changes to the device type code could fix that.

That did the trick, thanks!

1 Like

Michael this SmartApp is designed to work with the stock ST Z-Wave Lock device, so no customizations to the device can be done. You can always tweak the app for your own installation.
The architecture is setup to resend all codes each time, this it the only reliable method after much experimentation since the base ST device type does not support read back yet.
The best solution to your issue, as mentioned in the 1st post, is to find the ideal programming delay for your lock and this varies for each person’s setup and configuration and layout for each lock. Some folks have success with 5 seconds and others 30. 15 was the most common hence the default.

Just to clarify for all users, there is NO connection between this SmartApp and any specific SmartDevice or any lock. It works with ANY SmartDevice/Lock that supports remote codes (currently ST ZigBee SmartDevice doesn’t support remote codes). The questions and solution above in relation to FE599 were related to a different thread and nothing to do with this SmartApp.

This SmartApp works with the stock ST Z-Wave SmartDevice which works for all Z-Wave locks that support remote codes.

A couple of users have reported that after a few days the code check/updates stop working, this is happening because of an issue with the ST platform where the scheduled timers stop working a some users (don’t know why some and not others). I’ve put a patch in the code to work around this ST bug, essentially everytime the mode changes (e.g. Home to night or away etc), the app kick starts the scheduled timers again.
However if you’re facing this issue please report it to the ST devs here:

Thanks. I read the the first posts and i’ve tweaked it to best suit my setup but it’s far from ideal in general to not confirm.

Networks change over time so the timing could constantly need to be changed. And if someone happens to flip a z-wave switch (locally or remotely) then the timing one picks can get imploded. Never mind if someone happens to use the lock in the middle for the 1-2 minutes of sending codes.

I’ve been using my lock for 5 years now- previously used vera and i regularly changed codes with that and never had a code get fubared in those 5 years. Sadly can’t say the same with ST. Much not your app’s fault obviously but still that’s the reality. Fingers crossed they address the issue when they roll out their official lock code manager.

Hi there RBoy! You told me today to make an account here and to update my progress.

I reinstalled your app, and the codes were resent. The issue that occurs is my Schalge lock and STv2 will work for a day or so when I resend the codes/schedules to my lock. Then it just stops sending the codes/schedule to my lock. It seems to happen overnight because it remembers to delete the codes the day before but does not write them back the next day (I codes to be send 8AM-5PM M-F).

I’ve noticed since the last ST update, the lock is sometimes slow, or doesn’t even tell me via the ‘messages’ on the ST app if the door was locked or unlock or who used their code. Sometimes it works and registers, but sometimes it doesn’t. It worked fine on Thanksgiving day, as I’d show my family how it would respond and how I could unlock from my phone. As of today, it does not unlock/lock from my app, or its very slow in doing so (more like 10% chance it will work).

Now we did have power shut off during a storm after Thanksgiving (when the lock became worse and worse in responding), so I did the following:

Unplugged my STv2 Hub for 5 or so minutes and waited until steady green to do the following:

Removed/Reinstalled the lock app
Removed/Reinstalled lock from my Z Network

Now for today, I reinstalled the app with the newest version, and the codes were sent and all is well. When I used one of the codes, it worked, but ST did not see it as it happened. It just unlocked the door and the activity did not show that it was unlocked, and in which, did not tell me via SMS that it was unlocked.

I just tried it again after a few minutes since the last time I tried, and it worked and show me via the app and SMS. But I tried to unlock the door from the app and it did not work. If I manually lock it, it thinks its still unlocked. I have the Schlage lock to auto-lock after 15 seconds, I’m not using any App to do so, could that be the cause?

I know I rambled on, but I’m fairly new to all HA, and don’t know the best way to explain myself.


This thread is related to the door user management app, please post comments related to the Schlage lock smartdevice here:

As for the door mgmt app quitting after a day or so as I had explained it’s related to the ST platform timers dying. While there’s a temporary patch I’ve put in the latest code that reboots the timers each time the mode changes please report the issue here to the ST devs so they can monitor/fix the issue:

The ap did not upload the codes to my schlage Camelot with alarm??

Auto lock and unlock not working for me, using latest code.

See live logging to see what’s going on. Most likely it isn’t receiving notifications from the door sensors.

Change the delay and set it to what works best for your setup. Make sure you lock is not more than 15-30 ft from the hub otherwise use a repeater.

I did no difference. Seems it wiped out the standard code though. It seems like its trying to keep me at 4 numbers when all the codes i used were 6

I did no difference. Seems it wiped out the standard code though. It seems like its trying to keep me at 4 numbers when all the codes i used were 6
It also now says jammed all the time but before i added this code it never showed jammed

Using several repeaters and have quick action times. I looked at log and ST keeps sending delete lock codes to the device?? So I assume that’s why none of the codes work. Also, it now shows jammed a lot yet it never showed that before and would at least lock and unlock with simple ST program. Also, this morning once I arrived and finally was able to get in my door the door kept on opening the lock even when I manually closed it or used the ap to close it. I know your stuff works I see the comments but right now I’m lost as to why this is going on.

The app is basically a Set if rules which execute based on event notifications it receives. So for some reason the app is receiving a whole bunch of incorrect events.

The question is why is ST or the device sending it all those notifications.

First up try to repair your z-wave network
Second make sure your code length matches the lock code length you cannot use a 6 digit code on a lock that is configured to only work with 4
Third check your activity log, is the door sensor sending it door open events and you’ve configured the app to send a door unlock command then it receives a door open event
Fourth for jam events again it’s subscribes and responds to what it receives. Why is lock sending Jam events? Does the lock need to be reset.
Finally try to delete the smart app and start over with a fresh install maybe it’s corrupted (this more likely with SmartDevices than SmartApps)

Essentially the question to ask is what’s different about your setup/ecosystem who his causing all these events to be generated (door jam, door open etc) when they should not be. The app is just responding to them.

Maybe your lock and sensors need to be reset. Some Schlege locks get stuck in a loop (see the IDE live logging and search this forum for details)

1 Like

There does seem to be something funny going on with the latest version of your app, RBoy. I had been using a version from 11-21 and I updated to the latest version last Saturday.

The next time I left home, I found that I was locked out when I tried to unlock one of my locks. What I found was that my codes had been wiped. I didn’t have a lot of time to experiment, but what I saw in live logging when I reentered 2 codes was codes getting sent to the locks and then immediately deleted. Looked like messages getting out of sequence, so I cranked up the delay time to 60 sec. and things started working again. My delay previously had been set to the default.

If I have some free time, I’ll do some experiments and capture the logs. The thing is, that 11-21 version of the app had been rock solid since the day I added it.

By the way, don’t get me wrong, this is an awesome app.

1 Like

I was experiencing the same issues so I had to stop using the app. Codes kept getting deleted.

The jam event is a subscription event. If the app subscribes to it you get a notification, not all apps use it, this one does (the basic device doesn’t). If you don’t want the Jam event just turn the option off. That’s an issue with your lock sending Jam events. I’ve seen locks send Jam event if the lock is opened too slow or closed too slowly also. It’s very lock dependent, nothing to do with the app. The App just reports what it receives.

Coming to your codes, any code that isn’t used, as a safety measure it will send a delete command for that slot. So you have configured 8 slots and only entered codes for 2 of them, it will send the codes for those 2 and delete the remaining 6. The delay depends completely on your setup. As you can see from the above post @tyuhl found that 60 seconds worked for him. In our labs 5 - 15 second work best for us. Each setup if different, depends up on the layout of the house, devices, distance walls, reflections etc etc. This point has been repeated multiple times on this thread. There is no one answer for everyone. If the codes aren’t being programmed try different delay options, try 5, 30, 60, 120 seconds. See what works for you.