[RELEASE] Lock User Management (LUM)

Thanks for clarifying, Rboy. #1 was not updating in my app for a few weeks and was just displaying the guy face down in the pool. #2 I don’t use. #3 has worked well as long as the history service is working. (i.e. sometimes doesn’t update even after pulling down the screen to refresh). History service sometimes gets truncated in time to a few hours too. #4 has also worked well.

Lock User Management works GREAT!!

As a SmartThings and Schlage Connect owner, I got screwed by buying two of the same Schlage Connect locks a few years apart. The first one worked fine (with limited functionality) with the old SmartThings app, however, once I added the new lock it would not show up with the same functionality. I tried changing the device type, etc. as others have mentioned. Didn’t work. The upgraded/new app would not let me add codes for the new lock.

After a fair amount of research, kept running into the RBoy LUM SmartApp. Decided to give it a go and 30 minutes later both of my locks are working seamlessly. All functionality worked as promised and I even used the custom Device Handler to provide more functionality in the device interaction screens beyond the LUM SmartApp options.

Coulnd’t be more pleased and well worth the price of admission.

3 Likes

When my Smart Hub goes offline for a while and then turns back on, all the notifications I get on my phone are time-stamped at the time the Hub restarted.

Is there a way to get LUM and other Rboy related apps to show actual time stamps after the Smart Hub reconnects to the Internet/Samsung server?

hbs

Did you ever figure this out or get an answer? I had asked about this a while back, before migrating to the new app. I just assumed it would be even more impossible with the disassociation of STHM and ability to be automated with smartapps. This is actually one of the things holding me back from making the keypads part of my standard security setup. The primary reason I would want keypads at my doors is to indicate if the house is armed and if it’s ok to open a door. I have kids, so without that feature they’re sort of useless. I really wish ST would open up STHM bc I know that’s the key to a lot.

I did not. I’m not sure if that’s because there is some obvious fix or setting that I’ve overlooked and people just thought I would eventually realize it on my own…or if it’s because it’s not possible and people are sick of talking about it. :slight_smile:

This week is set to be a slower work week, so maybe I’ll have some time to do a little more reading/research. I’ll post if I figure anything out…

@leonardo In the STHM arm/disarm post, at the bottom it has a link on how to do a two way sync with a keypad.

Thanks. I actually just stumbled on that post myself and was messing with it. I’ve come to the conclusion that my keypads are the most frustrating part of my setup. I have 3, and I can’t get any of them to function as they should. Even before worrying about syncing the STHM status, I figured that I would just make sure they were functioning by having them turn off a light switch when I “unlock”. Even that didn’t work. One keypad (Xfinity HFK) accepts my code, and beeps as if it worked, but nothing happens. The other (Xfinity 3400-X) throws an error on my phone saying that in is an invalid code (same code, so yes it is valid). I’m stepping away from them for the evening, or I might throw one against the wall and regret it tomorrow :slight_smile:

does anyone know what might be causing my keypads to now throw an error that the user code is invalid? The codes are not invalid, they are configured by LUM. The DTH for the keypads, as well as the Smartapp are all running the latest versions.

Thanks for the link. It doesn’t really solve for complete sync. For example, I need my keypad to update to “OFF” if I disarm my system through the ST app. But either way, if I’m needing to use webcore, I’m able to do that utilizing the virtual switches that I setup for LUM. I also needed to add another automation in ST “if STHM changes to disarm, then set keypad to disarmed”. Easy enough. I just wish I didn’t have to configure all of this between 3 or 4 different smartapps and virtual switches.

Can you tell me how I can disable auto lock please on a Yale Keyfree door lock? What I need to do on occasions is unlock the lock remotely and keep it unlocked until I choose to re lock it, this could be after 1 hour or 6 hours, it would be a random length of time that I cannot determine with a regular lock/ unlock sequence.

In the previous Smartthings app, there was a setting where I could unlock the lock, this would override anything I had set in my automations and the lock would stay unlocked until I re locked it, I cannot find anything in the new app to do this. I use rboys lock user management and Universal Enhanced Z-Wave Lock but cannot find a setting to do this as I need to.

I have been onto Smartthings and Yale and neither have helped much, Smarthings say my module is old and Yale want me to purchase a z wave 2 module which I am reluctant to do until I know it will do what I want, plus my module 1 worked perfectly until the new smartthings app was implemented.

All of my automations including my automations ‘lock door’ were migrated from the previous app and have not been changed by me or anyone else so I can’t see how that would change anything.
Hopefully you can help, thanks again

Can someone who uses webcore with the LUM device handler tell me how I can find out which lock code in webcore is assigned to the lock code I have in ST. I am trying to connect virtual switches to each user-code, which would trigger Alexa to announce the usercode that unlocked the door, since echo speaks stopped working.

EDIT: Forgot to mention it’s a Schlage BE469.

Hi there. Please note that SmartApps run concurrently and are not dependent on each other. What that means is one SmartApp cannot “override” another app, they all work independent of each other. If you have two SmartApps which provide an auto lock feature, then they will both operate simultaneously and can therefore create expected locking behavior. Hence it’s a good idea to verify that SmartApps features don’t conflict with each other or execute at the same time.

There are two types of auto lock:

  • SmartApp based auto lock, for example what LUM and RLA offer through the Door Open/Close Actions page
  • Hardware based auto locks, these are built into the lock hardware, some are configurable (e.g Yale), other are fixed (Schlage, Kwikset)

It’s a good idea to check that both SmartApp and Hardware based auto lock aren’t enabled at the same time to avoid conflicts. To configure Hardware based auto lock you can do it directly on the lock itself (refer to the lock manual) or for supported locks you can use the Enhanced Z-Wave Lock device handler to manage them through SmartThings. If you’re upgrading from the Classic app to the new App be sure to update your device handler and follow the instructions here to clear the cache for the new controls to show up in the new app.

3 Likes

I have Schalge Connect. I disabled AutoLock in The LUM, and disabling used to work for 3 years. Now, it seems LUM Autlock after 255 seconds even I disabled AutoLock in LUM “after” I updated the latest handler and SmartApp from your Website, and it is not working. Is there a bug in the LUM? or something else?

@rboy team curious since echospeaks is no longer used is it possible to update the notification section to incorporate the use to toggle a switch or sensor when a door is left open. As of now the text does work but would like to get annoucements back I’m now using virtual contact sensors when triggered signal alexa to run a routine to send an announcement on all my echos. I use webcore and that does work and I can build others just figured since your app has a trigger type notification maybe that would work. Just a thought.

Recently my Schlage lock has been locking when the door is open, this is THE MOST ANNOYING thing in the world. I’ve never had this issue before. Now im in the LUM app and I don’t see where it even knows about my open/close sensor. I thought before you used to have to tell it it had one, and it would use that to detect if the door was open and NOT lock it.

1 Like

I have exact same problem too! It’s extremely annoying! I have Schalge Connect. I disabled AutoLock in The LUM, and disabling used to work for 3 years. Now, it seems LUM Autlock after 255 seconds even I disabled AutoLock in LUM “after” I updated the latest handler and SmartApp from Rboys Website, and it is not working. Is there a bug in the LUM? or something else?

I answered your question on the other topic. LUM doesn’t configure auto relock in seconds, only minutes. It’s something else that’s interfering with your lock.

It’s in the Door Open/Close Actions page. On popular request from users we’ve made the door sensor optional. If you’ve selected it then it will check the status before relocking, if you haven’t selected it then it’ll relock after X minutes as configured.

LUM works as configured by the user. I would recommend checking your setup and reading this post for more details:

1 Like

I remember seeing “Door Open/Close Action” page in Classic App. But I no longer can see this in New App even I updated the latest SmartApp code. Where can I find it in New App? TIA

I think I found it, when I arrived on the "Door Open/Close page nothing was selected here for sensor. Selecting that item it sees three sensors, but wouldn’t let me select the one I needed. However when I backed out it populated the right sensor on its own without selecting one. So, haven’t tested but it will probably work now since it show the right sensor.

I thought it used to be possible to run a routine based on the user code entered. I’m not seeing that as an option, only the option to change the mode, turn on switches, etc. Were routines removed?

Thanks.