[RELEASE] Lock User Management (LUM)

Thanks, but I’m confused… so what can be causing my issues, if my mesh network is strong and my locks are in close proximity to zwave light switches?
I already tried doing zwave repair.

.

Can’t help you much there. I had similar issues with my Schlage z-wave lock and open/close sensor. They kept dropping off even though they were 15’ from the hub. But it turned out in my case the z-wave signal could not compete with 2 concrete cinder block walls. I installed a z-wave light bulb in a direct line of sight between the lock and the hub and I have been stable ever since (maybe the occasional glitch).

As maddie suggested I did delete my lock from the network, added the new light, then re-added my lock and finally repaired my network just to be on the safe side. Sadly no easy way to actually see what is connected to what in the z-wave world.

I am also using the standard z-wave default lock manager DTH. It does everything I want except code expiration so I am thinking about it but they only have an all or nothing price so I have not made the purchase yet. I don’t need any of their other stuff that comes in the “package”.

another happy customer!

i was super unhappy with the shortcomings of my door-lock and management of it via the smartthings apps (repeated server errors for all other solutions). got this and now i can remote program codes for my schlage connect dumb z lock and life is good. don’t balk at spending a bit on this; it is completely worth it and much cheaper than a new lock system!

4 Likes

@visonpilot, Have you tried the more advanced functions and are they working? Notifications are only sporadic for me, no defined custom actions are working, and the locks are not respecting restrictions based on mode of the house (Home, Away, etc), as they should be based on programming of the SmartApp.

I haven’t tried any conditional functions yet… waiting for the family to get used to the new codes (personalized codes and remote programming were my main goal here) however I can say the notifications are working. hub v3, Schlage connect, FYI, not sense or any advanced model, running smart things app (new and old) on android 9 phone.

Chalk me up to another happy customer. Working great for me here, notifications and actions. I use “presence” users since I love that I can limit the cleaners code to be used only when my spouse is at home. It works perfectly and also the actions associated with them.

I did a quick test here for the “modes” based users (using home and away modes). The users activated and deactivated when I changed modes, also got a notification and actions were executed (turning on lights).

If you’re seeing sporadic notifications it sounds like a zwave mesh issues. Maddie gave me some great tips to get my mesh sorted out similar to what michael_edmonds said above and I’ve never had an issue since (key thing for me was to move the hub away from the lock into a different room and rebuild the mesh). Or maybe you may just have a bad schlage lock like these folks figured out.

1 Like

I am using your lock use manager. 07.09.05

It works great with one exception

I am now using the new st app and the new st shm.

I have your lock app setup that when the door is unlocked via the keypad it is supposed to disarm the shm.

I have your app set to

Disarm Smart Home Monitor

Set mode to home
Send me a notification

But it does not.

Every time the people enter via the keypad the alarm goes off.

Also I tried setting a code to be enabled only on a particular day instead of permanent, and that did not work either.

Do I need a different DH?
Would a zwave repeater help?
I have a schlage lock that works very well with st except for the above.

Can u help.

Hi there. The new app STHM does not support direct control via SmartApps as yet.
However check out this great tip to control STHM via LUM actions using physical or virtual switches

Hi just trying to understand how this app work and if it’s what I need, I live in the U.K.

I have a conexis l1 door lock which at present I can use the Yale app to programme cards, key fobs, use my phone via the app and send people keys so they can unlock via the same app on there phones , keep seeing mention of key pads ,

My question can I do all the above and if yes how? Or do I need to have a key pad in order the grant people accesses via a code

Thanks

Usually Keypad codes and RFiD codes are programmed and reported in different ways.
To simplify it , this app works best if your lock can be programmed over zwave. (eg a lock with a keypad to enter codes).
If you have a lock which is programmed directly or using a native app and reports code usage over zwave (eg locks with RFiD fobs) then use the sister app which is designed for that purpose as explained by @maddie in this post:

I have two Schlage deadbolts setup in SmartThings. Can lock & unlock ok.

Installed the smart app to program users…1 lock works great, other lock doesn’t and keeps failing with “user code not added”

Both locks are within 3 feet of a repeater
Have tried the clear codes process

Thoughts?

Welcome to the ST Community.

If you still can then it may be worth undeleting your post.

As you managed to resolve the issue it may help others who possibly experience a similar scenario.

Thanks! :blush:

I haven’t resolved it – did I click something incorrectly? Sorry this is still my open question. Thanks.

@RBoy - not sure I need access to all smart apps and DTH’s you have. Can one simply buy the LUM rather than the whole thing? If so, is the cost different?

Hi Paul. That was not in reply to yourself. There was another post after yours that was deleted by the user. As it was deleted and they did not undelete it I think the system attached my reply to your post. This is a dumb thing to do but maybe it takes the last comment above even though I replied to a specific person.
The post I replied to was updated/edited then deleted by whoever it was stating the way they fixed the issue. Sorry but no idea why it then tagged your post in the reply.

Works perfectly thanks!

Hello, I have a problem with the “delay running action”. I set it to 1minute but “change mode to” execute immediately and it don’t wait the 1 minute exiting delay before switching the mode. I use a Centralite 3400 Zigbee Wireless Keypad.
I check an I run the last version of the app and all rboy device handler.

Hi RBoy, I need to integrate the Kaadas K9 with my Smartthings and get codes for each user in the house. Is it possible to do so with your App and device handlers??

It should work, that model supports 10 pin codes and according to the specs it should work with the Enhanced device handler and LUM app to program the pin users. We haven’t specifically tested that model so I can’t confirm if the fingerprint users are reported over z-wave or not. You can always PM me or send our support desk an email. Also it looks like that model may not send notifications about which user was used to unlock the door.

@RBoy & @maddie:

As a long-suffering and recently liberated Vera user (from 2008!), discovering and implementing your lock solution just made me… happy.

Elegant, simple and resilient (re-tries programming! with clear comms!). Schlage, Kwiksets, all worked flawlessly.

Seriously, thank you :pray: .
.//A.

2 Likes