[RELEASE] Lock User Management (LUM)

Hi all!

Been using this for the last almost 2 years with zero issues but last week I stopped receiving notifications when door codes are used. I’ve tried updating to the most recent version but the problem is still ongoing.

I’ve tried going into notifications and enabling text notifications but still no luck. Is there a specific way you need to enter your phone number? I use to just get standard notifications but those have stoped and I’m not seeing an option for those in here.

Any Ideas?


It sounds like you may be using an old custom device handler for your lock. There were some changes deployed to the platform/hub firmware last week which required an update to custom DTH’s. You can either:

  • Switch your lock to use the standard ST “Z-Wave Lock” DTH, or
  • If you want to continue using the custom device handler, update to the version that was released a few months ago in anticipating of this update.

You may also want to check if you’ve got notifications enabled:

Thanks for the reply Maddie!

I realize I only updated the RBoy Smart Apps code but not the Device handler, maybe thats the issue.

I’m doing that now, but I’m a bit confused at the last step. It says

“Open the Device page on your phone using the Classic ST app, check/update your preferences (little gear icon on the top right) and tap “Done” or “Save”. Now tap the “Refresh” tile (with the circular arrow). If you skip this last step the updated Device Handler may not work properly.”

I’m wondering where I find this device page? can’t find a page with a little gear icon other than just the menu sidebar. I’m sure its probably obvious but I can’t seem to find it.


I’m really excited about this app! I previously had no idea there were 3rd-party apps to enhance my device’s functions.

Question 1
I’m trying to set up push notifications for when the door is unlocked. I’m in ST Classic -> Lock User Management -> Notifications. For “Play notifications on these devices,” it’s telling me “You can’t currently add this.”

If I go back to My Home in the ST Classic app, my phone is listed. (But I don’t see a way to add it as a Thing in the new ST app, if that’s relevant.) What do I need to do to make Lock User Management recognize my phone as a device to send push notifications to?

Question 2
Can I set up an auto-lock without a door sensor? I want it to lock 5 minutes after it is unlocked.

I’m in ST Classic -> Lock User Management -> Door Open/Close Actions. Relock Door Automatically is toggled on, and Relock After Unlocking is set to 5.

Question 3
Can I see a detailed history of code use?

Thank you!

1 Like


And push notifications when the door is locked too?

Im able to have it announced that the door has been locked but when we’re not home, i would like to know when the kids go home and unlocked the door and door locked after them (after 2 minutes).

You need a compatible Text to Speech audio notification device like a Sonos or Echo Speaks (Alexa) paired to your hub to announce the notifications.

Yes, you’ve done it correctly, the door sensor is optional. Please ensure that your lock is within 20 ft of a buffering device to ensure that commands don’t get lost in the mesh. Locks are very sensitive to this.

If you’re using the new RLA SmartApp we have added a page to view the last 7 days of user code and lock usage history per lock.
If you’re using LUM you can currently find this information in 3 place outside the app

  • If you’ve got SmartLocks installed, then in the History page your can see this information
  • If you’re using the Classic ST app, then open the lock page under My Home -> Things, click on your lock, click on Recently and you’ll find the history of the usage
  • Open the Notifications (Classic) or History (new) page in your ST app and you’ll find the notifications there (it will be from all the apps and not just LUM)

I have a kwikset 916 lock that I have used successfully with a different lock manager that didn’t have the features of LUM. After removing the old lock manager, I installed LUM but cannot get any of my codes to successfully program into my lock - each time it says no response from lock. The lock is less than 10 feet away from both the hub and the router and I have not had any issues with connecting to it before. I have changed the time between codes to 50 seconds (even though I am only adding one and waiting), have uninstalled and reinstalled, have unpaired lock, excluded zwave, repaired, reinstalled. Nothing works. I am missing something but can’t figure out what it is.

EDIT: I tried it again and it confirmed programming. Unfortunately, it still doesn’t work as the codes I programmed won’t unlock the door.

EDIT: I factory reset the lock and now it works. Leaving this in case others have same issue in future.

Yes that’s the right process. We’ve mentioned it on our website also, before installing the app all codes need to be cleared from the lock otherwise the lock may reject existing codes.
There are two ways to do this, either a factory reset which clears all codes or follow the Clear Codes procedure on our website.

I didn’t see that on the website – I apologize. However, I did clear all the codes thinking that may work but in this case it didn’t. Fortunately once I reset it everything works as expected. Thank you again!

/s/ Brian J. Ritchey

Competency is found in one’s character, not in their title.”

1 Like

Hi, I downloaded the rboy LUM app so i could schedule when codes can enabled for specific users but I can’t figure it out. I have created multiple codes for different users but there’s no option to create a schedule when that code can be enabled.

Tap on Select User Type and select Weekly/daily schedule(s) and then you’ll see the options to select up to 3 schedules for the user.

1 Like

Is this the SmartThings app? The attahced image is all i can see. once i click on a specific person/code it
only gives me the option to edit guest name or delete guest. I am wondering if i have the wrong app.

That isn’t the LUM SmartApp, it’s the GuestSmartLocks interface from SmartThings.
If you see the last step of the installation instructions for SmartApps it tells you how to access your installed LUM SmartApp from the Automations page in the SmartThings mobile app.

Great - ill give that a try. I was thinking I probably had the wrong app. THanks!

1 Like

Using LUM with your Enhanced Zigbee Keypad Lock handler and want to know if the door open/close actions only apply to one open/close sensor. I would like all my windows and doors to chime my Iris V2 keypad. Thanks.

I’m having trouble getting this to work. I’m using an Iris v2 with Enhanced ZigBee Keypad. I detect the keypad and the device seems to be working (it detects the tamper switch, etc.). I add LUM and under “Select Lock(s)” I see “You can’t currently add this”.

Hi, I just installed this application the other day and configured it with my Zwave Schlage Connect locks. I’ll admit, I’m new to all this, so I’m convinced I’m doing something incorrectly here.

I connected the locks initially with the default device handler and configured the SmartThings app just to make sure they would lock/unlock from the phone.

Then I updated the device handler to the Enhanced Zwave version from the site(updating via the IDE to make sure it applied to the two locks after adding it), then added the LUM. I did follow the clear codes procedure on the website. I can lock/unlock the locks from the SmartThings “Things” interface still at this point. I programmed 3 users with unique codes, all configured to access both locks. When I program them, it goes yellow at first, then goes green about 10 seconds later, indicating programming to the lock was successful.

However, the codes I’m programming are not actually working on the locks.

I did a clear codes procedure again, and reprogrammed another code for both locks and I get the same result.

I’m going to wipe everything when I get home later and try to attach the locks using the Enhanced Device Handler initially(rather than updating it per the website instructions) and I guess I can copy/paste the LUM app again(although I think it’s working correctly), but is there anything else I’m probably doing wrong?

Thanks for any suggestions.

edit - just in case it matters, the two doors are both near each other(garage and front door). The SmartThings hub is sitting maybe 10-15 feet from each door with clear line of site. I do have a ZWave repeater i can plug in closer, but I don’t think that’s the issue, as I interpreted the yellow/green measure to indicate that a confirmation was being made of the lock code provisioning. I’d assume the code is stored in the actual lock, and that the SmartThings LUM is only doing “provisioning” and notifications and any other automation, not actually doing the authenticating, that’s all inside the lock…maybe I’m wrong.

LUM app can associate one sensor with each lock, so under Door Open/Close actions, for each lock you can select a corresponding sensor and a chime which can be activated.
On popular request, we’re also working on a new SmartApp for door bell chimes and window/door sensor chimes which will allow you to use a single chime for multiple doors/windows which don’t have locks on them.

This is SmartThings way to saying that it cannot find your keypad to use. That means that your SmartApp and keypad aren’t installed in the same location. (some new/migrated ST accounts have a dummy location which is created and if you’ve accidentally installed your device or app in that location it won’t be able to interact with your real location/devices/apps)

The repeater should ideally sit between the hub and the lock so it can buffer messages. See this topic for more details: FAQ: why would I need another beaming repeater if my zwave lock is already close to my hub?
Since you’re seeing green, that’s a confirmation from the lock that it has successfully programmed the codes. Check if the keypad is disabled (i.e. vacation mode), if you’re using the Enhanced Z-Wave lock DTH you can re-enable the keypad using the Classic ST app on the lock device page. Also another very common mistake is that users accidentally install 2 or more copies of LUM (or another app like RLA) on the same lock while testing and don’t realize that they conflict with each other. One adds the code while the other deletes the code. You can verify this with the Classic ST app, open your lock device page under My Home, click on the SmartApp tab and it’ll show all SmartApps connected to the lock. There should only be one instance of LUM (or RLA) connected.

I’ve done some more digging and I think I found the problem. There’s another device handler for the keypad which is getting installed first. It has capability Lock Codes but not Lock so it’s not being found. When I get home I’ll remove the extra handler and reinstall the lock.