[RELEASE] Lock User Management (LUM)

I still see the notifications for my lock codes being added and set, but I do not see any notifications when any of the codes are used.

Are you using / have you enabled the contact address book feature for your account? It’s still a beta feature from ST and can cause random issues like you’re seeing. If you have that feature enabled, contact ST support to disable it.

The app is working fine exactly as it supposed to, it burns the code and disables it after a one time use.

The app states "One time code USED!

Note that when you open and SmartApp and if you click Done it WILL reset the one time codes and reprogram them. So if you’re just “checking” on the state of the code in the SmartApp after using it, do not click on Done as now you’re starting a new programming when you click Done.

Instead press back and come out of the app or set the code as inactive if you don’t want to use it again and then click Done.

Also make sure you’ve done the clear codes procedure the first time you install the device handler or SmartApp to clear the database before using the codes.

Sorry, but the app is not working fine for me.

I cleared the codes from the lock, reinstalled the app, set up a different (never previously used) code as a one time code which also cleared the codes from the lock. Tried the code - which worked - left it for 2 mins, tried it again, without touching my phone/app and it worked again, then again and so on. The one time code is behaving like a permanent code.

Any other ideas ?

This indicates that the lock is having communication issues with the hub, it isn’t deleting the codes after use. Try moving it closer to the hub and doing a Z-Wave repair (also reboot the hub which helps a lot!). It’s working without issue here across 10 locks from 4 different manufacturers. How many active Z-Wave devices do you have? A weak mesh can also play havoc with communication.

The SmartApp sends a delete command to the lock once the code is used. Look at your IDE Live Logs when you unlock the door using your one time code. Look for when the SmartApp sends the delete command check to see if lock acknowledged it (it will be in BLUE). If you don’t see the acknowledgement then that’s the indication of a mesh/communication issue.

Feel free to PM (copy paste) me your Live Logs and I’ll check it out for you. Please filter the messages by the SmartApp only (top row of the Live Logging, select the name of the SmartApp).

1 Like

@RBoy I’m thinking of signing up to your smart apps and device handlers… just want to know first if your app supports the yale conexis l1 lock and more specifically RFID notifications for that particular device?

1 Like

Yes it does, you will need to use the Enhanced Z-Wave Lock device handler, see these release notes:

So I’ve installed the device handler and smartapp… I have a yale Keyless connected on my front door and a Conexis l1 on my back Door… I can’t seem to figure out how to make the RFID notifications work… I’ve reset both locks and tried to set up all keycards / pins again but no joy. Is there a specific way to do this?

If you’re using the RFID tags, then use this SmartApp along with the Enhanced Z-Wave lock device handler (after installing the device handler code I hope you’ve also changed your lock/device to use that custom handler). The below app is used for only reporting/taking actions (since you can’t program RFID tags as yet through ST), otherwise it’s identify to the app on this thread with the exception of the programming part.

Enter the username for the slots and program your RFID tags to use those slots, configure the notifications options and you’ll get the notifications when the RFID tags are used.

Thanks for letting us know that reinstalling the app solved the notification issue. Going to chalk this one up to a platform quirk. Can’t think of any reason why it would suddenly stop working out of the blue.

Thanks for helping resolve my One Time Code issue, and for all your good work with this app.

1 Like

###Door Lock Code Multi User Management with Notifications and Actions - Version 05.06.00

  • Improved speed and resilience to platform issues
  • Improved One Time code resilience and programming
  • Fixed Auto Unlocking of Schlage deadbolt locks while door is open
  • Added support for notifying via text to speech (e.g. Sonos)
  • Added support for Bluetooth locks (e.g. Yale)
  • Simplified the user interface to make it more intuitive

Recommend use the [Universal Enhanced Z-Wave Lock] ([RELEASE] Universal Enhanced Z-Wave Lock, Schlage Lock, Yale Lock, Kwikset Lock, IDLock, DanaLock and August Lock Device Handler with Alarm Control, Notification, RFID, Door Sensor and advanced features) device handler version 03.03.00 or newer for full SmartApp and automatic update notification functionality

1 Like

I tried that and the pin codes work… just not the RFID tags. They unlock the door but I get no notification at all in smartthings. I really hoped this would work. Any ideas?

Open the IDE click on Live Logging, now unlock using your tag. PM me (copy paste) what you see coming from your lock (filter the messages by those coming from the lock device), copy paste. Since folks are using it I’m guessing either the lock isn’t reporting it or you don’t have the right device handler installed.

Looking for a automated routine in the app but not sure it exists.

The Schlage 469NX can be locked with a one button press (SCHLAGE logo) on the keypad. The app allows you to assign a routine to that e.g. Goodbye.

If someone uses their user code to lock the door (rather than the one button lock), is it possible to assign a routine to that ?

Update : Just tested this and it appears that the same routine is assigned whether your lock using the logo or a user code, which is what I was looking for. Just wasn’t clear from the wording in the app.

1 Like

Yes as you’ve seen it uses the Global/General settings for lock both one touch and user pin based locking. However you can override the user pin based locking settings by defining custom actions for the individual user in the user page.

Did the reinstallation solve your notification issue? I don’t see that in your post. Hoping 5.06 will. I rebuilt my whole ST system from scratch on Wednesday - still no notifications. Later today is the first chance I will have to get back to the problem.

I’m still not getting notifications, despite going so far as to reset my ST hub and COMPLETELY rebuild my setup. It was nearly 100% reliable for over a year, but I no longer receive notifications when someone uses a code to unlock.

Can the notification behavior be isolated to either the DH or the SmartApp? I’m not sure how to further troubleshoot. I’m on 5.06.00. @Ron_Lu, did you ever start getting notifications back?

Everything is back to working great for me. To fix my issue I first removed the app, the device handler, and my lock from my my ST hub. I then performed a factory reset of the physical lock. After re-adding the lock to the hub then re-installing 5.05.03 of the app and 3.03.03 of the device handler everything worked again.

1 Like

Check your lock batteries, seen issues with lock not sending notifications to the hub where replacing batteries and doing a Z-Wave repair fixes the issue. Confirm that the lock is sending notifications to the hub - mostly likely that’s the issue. Did you reset the lock itself? If not try that.

Batteries were fresh 7 days ago, now reporting 95% charge level. Batteries were fresh two weeks before that, but dropped below 85% in two weeks so I replaced them again.

I reset the lock itself, I reset the Hub (v2), I even went so far as to delete my instance on the ST servers, delete the app on my phone, and rebuild my ST network from scratch (see my other posts).