SmartThings Community

[RELEASE] Lock User Management: Door lock code manager (create, delete and schedule codes) with automatic lock/unlock, custom user actions and SHM/ADT integration

smartapp_security
smartapp_locks
project_locks
project_secondhome
rboyapps

(Lee Florack) #1659

The 912, in combination with the @RBoy app and DTH, reports the user’s name on the 912’s 'Recently" tab, . For instance, "Unlocked by “George”. It doesn’t report the actual passcode used.


(JIm) #1660

How can I get that info in my own smartapp. The name itself is fine, if not the passcode. I just can’t seem to find the right capability or whatever it is called.


(Mark) #1661

@maddie

When a lock is unlocked the “Recently” tab under my locks shows “Unlocked by Code 2” for example. Would it please be possible to change this so it reflect what has been entered under the Users Config under the App please?
So for example I have set Slot 2 to be Car Keys, the Notification I receive is correct (Lock Back Door was unlocked by Car Keys via rfid) however the details under the Recently tab under the lock itself states Unlocked by “Code 2”, would be great if this also reflected the actual details that are set in the app. Not sur eif this is possible though of course.

Thanks!

Oh one more small thing, could you please change the “rfid” text to come back in capitals please “RFID” in the notifications. I have done so myself but thought it may be nice to have it baked in. TY :slight_smile:


(Head of Support (rboyapps.com)) #1662

If you’re using this app to program your codes it will show the name under the recently tab.

Seeing that you’re using RFID tags I assume you’re not using this app to program your cards but rather the RFID cards are programmed directly the lock and you’re using the following app:

We can continue the conversation in this topic to avoid confusion:


(Mark) #1663

Thanks for the reply.

That is my point though, it does not show the name, it just shows ‘Code 2’ for example yet the notifications do show the correct name as the notification comes from the app of course.

Correct though, the RFID’s are set via the lock, I use this App as I name the slots accordingly, so I unlock the door with a certain RFID tag (‘Car Keys’), see the slot/code it takes in the app and rename the slot accordingly. It works as it should and the Notification states the name I have set however under the ‘Recents’ tab under the Lock it just states ‘Code 2’ as opposed to ‘Car Keys’ Also, I am using this App as opposed to the other as I have a KeyPad but I will be starting from scratch once all is working correctly so may revert to the other App for just the locks which are Conexis L1. Still think I may have the same issue though.

I am not 100% sure but have a sneaky feeling that it may have displayed correctly under Recents in the past, perhaps the last update a few days back changed something. I will try to remove the app and add it back again.


(www.rboyapps.com - Make your home your butler!) #1664

Mark as @maddie mentioned, if you’re using this SmartApp, the Door Lock Code User Management to program your locks, the user name will show up in the Recently and Notifications tabs (it syncs up the names with the DTH while programming the locks).

However, you are not using this SmartApp rather you’re using a different smartapp which works differently. That SmartApp cannot put messages in the recently tab since Recently messages are only controlled by the DTH and since you’re programmming your codes outside of ST the DTH doesn’t know the names and hence they do not show up in the Recently tab when used. Instead the smartapp posts them to the notifications tab.

These are two different smartapps that work differently so it would be better to continue the discussion on the appropriate SmartApp topic here.


(Mark) #1665

I am so sorry! I was convinced I was using this app, well I was before! With all the testing I have been doing I must have swapped over to the other app and just forgot! :frowning:

Sincere apologies for the confusion!!!


(Scott Chapman) #1667

Installed new Yale lock, using the Universal DH and this app to manage codes.

It doesn’t seem to be working though… Codes I’ve assigned to users don’t appear to work.

In the logs for the app I see log entries with my users saying they are active.


(www.rboyapps.com - Make your home your butler!) #1668

Ensure that your lock is no further than 20 ft from the nearest repeater. You need atleast one repeater (Z-Wave Plus or ZigBee depending on your lock) between your lock and your hub to create a mesh and it will resolve 99.99% of your issues.
A repeater is any mains powered ZigBee or Z-Wave Plus device (like a switch or a plug), for example the Monoprice plug


(Scott Chapman) #1669

I have a repeater on a plug right next to the door.


(www.rboyapps.com - Make your home your butler!) #1670

Great then reboot your hub, do a Z-Wave repair (good idea to always do this after adding new devices) and run the Clear Codes procedure on our website to clear/reset your lock (this needs to be done for all new paired locks, see the website for details).

Also keep an eye on the ST platform there are outages affecting NA users right now which are slowing things down and users are having issues with the ST app to answer your original question.


(Scott Chapman) #1671

OK, I got it working with default DH and Smart Lock app. I’m guessing it was some unsavory combo of server issues and/or my hub needing to be taught who’s boss (because apparently it was in question).

I’ll switch over to yours this weekend. Spent too much time banging my head…


(TOO FLY FOR A FLY GUY) #1672

Can someone remind me again how to delete users? I seem to recall changing the number of users doesn’t automatically delete them.


(www.rboyapps.com - Make your home your butler!) #1673

If you’re using version 7 or newer of the app, yes it automatically removes “excess” users after you reduce the count of users. Or you can leave the user codes empty.


(Faron Faulk) #1674

I’m a techie but new to home automation. I wanted to let you know that Maddie has been a huge help in assisting me in getting our locks working, thank you so much for your help!


(Scott Chapman) #1675

Finally got it all set up with the new z-wave lock. I think this is a better solution than one of the fancy August locks.

I see I can set up custom actions when users lock/unlock doors. For my lock, you just put your palm over the keypad to lock it. I’m guessing in that scenario I don’t know who locked it so actions for that user wouldn’t be done?

My lock is a Yale Assure


(Scott Chapman) #1676

Bueller? Bueller?


(Scott Chapman) #1677

OK, I am having some problem. I have a routine that locks my door when no one is home. But whqt is happening is that the door locks, but then it changes the state back to unlocked (even though it remains locked). So the status of the lock is incorrect.

I captured the logs when this occurs, and it does appear that the lock is reporting unlocked? Can you check my work here:


(www.rboyapps.com - Make your home your butler!) #1678

This is a DTH question. Correct, your logs are showing that the lock is reporting an unlocked state.

If your lock is reporting the wrong state I would recommend resetting your lock and pairing it again with your hub.

See this topic/post for details:


(denisilic@hotmail.com) #1679

Hey Rboy,

I’ve recently run into a problem.

I’ve currently updated both the Device Handler and the newest version of the Door lock app (nice work btw with switching the menu of users so we can see names and if Expired. Bravo!)

I have 2 hubs each controlling a single lock. One of them works perfectly, the 2nd is giving me a headache!

It will allow me to set Permanent user codes,but for whatever reason, if I try to set an “Expire On” code, the lock won’t take it. It was taking it no problem up until about 4 days ago.

I have no idea what’s going on. I re-published the codes (for me) just now, but it didn’t fix it.

Help!