SmartThings Community

[RELEASE] Lock User Management - Door lock code manager (create, delete and schedule codes) with automatic lock/unlock, custom user actions and SHM/ADT integration

I cleared all the codes and reinstalled the app, still happening.

Is it possible to run a routine if the door is unlocked using the mobile app

It’s automatic. When the lock send the notification to the hub the app will push it to the user. It depends on the lock. Some locks send one notification for each invalid entry (e.g. Yale) while others send one for every X number (e.g. Schlage) of invalid entrees.

1 Like

You can create a rule in CoRE to detect if it was unlocked with type “remote” and then run a routine.

What does this actually mean?

Some locks support unlocking and locking using the Master Code (e.g. IDLock and Yale), while other like Schlage don’t allow “use” of the locking/unlocking using a Master Code. So now when you have a lock that supports unlocking and locking using the Master Code the app will recognize the user as a Master User. If there are global unlock/lock actions configured it will execute those as well. This notification cannot be turned off for security reasons, you don’t want to miss if anyone uses the Master Code to operate the lock.

Tried an incorrect code but didn’t receive any notification. Any tips? Thanks

Also, how do I specify only remote unlocks?

See my previous post

Some locks send one notification for each invalid entry (e.g. Yale) while others send one for every X number (e.g. Schlage) of invalid entrees

You need to look into your lock’s design, Yale allows you to configure it (which you can do through the Enhanced Z-Wave lock device handler) while others don’t (e.g. Schlage, it send one notification for every 4 invalid codes entered)

It’s the schlage connect, thanks. And how do I specify Core to only run routines with remote unlock? And lock manager will handle the imputed codes for routines

@RBoy I recently purchased your subscription and installed the lock SmartApp for my two Schlage locks. I have been using ST for over 2.5 years and have a great zwave mesh, however I keep getting the verify codes messages in recent history. Here is what I did for the installation:

  1. Using the Schlage keypad I manually reset all codes.
  2. Installed the SmartApp and set that I wanted 5 codes but left those blank. Did this before I went to bed knowing it may take time for the SmartApp to clear the codes again.
  3. Checked recent history this morning and confirmed that the continuous messages went away and that all the codes were cleared.
  4. Setup 5 codes around several hours ago this morning.

As of this post, several hours later, I am still getting the “code X is not set” messages on both locks. None of the codes work on the lock. Any ideas how to solve this?

1 Like

Are you using the Enhanced Z-Wave or stock Z-Wave DH?

Try this, do a Z-Wave repair. Then open the SmartApp, set to 5 codes, clear
all names and code, click Done. Wait about 10 minutes now go in and program
the codes. That should clear it all up.

If no codes are working that would indicate that the hub is having trouble
communicating with the lock hence the Z-Wave repair first, then clear codes
and then program codes.

I am using the stock DH. Will start a repair now and let you know later today.

@RBoy ran Zwave repair, then cleared all codes. Setup codes again and after several hours I am still getting the code not set messages. As mentioned I am using the stock DH should I be using your enhanced version? I would really like to have this app setup. I have had zero issues with the lock and status reporting prior to installing the app. The only other recent change is turning n device health.

Try the Enhanced DH. After updating the DH you need to clear the codes
first (the new DH has its own database that needs to be cleared).

Rboy, I have a number of occasional users who are older club members who often (usually) forget to wait for your smart app to disarm the alarm system before entering. I tell them to close the door, renter the code in order to lock and arm the system then enter it again waiting 10 seconds. This resets the system and turns off the sirens. But, after a few seconds, the door relocks. I do not have auto lock turned on for any of my doors. I tried this process at my home location and the same thing happened. Is that normal? Is there a way to disable this auto lock? I am using the latest smart app code and DH code.

Auto can happen from three sources, you can check which ones are enabled
and disable them accordingly.

  1. On the device itself (built in)
  2. Through the SmartApp if you have a door sensor installed. This will be
    on the Door Open/Close action page
  3. Through a third party SmartApp like CoRE

If you look at the recent events/activity tab of the device on your phone
it will tell which SmartApp or if the device is locking your door.

This is actually kind of a scary feature. It’s enabled by default and I paid no attention to it until the other day. Lock a door manually start upstairs, I hear the door unlock. Ask my wife if she did it, she said no. Go lock it again stays locked. Next day same thing happens and this time I’m waiting. Lock it again and it unlocks again.
I notice ST says the bar door is open and it’s not. But if I selected the sensor it reported closed. Door stayed locked. I don’t know why ST says it’s open when the sensor reports closed, but it made the app unlock the door. Not so much a problem for the app, but I don’t know that I’ll ever trust this feature again.

@RBoy I changed over to your enhanced DH this morning and finally had success getting the codes loaded! Do I need to keep using your enhanced DH or can I now switch back to the stock DH? I ask because I really don’t use many of the advanced features and I would prefer my lock run locally. If I can switch, do I need to reset the codes or will they stay?

Couple of issues:
I also noticed the lock isn’t updating SmartThings as quickly as I tested several of my codes and I only have one unlock event and it currently doesn’t show locked even though it is. Any ideas there?

I have two locks a BE468 and a BE469 and noticed the devices look differently in the iOS app. Is that supposed to happen? What’s interesting is the BE468 shows audio options even though it doesn’t have the alarm feature and the BE469 doesn’t show the alarm. See screenshots below.

BE469:

BE468:

How long do you guys wait for smart home monitor to be disabled before opening the door? I keep in setting it off