[RELEASE] Lock User Management: Door lock code manager (create, delete and schedule codes) with automatic lock/unlock, custom user actions and SHM/ADT integration

smartapp_alerts
smartapp_security
smartapp_locks
project_secondhome
rboyapps

(Radim Svoboda) #1239

exactly the same here with Yale deadbolt key version on an Android device. Tried to replace Device Handler for the universal one, the device stopped responding entirely, head to remove it from ST and completely reset and reinstall again…


(www.rboyapps.com - Make your home your butler!) #1241

Yeah I’m seeing it also. Think it’s a ST server problem.


(www.rboyapps.com - Make your home your butler!) #1242

Okay so looking into it, looks like ST made some changes to the platform at the backend which has broken the lock device handlers (custom and stock) which is why this error has popped up. Working with them to see if they can reverse the changes.

EDIT: This change by ST only impacts new programming, existing programming will continue to work just fine for now.


#1243

Thanks, I had another smart app for it but deleted it to try yours. Hopefully it can be fixed.


(www.rboyapps.com - Make your home your butler!) #1244

Definitely, one way or another. Just a question if ST is playing ball to reverse the changes or if the app needs to be updated.


(www.rboyapps.com - Make your home your butler!) #1245

###Door Lock Code Multi User Management with Notifications and Actions - Version 05.07.00

  • Patch for changes in ST platform causing new programming to throw an error in the ST Mobile app
  • Improve programming compatibility with more locks

Recommend use the [Universal Enhanced Z-Wave Lock] ([RELEASE] Universal Enhanced Z-Wave Lock, Schlage Lock, Yale Lock, Kwikset Lock, IDLock, DanaLock and August Lock Device Handler with Alarm Control, Notification, RFID, Door Sensor and advanced features) device handler version 03.03.00 or newer for full SmartApp and automatic update notification functionality

EDIT: This is done proactively as a way to allow users to continue using the app. If ST decides to roll back the changes they made, users can continue to use their existing apps. Meanwhile, if you need to make immediate changes to your user codes please upgrade to this version to workaround the ST errors.


(Kevin Sime) #1246

Thanks for responding to this issue so quickly. Updated to 05.07.00 and app working fine again, error free.


#1247

So the error is in the device handler? It is working fine for me, just the smart app is giving me an error. I’m running the universal enhanced z wave lock 03.03.03.


#1248

Never mind, I see where you posted new smart app, I installed it with no errors, thanks so much!


(www.rboyapps.com - Make your home your butler!) #1249

The issue was that ST changed some lock capability properties which affects all handlers (stock and custom). So while the device handler itself would continue to function, SmartApps that depended on those specific capabilities will stop working. Hence the fix to work around the ‘missing’ capabilities was provided in the SmartApp version 05.07.00

This is our full time job. Our goal is to ensure that the app just works with the standard or custom devices. Just plain n simple, no messing around.


[RELEASE] Lock Manager
(www.rboyapps.com - Make your home your butler!) #1250

Quick update: ST just confirmed a hotfix patch is going out shortly so it should fix the problems if you’re still using the older versions. If you’re on the latest version you’re all set anyways.

Thanks @Tyler


(Tao) #1251

Hi, I am trying to read all the codes in a schlage connected padlock but without success.

Here is my code for subscribe:

settings["group_locks"].each{
    log.debug "subscribing to $it"
    subscribe(it, "lock", lockHandler)
}

Here is my reload all codes call

settings["group_locks"].each {
    it.reloadAllCodes()
    log.debug "$it reloading all codes"
}

I tried “lock”, “lock.codeReport” and “codeReport” in subscribe but no call back is fired.
Any suggestions?
Thanks


#1252

Hi, I’m using the Schlage BE469. The wife and kids lock the door using the front Schlage button on the front. Everytime they do that, I get a notification that the master code was used. I saw people mention that previously but I don’t know if it was resolved.
For me to use notifications, I can’t have it notifying me so frequently. I just want notifications under more rare circumstances. Thanks!


(www.rboyapps.com - Make your home your butler!) #1253

Yes it resolved some time ago. Have you updated to the latest version of
the SmartApp and the Enhanced ZWave Device Handler, if not please do that.
Have double checked that the BE469 is working fine here.


(Joakim Olerius) #1254

Is there any way to react on a specific user and do stuff only when that user unlocks the door? For example the one who’s gonna water the flowers while we are gone. When he/she uses her tag I want my alarm system to automatically disarm. So I don’t have to share alarm codes.


(www.rboyapps.com - Make your home your butler!) #1255

That’s the whole premise of the SmartApp, ability to configure individual user level unlock and lock action (need Enhanced Z-Wave DH for individual lock actions) apart from programming them (amongst other features).


(Joakim Olerius) #1256

Sorry, I can’t find it anywhere to use on specific user. ??


(www.rboyapps.com - Make your home your butler!) #1257

Every user has a link to define their own actions.
It’s the last option for each user.


(Joakim Olerius) #1258

I found it, but nothing happens. I added a light to code 2 just to test it. I get the notification in the lock history, but no light turns on. I have idlock. What could be wrong??


(www.rboyapps.com - Make your home your butler!) #1259

Probably a configuration issue. For IDLock confirm that you’re using the Enhanced Z-Wave Lock Device Handler. The Stock Device Handler doesn’t support all the features of IDLock. Then if you’re still having an issue open IDE Live Logging. Unlock the door using the code. Copy paste and send us an eMail of what you see on Live Logging and also a screenshot of your SmartApp settings. EMail it to us (see our support page) or PM it to me.