[RELEASE] Lock Manager

smartapp_locks

#1721

Notifications working? I tapped global settings>notifications and also user x>notifications and nothing happens just a refresh icon.

Using custom ethayer schlage DTH


#1722

Any ideas @ethayer

I tapped Notifications and switch over to ‘Lock Manager’ in graph ide but when I checked logs they are empty. All other features work except for notifications component .


#1723

Turn on and off debug in app and saw this:

But nothing else in regards to ‘notifications’


(David Jacobs) #1724

When I go into Lock User smartapp it has exclamation mark and says “something’s wrong” everything seems ok though? I dont think I should ever have installed it - is there a way of removing it from the app?


#1725

Follow steps here [RELEASE] Universal Enhanced Z-Wave Lock, Schlage Lock, Yale Lock, Kwikset Lock, IDLock, DanaLock, August Pro and Samsung Lock Device Handler with Alarm Control, Notification, RFID, Door Sensor and advanced features no need to remove lock just follow steps to remove app.


(David Jacobs) #1726

Perfect. Thanks!


(Erik Thayer) #1727

Those logs look fine. What version of LockManager do you have installed? How did you install it? Github? Copy paste? Could be a platform issue.


#1728

I installed v2.0 using github beta-2 branch.

I think i found a way to recreate this issue.

@ethayer try to see if add a contact using smartthings settings’more’>contact book then go back to lock manager app and click notifications then the notifications screen doesn’t show anymore. Once all contacts listed in contact book are deleted the notification screen loads correctly.


#1729

Separate/maybe related issue see below screen showing null

@ethayer It seems that when i used ‘send notifications to’ /contacts book icon and proceeded to add a contact then this causes the earlier issue where ‘notifications’ screen stops working/rendering. Not sure if it’s platform issues but now I’m not adding contacts using this option and only using text and push notifications and the only issue is the ‘null’ showing in both text and push notifications.


(Erik Thayer) #1730

I still can’t re-create your notification page issue. I have seen the ‘Null unlocked by X’ message before. This is because your lock doesn’t have a name.

Navigate to the ‘My Home’ section and scroll to your lock. Probably something like ‘Zwave Lock’

Click on the name and then click the cog in the upper right of the screen.

Where it reads ‘Give your device a name’ Enter in a unique name to identify the lock, such as ‘Front Door’

Notifications will no longer read ‘Null was unlocked by Joe’ will now read ‘Front Door was unlocked by Joe’


#1731

Ok cool the lock did have a default name so i was sure about the null but after renaming it to ‘front door lock’ the null is gone.

No worries on the other issue, ill stick with push and text notifications, they do job perfectly:).

I wanted to turn on/off door alarm mode using webcore but did not see the commands listed.

@ethayer Is there a plan to expose the commands/alarm mode available at the lock settings/cogwheel screen on Webcore for future releases?


(greg) #1732

Hey- I’m using the 2.0 beta with 2 Schlage Connect locks and everything seemed to be working perfectly initially… until I locked/unlocked both locks with codes set in the smartapp and I got no notifications and no hello home routines ran. I set them to run on the user, lock, and global levels. Still nothing.

Edit: I switched from the stock device handler to yours and the following happened:

-Code Locking/Unlocking notifications worked

-Running “I’m Back” routine on code unlock worked

-Running “Goodbye” routine on code lock did not work. Instead, it ran “I’m back”. Happened on global, lock, and user levels.


(Erik Thayer) #1733

OK thanks for the heads up! Im not sure why the stock DTH didn’t work… I think it’s important that peoples don’t use the “****** - With Codes” DTH… but otherwise

The “I’m back” routine running on lock with code was a copy paste oversight by me. This should now be fixed.


(Tony B.) #1734

Noticed you updated the code recently. Do you suggest a complete uninstall/reinstall?


(Dan Fox) #1735

Problem. (Running the beta 2.0 version).
I replaced my lock so deleted it from ST. Now when I try to open Lock Manager, I get a “Something’s Wrong” error. I can’t even delete this app from IDE, since it is installed in ST. What do I do?


#1736

@ethayer
Some commands are available in webcore :image|281x499


Maybe just expose alarmode command and e.g parameter string type ‘Tamper’ ??


#1737

Goto Locations
Installed SmartApps
Edit (upper right hand corner)
Scroll down to Other
Uninstall every Instance of the Door Lock User… SmartApp. Also the ones labeled Lock Multi User…

Steps that help me force remove, provided in another thread.


(Dan Fox) #1738

Thanks. That was easy, once I knew where to look!


(Shylo Sanchez) #1739

@ethayer I followed your instructions to add the Lock Manager App. It shows in my list of apps

But it does not show up in ‘My Apps’ on my mobile device (I am using the SmartThings Classic App on my Google Pixel phone)

What did I do wrong?

Never mind. I figured it out


(MacTechGenius) #1740

With the Iris Keypad…is it possible to prevent routines from running twice in a row? For instance…if I arm away - it runs the good bye routine twice (only want it to run once).