[RELEASE] Lock Manager

smartapp_locks

(Eric Anderson) #1621

Lock status not shown in app (unknown) and app says it can no update the lock status.
Yet lock status is correctly reported by lock under my home.


(David Fenstermaker) #1622

I just installed a Kwikset lock. Well I should say it was a warranty replacement lock for one that started melting (there was a short). I currently have 4 more Kwikset locks around the house. Anyways, I have the correct DH and everything and lock manager correctly imported all my users and codes to my lock. About an hour later, out of the blue, it started disabling certain people from the new lock. I went in and reset the user data for the users that got disabled. All worked except for one user. The code was 0827. It wouldn’t for the life of it enable that user. So I played around, removed that user, and re-set up the user with same code. Still wouldn’t set code for that lock (all other locks worked). So again, I deleted user and added user with a code of 1313. That worked great. Went in and changed code to 0827 and the it changed to code on that specific lock to 2423. so I figure maybe something with the code so I changed it to 0828 and it saved the code to 2424. Finally i gave up and changed it to 0829 and that saved correctly.

On kwiksets, the buttons are 2 numbers (1-2) (3-4) (5-6) (7-8) (9-0) so maybe something internal with the lock for that specific set of numbers (7-8). I have other codes that use 7 & 8, just not as the last number. I’m thinking something is messing up when the last number is 7 or 8.

Updates: Just tried changing it from 0829 to 0827 and worked on all locks except for that one. Wont change code. Changed back to 0829 and it’s fine.

Tried adding a new user/code of 1317 and that added fine so my above theory on the (7-8) button isn’t right.

It’s like there is something preventing that specific code 0827 and 0828 from being used only on that lock. Unfortunately I’m 5 hours away so I can’t easily re-set the lock.

P.S. the live logging also says I have 15 lock users, at one time I did, but now I only have 11.


(David Fenstermaker) #1623

OK so I think i figured it out. After doing some testing, it won’t allow you to add a user with the same code as another. So if I have one user with code 1234, i can’t add another user with codes 1234, 2234, 1134, 2134, 2234, 1244, etc… (remember with kwikset each button has 2 possible codes associated with it). I think this must be coded into the lock itself as a safety or something. If it was “lock manager” related, and 0827 was somehow stuck in the memory, it wouldn’t allow it to be set on any other lock. Since I’m only having issues with it being set on one specific lock, it must be lock related. When I do the code 0827, the code sets fine on all my other locks except for that specific one mentioned. So when that lock arbitrarily started disabling users, it must have kept 0827 somewhere in the memory and won’t let me set that code again. So I’ll probably have to reset the lock next time I’m there. Does anyone know if you can reset all the codes from memory remotely?

The 15 lock users includes the users and the locks combined i figured out.


(Eric Anderson) #1624

Status unknown


(Dana ) #1625

Don’t want to jinx myself, but since I cleared up some somewhat self-inflicted issues a while back, Lock Manager has been purring like a Rolls Royce. Just phenomenal work, @ethayer. Thanks very much.

I just sent another donation to Erik, and I encourage other users to show their appreciation via a donation…even a few bucks is appreciated, and well worth it considering the many hours he puts into development and support and the extensive functionality Lock Manager provides.

There are over 1500 posts in this thread, and only 54 clicks on his donation links.

Don’t make Erik feel like an unsupported public radio station. :wink: Buy him a cup of coffee to let him know you appreciate it, makes you feel better, makes Erik feel better. :smiley:


(Eric) #1626

I have tried several lock Manager types and had some sort of problem with them. I then found this one and it has been working like a charm. One very minor thing that bugs me is that when the door is locked or unlocked via smartthings it says door unlocked/locked manually. To me this was not done manually but electronically. Is there a way for the program to say locked/unlocked by User x present sensor, or locked/unlocked electronically by users x. I know I can see the number of times a users has used the locked which is great but it would be nice to know when the lock is done by a present sensor, who it was that was arriving or leaving.


#1627

Hi Erik, I have followed the dropbox instructions for Lock Manager which were great for an amateur like me The app has appeared on my phone but I dont think it is communicating with the lock? It lets me select the front door option. When I click on the lock it shows all 30 slots but doesnt “learn” the codes as you mention. If I exit the app and go back in the lock is no longer showing and it lets me add it as a new lock again. I also tried to add a test user code but it didnt work which makes me think there is a communication break down? Thanks!


(Erik Thayer) #1628

Hello.

It’s been awhile.

I’m working on some updates. Hopefully API service will be ready soon, but I have been doing housecleaning on the app to make developing on it more enjoyable. This will include getting rid of all the child apps. The app architecture will still use the child-app system, but all child app code will live in the same file.

This is working well, and I’ll test it to make sure it’s good to go while I develop the minimum viable amount of functionality for the API service… which is a lot.

*User Creation
*User Scheduling

I also want to include a feature called ‘entanglements’ that will allow you to tie two switches together across locations… though maybe that can wait.

This new app will be version 2.0. Not because it includes awesome new features (well, the API might be cool), but because (unfortunately) it will cause users to have to re-install the app. =(

//general pro-tips>

I’ve noticed a lot of people saying their data doesn’t ‘stick’ in the app. I think this is a result of people attempting to access the app from the ‘Marketplace’ and not from the installed apps section. This will cause a lot of problems.

  1. You’ll notice your data doesn’t ‘save’ This is because you’re creating a whole new app install! There’s no data to see in a new app.
  2. When you have more than 1 instance of Lock Manager installed, They will fight, forever. You will program your user into 1 app, and then since the other app knows nothing [jon snow] it will delete your user… then the first app will see that the user is gone and it might program it in again, and so on and so on until you go mad and your batteries die.

So don’t be a goober, install only 1 app at a time. For advanced user purposes, and when I first wrote this app, I didn’t include the flag to disallow multiple installs. The new app will have that flag enabled.

Lock status doesn’t receive codes programmed before installing Lock Manager

This is normal. For security reasons, most (all?) locks do not give their codes to the HUB once they are programmed. The SmartThings device handler tries to keep a record of what it thinks the codes are, but it is not guaranteed to be correct.

PS.

Thank you for your donations. I don’t expect them, but I very much appreciate them. While certain aspects of the API might not be free (The server is going to cost me money) I will continue to develop and offer this app for free as long as it is useful.


(Ken Snyder) #1629

I have to say I’m already quite happy that having gotten about 40% through the guide my SmartThings app now displays the “Smart Locks” menu and the “status”, “lock codes”, and “history” tabs seem to display the correct info. What bothers me is more what I didn’t do in the guide:

  • In “My Devices” on website (graph.api.smartthings.com) I see no devices listed. I’ve waited but nothing comes back. I think I did “activate” the app on the smartthings mobile app (although I’m forgetting what I did precisely). this also means that I can not Edit the Lock Device.

I am literally half-way around the world from my lock so being very cautious and not making any door code changes but would love some assurances or directions on getting to the happy path.

Ken


(jkp) #1630

@ksnyde try logging into IDE with https://account.smartthings.com instead of the link you posted above.


(Ken Snyder) #1631

@ksnyde try logging into IDE with https://account.smartthings.com instead of the link you posted above.

That did the trick! Thank you!

One follow-up question though … when I click “edit” on the device and look at the “type” dropdown it has already highlighted Z-wave Lock. I looked at the list and there was no mention of a specific Yale option. Is that an issue?

In the “data” section of the device I see the following listed:

  • fw: 254.194
  • manufacturer: Yale
  • MSR: 0129-B52B-34F8

(jkp) #1632

Z-Wave Lock is the stock ST device handler for z-wave locks. If you wish to use the ST Smart Locks app, you would need that device handler. If you wish to use ethayer’s Lock Manager app, you would need to install the Z-Wave Lock Reporting device handler and assign it to your Yale lock. that device handler can be found here…


#1633

I eventually switched to Rboyapps because it was more “reliable” than this one. Not a knock on your work, I think your app has much better features and Rboyapps’ method is to completely reset every code slot upon saving (which is why I think it’s probably more “stable”) and is incredibly slow.

That being said, I’d still like to switch back because of the more sophisticated scheduling and changing a key will only update its respective slot. So I’m wondering, did you ever get more bug reports about the issues I reported May '17


(Evan) #1634

I have this exact same problem on my Yale YRD 446. My other lock (a Schlage) works fine in Lock Manager. Has anyone solved this yet?


(Glen King) #1635

If I could… I’m using ethayer’s App and here’s my take:

  1. I had difficulty getting it installed the first time.
  2. That was mostly my fault (the instructions could have been a little better)
  3. Second install worked… and since then it’s been bulletproof.

My lock is Schlage BE469.


(John P. Hoke) #1636

Ok, setting this up and want to make sure I am using the right DTH - I have a Schalge Camelot so use the zwave-schlage-touchscreen-lock DTH right?

TIA :slight_smile:


(jkp) #1637

That is correct.


(John P. Hoke) #1638

Thanks - perhaps dumb question …

In the tiles for the lock there is a red line that when selected is a dimmer control / level set from 1-5 … what the heck is this for ?


(jkp) #1639

sensitivity level for the alarm


#1640

For the past week my Lock Manager app has been completely disintegrating (with some added help from me), after working great for months. I did the recent updates (after some of these difficulties started to emerge), I tried to do a Z-wave mesh repair. I have two smartapps installed: the “5-2 Day Thermostat” and the “Door Lock Code user Management…”. I have 4 schlage z-wave locks. NONE of the locks work via their keypads now. I can only use a physical key or press “locked” or “unlocked” in the ST app in my iPhone under “My Home” > “Things.”

When I go to Automation > Door lock code user management… and select all 4 locks, 20 users (slots) and then configure several of the users, all as “permanent” with 4-digit codes, and “Notify on use”, and then click Done and Save, I do not get the old green pop up saying that the info is being saved. When I go to the hamburger menu, and click on Notifications, it seems to show an endless loop of “Requesting Front Door to add permanent code FRED to user 1, code: 1234” etc. for all the different locks/things and users I have tried to install. The messages all constantly say “requesting” with no confirmations. I’m exhausted. Please help!