[RELEASE] Lock Manager

You should be using https://account.smartthings.com

Does anyone have a thought on this one? Would performing a factory reset on the Yale Assure Lock with Bluetooth help? Thanks.

I have had this exact issue for a while, and still am. Both with YRD446 and with YRD240. Any thoughts?

Sorry, I never got this fixed. I got busy and couldn’t mess with it anymore.
I assume it is still an issue, but I haven’t tried with the most recent DTH and SmartApp.
Would love to be able to use the feature though.

Erik
What a great app. You know, I just bought two more Kwikset 916 locks (12/2017), and neither lock accept the codes from lock manager like the 916/910 locks I bought in April 2017. They just don’t. It’s sad. “App is learning codes. They will appear here when received. Lock may required special DTG to work properly.” And then each slot has the proper name “Tony”, “Lori”, etc but no code. I go to lock settings in the lock manager app, and the status is stuck on “lock is loading data”. But days go by, data never loads. Thinking a release upgrade? You looking at this again by any chance? How can I help? Money?

I have installed my Yale Lock (YRD220) then installed the Smart Lock app. not enough control so I installed Lock Mananger thru my laptop it now show up in my phone app but ever time I try to Add the lock or a new user I get " ! Sorry, but there was an unexpected error." ? can anyone help me out??

For anyone using a Centralite / Xfinity / Iris Keypad with Big Talker, that wants an announcement when the keypad is set into ExitDelay mode, I released a Smartapp, Keypad_ExitDelay_Talker that performs this function.

Other keypad related announcements are easily handled by Big Talker.

1 Like

I’m having a similar issue now. The lock itself reports as Locked, but is sending messages that say it’s Jammed. Even though the last Jam occurred yesterday evening. The message pops up at the top of my screen multiple times every time I am in the Lock Manager app or looking at the lock device itself.

Clicking the X does not clear the message from popping up again.

How do I clear that queue?

Hi,

Installed the app yesterday. Great app. I was able to create user, change codes, etc.
Question: is there any way to fetch and manage old lock codes, that were entered via lock itself?

Thank you
Gene

Setup:
Samsung S8+
Samsung Smart Things Hub
Schlage Connect Camelot Touchscreen

I get an error message when following the installation instructions for adding your github repository (https://www.dropbox.com/s/pfi9ciqmxbjq9lo/guide.pdf?dl=0)… it says, you don’t have access to ethayer/lock-manager. Do I need to request access somehow?

I have seen others report this issue with WebCORE. The solution was to disconnect from your github account and then reconnect it. Don’t know if this will solve your issue.

that did the trick! thanks!

I get the same problem on two Schalge locks except the code does not work. I’m wondering if anyone was able to overcome this issue. The problem occurs with Schalge lock with both Zwave reporting and Touchscreen DTHs from lock-manager repo.

I have the same issue on two Schalge Deadbolts too. I wonder if and how you ever got it resolved.

what happens if you open a user, scroll to the bottom of the screen and select one of the locks affected and tap on Reset lock?

In most cases, reset user, reset lock, delete user and add again – all do not help the failure counts starts again and when it reaches to 10 it is disabled again. Every once in while I’m able to get it done when I reset lock before it hit 10 but that works with some users and not others.

I kept resetting them in Smartthings and it went away

1 Like

FWIW certain codes have this problem and others not. Idk if it is a Schalge issue or the app. Codes having the digit zero are more likely to have this problem. This after trying quite a few different codes and validating by recreating users with working vs non working codes 3 times each.

Not sure of that. My Lock Manager has multiple codes that contain zeroes, and all work correctly.

However, my first two codes are stored in the lock itself. The very first one has no zeroes, the second has two zeroes. Both of those work fine. The remainder are sent to the lock by Lock Manager, and of the six stored in the smartapp three have zeroes in them. They have all worked correctly, with no problems whatsoever.

I did have issues with other DTH configurations, but this one has been flawless. BTW, the lock is Schlage BE469.

I think I figured out that I should not be going through marketplace to find the app, but now I have 2 instances of it installed in my automation tab. How to remove one?