[RELEASE] Lock Manager

LOL - We are on the same page :slight_smile:

I am bowing out, take over :slight_smile:

1 Like

Just updated all smartapps again and now it seems to work without uninstalling. Big thanks to everyone!!

Good deal :slight_smile:

Hey, all. Thanks for the Lock Manager. I’m having an issue with the Yale YRD256.

  • I set only the master code from the lock
  • I am using the Enhanced Universal Zigbee DTH from ethayer

I’m able to add users and set the codes and have them all work, but within 24 hours, none of them will work any longer. The device state will be “tampered” in ST, and the device log shows numerous entries of “User 0’s PIN code deleted locally”.
Any ideas?


ST rolled out fix on Tuesday.

1 Like

I have two Yale locks:

Yale Touchscreen Deadbolt Door Lock
zw:Fs type:4003 mfr:0129 prod:0002 model:0000 ver:33.32 zwv:3.34 lib:30

Yale Assure Lock with Bluetooth
zw:Fs type:4003 mfr:0129 prod:8002 model:0600 ver:1.74 zwv:4.24 lib:03

The first lock (Yale Touchscreen Deadbolt Door Lock) works perfectly with the Lock Manager App. However, I am having difficulty trying to figure out why I am not getting SMS messages from the second lock (Yale Assure Lock with Bluetooth) when a user unlocks the door with their code. I do get SMS messages from the second door lock when it is manually locked or unlocked.

I have the SMS setup under the “Global Settings” and it is working just fine for the back door lock so I don’t think the problem lies here. I also specified the cell phone number in the “Notification Settings” → “Text This Number” for a user. However, this still did not work.

I tried enabling “Notification Settings” → “Send A Push Notification” for a user as well, but this also did not send any alert.

I have removed the user from Lock Manager as well as the lock itself and added everything back, but nothing seems to get a SMS message working when a user unlocks.

When I look at the “Live Logging” for the door that is working I see:

"zw device: 05, command: 9881, payload: 00 71 05 13 01 " parsed to [‘name’:‘lock’, ‘value’:‘unlocked’, ‘descriptionText’:Patio Door Lock was unlocked with code 1, ‘data’:[‘usedCode’:1], ‘isStateChange’:true, ‘displayed’:true, ‘linkText’:‘Patio Door Lock’]

When I look at the “Live Logging” for the door that isn’t working I see:

"zw device: 0C, command: 9881, payload: 00 71 05 13 01 00 FF 06 06 04 63 03 01 01 00 " parsed to [‘name’:‘lock’, ‘value’:‘unlocked’, ‘descriptionText’:Front Door Lock was unlocked with code 99, ‘data’:[‘usedCode’:99], ‘isStateChange’:true, ‘displayed’:true, ‘linkText’:‘Front Door Lock’]

When I look at the lock, in Lock Manager, I only have 30 slots available to assign to a user.

I rebooted my Hub as well.

Does anyone have any thoughts?

I also posted here, but this can be deleted since I was initially not sure how to post for this App:


Its towards the bottom, as the instructions point out.

See page 10 of the User Guide.

LOL. What are you talking about? Was that post intended for me?

You replied to my comment asking where that DTH was located.

I responded where it could be found.

Towards the bottom of the list of available DTHs for a lock.

See screenshot:

Just as the User guide for Lock Manager states.

See screenshot:

How is this confusing or amusing?

It was amusing because there was no quote associated to the reply, so I had no idea what the post was referring to. Now that I have a little more detail in your last reply, I scrolled back 10 days to have that jog my memory. Wasn’t laughing at you, just had no idea what is was in reference to as I have made a ton of posts in the last 10 days and someone else on this thread after yours in this thread.

Anyway, did you get your issue resolved?

Hint, if you select text from someone else’s post, you can then press Quote and it will carry that down into your reply so they know exactly what you are replying to, no matter how far back in the past :slight_smile:


Sadly, I have not resolved the issue.

Hehe that’s much better and easier to follow :slight_smile:

Have you tried using the standard Z-Wave Lock DTH as I had shown in that one screenshot? Any DTH that is at the very bottom of your list are custom DTHs. Try with one of the OOTB (out of the box) ones to see if that reports on more than just unlocked.

I just tried and it was not responding to lock and unlock commands through the app.

Even if you are using the SmartApp, the stock DTH should allow you to lock and unlock at the least.

Well I would apply the custom DTH again and see if it at least locks and unlocks again

Can an Exit/Entry Delay option be added to Lock Manager? Then it would be complete for me.

EDIT: Oh I see SHM Delay can be used. I will try that out. If it can ever make into it your app itself that would be cool too but if SHM Delay works then awesome.

Hello im new here. I have a question. Do i have the wifi adaptor so i can work with my samsung hub?

No need for wifi.
The lock doesn’t have wifi and smartthings hub doesn’t have wifi either.
Smartthings hub is wired with an ethernet cable to your router.
A lock has likely z-wave, ZigBee or Bluetooth radio, it depends on the model.

thanks you ill check the model i have when i get chance. Hopefully i dont have to buy any thing else for it…

Just a note since I’ve seen it a few times, but nobody seems to have noticed this.


will take you to the correct shard for your account. Least it’s supposed to.

I’ve been using Lock Manager, but jumped to SmartLocks (I wanted local processing)

I’m jumping back. Too many things depend on my routines firing to put me in the correct “Mode” e.g. Away, or I’m Home. SmartLocks doesn’t have this right now.