[RELEASE] Lock Manager

Just wondering if the fix for the battery level in the locks got fixed? I have 5 locks in total. One has always said 1%, one says 0%, and the other 3 report nothing.

It is minor, but would be nice to see it working correctly.

THanks

Jeff

1 Like

Is there a way to trigger something in WebCoRE based on a user entering a correct code into a lock? I’m using the DTH for ‘Z-Wave Lock with reporting’. Most of what I want to do can be handled by the Lock Manager app & Routines, but I may want to centralize this into a single location in WebCoRE. Juts trying to see what is possible at this point.

1 Like

I’m using this along with jhamstead’s Universal ZigBee Lock DTH with Lock Codes with a Zigbee Kwikset 916 and everything seems to be working except manual unlocking (from outside with key or inside) doesn’t execute the selected routine. On Code Unlock does (and it’s the same routine as selected for on manual unlock).

I’ve got the latest version of Lock Manager installed for my Z-Wave Schalge Camelot touchscreen lock, however I cannot find anywhere to review/add/remove my codes. Any and all help is much appreciated.

Thanks!

Hi everyone. I ran a search against this topic but didn’t see anyone reporting this issue. I have the most recent version of the mobile app for iOS as well as the current version of Lock Manager from Github as well as a v2 hub

I have an existing Schlage Connect lock and installed the Lock Manager smartapp and have had no problems adding and removing users and codes. I just added a second Schlage Connect lock and configured the Lock Manager app for this lock. However, after adding this new lock to Lock Manager app, the only thing that shows up under the SmartApps for this new lock is the “Lock” app and NOT the “Lock Manager” app.

Both the locks are using the “Z-Wave Schlage Touchscreen Lock” DTH in case that matters.

Is there a trick to using the Lock Manager app with two (or more) locks?

Thanks!

can you take a screenshot of this screen and post it. I am confused because you stated you added it to Lock Manager but then say you do NOT see the Lock Manager app. Cover any info you don’t want exposed.

Hi jkp and thanks for the response. I’m confused by the end result as well because I did add the new lock to the “Lock Manager” app and not the “Lock” app. When I check the smartapps associated with my original lock, “Lock Manager”, “Lock” and “Keypad” are listed and I use “Lock Manager” to add users. However, the new lock only shows the “Lock” smartapp.

I would be happy to take and post a screenshot but don’t see a way to do it using this forum.

Thanks for your help.

  1. Make sure you have the latest version of Lock Manager installed in IDE.
  2. Then use the Lock Manager located in Automation: SmartApps. You can ignore any of the child apps (Lock, Keypad and Users)
  3. In Lock Manager, you can add both Users and Locks and both would be listed within the Lock Manager app after you add them (assuming you have the latest version installed).

sorry, it took me 5 minutes to type this because my cat is assisting me on the keyboard so lots of backspacing to correct typos.

1 Like

No, I’m still having the same issue. I did a factory reset on the lock and reinstalled/configured the program. The first codes I created with the app worked but I tried to create more a couple days later and now they aren’t writing to the lock either. I’ve gone back to using a key because I can’t get it to work again.

Hope you can help. Im having a BIG problem. I updated the device and smartapps by overwriting the code and suspect I must have been on a Beta version!! Now nothing is working and I cant uninstall the device/smartapps. Can someone please tell me how to its been some time since ive used Smartthings and think ive forgotten a few things. Do I need to remove the actual Yale Lock device to achieve this??

No need to remove the locks. If you can’t remove the lock manager from The ST app, log in to IDE and remove it under My SmartApps. Remove the child apps first, keypad, users and locks, then remove the main lock manager app. Try that and then follow the guide at the top of this post to reinstall.

THanks for response I still have Lock User and Lock Manager in the IDE smartapps however I get this when I try to remove "This SmartApp can’t be deleted at this time because it is installed by one or more users"
Appreciate help

In IDE, go to My Locations: smartapps: click Edit under the banner at the top, scroll down until you find Lock Manager and click Delete to the left of it. if there are any sub item under it, delete them first. then click Done at the top. Be careful and delete the correct app :slight_smile:

1 Like

Try this:

In IDE:

  1. Goto Locations
  2. Installed SmartApps
  3. Edit (upper right hand corner)
  4. scroll down to where you have Lock Manager
  5. Any sub entries (Children), try pressing uninstall next to those first. If they don’t disappear, scroll back to the top to see if you receive an error.
  6. if it does let you uninstall the child entries, then try doing that for Lock Manager.

If this fails, this may be something very similar to what happened with NST Manager and trying uninstall there. Recently there is an issue ST knows when trying to uninstall an app with child apps. It might be related to the same thing, but try those steps first. You should not have to remove the code at all (SmartApp or DTH). Going to ping @tonesto7 as he addressed this in his app.

Guys thanks for help. I successfully uninstalled through this method (or so it appeared) then when I go back in they are repopulated!

Time for you to contact ST support and ask them to remove it.

Not sure why you want to uninstall though. If you update your code either manually or thru the repo, that should take affect when you republish. What exactly was the issue when you updated the code?

I updated everything OK - I believed. But the smartapp LOck Manager (on the device) and into a user it says “somethings wrong” the lock also wont accept the codes!!!

In IDE, under My SmartApps, do you see the 4 smartapps listed?

If you must uninstall, try this for a moment:

In the ST Mobile App:

  • Goto Things
  • Select Lock
  • Got SmartApps tab
  • Do you see the Lock Manager listed there?
  • If so, select that and see if it will take you to the app (kind of backdoor).
  • Can you unselected the Locks from within there?
  • Or do you get something wrong again
    If it will let you, remove all your locks, then try uninstalling again.

You shouldn’t have to go thru uninstalling again though. Can you take a screenshot of your listed Lock Manager from SmartApps in IDE. Just want to see the front page.