[RELEASE] Lock Manager

Cant say for sure on the Kwikset, but i use the ‘Garyd9’ handler (available from GitHub account above) for my Schlage and it has worked well for quite some time now.

You will need to use the ‘Developer Tools’ to create/set the custom device handlers necessary for each lock: https://graph.api.smartthings.com/

Highly recommend following the install guide posted above if you are new to all of this. It is one of the best I have seen around.

1 Like

I have a two Schlages and one Kwickset. For the Kwickset I use the Z-Wave Lock Reporting DTH. For the Schlage I use the Z-Wave Schlage Touchscreen Lock. These are the two DTHs detailed in the installation instructions for this app.

1 Like

Assuming DTH somehow references a device handler. Everyone is using the acronym and the definition of that acronym is nowhere to be found. Wiki turned up primarily NC Tarheels newspapers and Urban Dictionary, while funny, didn’t offer much more help. Clarification would be nice…unless everyone using the acronym has no idea what it means and has just been too ashamed to ask.

Second, has anyone else noticed that, in general, changing a code for an existing user required deletion of said user and recreation of a new user account? Somewhat similarly, after creating a new user account or deleting an unwanted one, it doesn’t seem that the change takes effect until after I log out of my SmartThings app and then log back in.

I am looking for a behavior that I can use that will provide me a high level of confidence that everything is working properly. I will be managing this lock from over 2200 miles away for no less than two years and lapses in reliability, while manageable when experienced on occasion, will eventually make the juice NOT worth the squeeze.

Thanks!

What happened to the icons?

2 Likes

Maybe an Android issue? They’re present for me on iOS.

Probably working from cache. File not found in Windows
https://dl.dropboxusercontent.com/u/54190708/LockManager/lm2x.jpg

Yeah, I see that. Even the SmartApp icon is not there when looking in the IDE.

40 AM

Put in your own icon :wink:

1 Like

Done :sunglasses:.

Dropbox changed the policy for shared folders and broke all the icons. I’ll get them sorted out shortly with an update… I have to find a new place to host them.

5 Likes

I stick my icons in GitHub. Not sure if that’s good practice or not.

1 Like

I’m actually just going to host them on S3 I think. I bought lockmanager.io

:wink: :wink:

Note: This sign up form wont work, its disabled, suckers.

2 Likes

Images are back, update your app. Now hosting on s3.

3 Likes

Thank you.

Hi, how do I use one touch lock with Lock Manager?

Before installs this, I only need a code when entering the house, but now I have to enter the code when leaving the house during locking phase.

If you set up an automation that closes the lock as soon as the door’s contact sensor closes, you no longer need that feature.

I can’t do that as I’m using it for homestay. Some guests just wanted to leave it for a moment to buy something across the street (just 20 steps away).

I am interested in this as well.

EDIT: I just saw that if you enable “Lock and Leave” mode, it enables you to lock with single touch.

1 Like

I’m guessing you have a Schlage lock?

On the SmartThings app ->
Click ‘My home’ ->
click ‘Things’>
<find your lock, click on it>
Tap on the tile ‘Lock & Leave’ slowly (about 5s apart) until it reads ‘Lock & Leave Enabled’

It may truncate the text to fit the tile to show something like “Lock & Leave En…”

1 Like

I’m having a huge problem with my BE469 Schlage lock.

I was able to install Lock Manager, and get it running. I’ve tried to add 4 sets of user codes. This is where I get into problems:

  1. 2 codes only ever seem to get set in slot 1 and 2. Users in Slot 3 and 4 can’t get set and I get the common error people report about failure “Controller failed to set code for [user]”.

  2. Commonly, my SmartThings Lock Manager app section forgets my lock. It just disappears and I have to keep readding it. After I do, the codes are all not set.

  3. I’ve also noticed on the smartthings IDE, my hub keeps getting forgotten as well (this probably explains #2). In my SmartThings mobile app, my devices and hub seem to be fine there so the hub is clearly connected and reporting things to the cloud. Not sure what the heck is going on.

Any suggestions?