[RELEASE] Lock Manager

You should give Lithium Iron Disulfide batteries (primary Lithium) a try, they are awesome but they’re expensive in the US but they last twice as long as Alkaline with a much better voltage discharge curve.

Check out this post for a comparison between batteries:

2 Likes

good to know for when I try different batteries but I put the current set in over a month ago and the battery level still says 15%. The other batteries stated 100% until they died. So, I’ll try one more new set of batteries, I’ll even volt check them first. And wait a few days. If I still don’t see a change in battery status, I’m not sure what the next step would be. I checked logs, even refreshed in app, never any errors. Just the warning flag in app on the thing is annoying.

I might pick up a pack for my presence sensor project this weekend.

I had a bit of a time figuring the app out, but I love it now.

I set up multiple codes for members of the family and Made an automation that gives them access to the house and also dissarms the alarm all at one time.

Then I created another code for “lockup” that is universal so that any user can enter the code into the lock after they leave to re-arm the system. I very briefly unlocks the lock and then locks it back as it switches from unarmed to armed.

Thanks for your hard work to make this.

2 Likes

First off I must say this been working great on 2x Schlage.
Is there a possibilty or maybe a future option to disable SHM when a valid code is entered?

update…please disregard i found it. thanks

Must say tho, there is a very long delay before SHM is Disarmed

Erik - I am new to Z-Wave systems. Would you be able to offer a list of some deadbolts (make/model) that are compatible with remote codes and working well with your code? I am setting up a new system and this info seems very difficult to track down. Thanks!

Not sure if I am in the right place or not. I seem to have two issues and I assume they may be related but not sure.
First - Kwikset 916 is installed. Installed Device Handler, set to Zwave Lock Reporting, installed Lock Manager from this thread.
From My devices in App, I can unlock and lock the deabbolt however the status does not change. It just shows unlocked.
debug shows fail to set device or lock rejected last request.

Second issue is when sending user/code to device I get a reject there too. Code does not work on lock either.Any ideas?

83d72633-8e53-4124-9a21-8eecc6a8b438 1:57:37 PM: debug "zw device: 0C, command: 9881, payload: 00 22 02 00 " parsed to [‘displayed’:true, ‘descriptionText’:Front Door Lock rejected the last request, ‘isStateChange’:false, ‘linkText’:‘Front Door Lock’]

83d72633-8e53-4124-9a21-8eecc6a8b438 1:55:15 PM: debug "zw device: 0C, command: 9881, payload: 00 63 03 01 00 " parsed to [[‘name’:‘codeReport’, ‘value’:1, ‘data’:[‘code’:’’], ‘descriptionText’:Front Door Lock code 1 is not set, ‘displayed’:true, ‘isStaeChange’:true, ‘linkText’:‘Front Door Lock’]]

83d72633-8e53-4124-9a21-8eecc6a8b438 1:55:15 PM: debug code report parsed to [[‘name’:‘codeReport’, ‘value’:1, ‘data’:[‘code’:’’], ‘descriptionText’:Front Door Lock code 1 is not set, ‘displayed’:true, ‘isStateChange’:true, ‘linkText’:‘Front Door Lock’]]

Installed everything on my Schlage Connect yesterday and it seemed to work great. Added 3 users and codes, limited one user to certain days and timeframe. All codes tested and worked successfully; app reported everything properly. However, this morning, the keypad is totally non-responsive. No lights, no ability to press digits…but, I can lock/unlock from ST app… Any ideas?

Hopefully just the keypad is locked. If you are using garyd9’s DTH, you can enable the keypad through ST. I don’t own that lock so I’m not sure what the manual process is. On my Yale, there is a privacy button on the inside.

I had a similar issue with the same lock and it turned out to be a z-wave routing issue. I could use the keypad when I put fresh batteries (or even took the batteries out and back in) but within an hour the keypad would go totally dead while still having control through ST. I left it for awhile and then for different reasons replaced a zigbee switch with a z-wave switch. This must have triggered a z-wave network heal because the keypad started working. I’ve ran a few more network heals just to be safe but the problem hasn’t come back now after a few weeks.

1 Like

I’ll try the network heal later and report back. Thanks for the quick response!!

i added the 3 apps and 1 device hander but there is no lock option in my devices

Ran several heals, but it didn’t correct the issue. I just pulled the batteries out and put them back in and the keypad works…for now. I’ll wait for a few hours and see if it locks again. Anything else I should try?

@ethayer - have you seen this with the Schlages you recently received?

@StewieGriffen
I have several of the locks and so do many of my friends and family. This is what I suggest. Exclude the lock and do 2 resets on the lock. Then Include the lock again and I bet you won’t have anymore issues.

i tried removing mine, network heal, factory default and no change. will lock and unlock but always shows unlocked. push config to lock but it does not take them. i wonder is there maybe a different device handler i can try? not sure where to go.

Hi, I’m new to smartthings, but have recently installed this app and love it. I’m just having one issue with the notifications/lock status and looking for some advice.
I’m using a schlage fe599 and my lock was previously set to auto-lock a few seconds after a user code is entered (I had verizon/Nexia a few years ago) and I like that feature, but now when I enter a user code, it’s like the app doesn’t recognize that the door has been locked after. I have to hit the refresh button to get it to say it’s locked again. Not a big deal, but what I’ve noticed is that since the app thinks the door is unlocked, when someone uses a code to get in, I won’t receive a notification.

Sounds like a DTH issue, not necessarily the app, but I might be able to make a work around… by automatically asking for a refresh on a lock after a certain number of seconds after a lock was unlocked… say 1 minute?

2 Likes

The FE599 firmware has a bug in it, it’s supposed to send a lock notification after an unlock and subsequent relock action (automatic) but it doesn’t. The stock ST DH doesn’t handle this and requires a patch in the DTH/custom DTH to handle this situation or as you pointed out manually refresh the state of the lock. Downside being the obvious it increases the overhead/battery life depending upon how often you unlock/refresh it.

Curiously what’s the battery life on your FE599 and how much do you use it? Asking because in our lab I’ve seen the FE599 battery life vary hugely between pieces.

@RBoy,

I see you charge for your device handler. Do you think it would help resolve my issues?

Probably not. Not that the paid DTH isn’t great, but It sounds like your devices are having communication issues with the hub.

Is your hub a large distance from your locks? Try pairing one of your locks very close to the hub, test it, then move it to its final spot.

You may need to add a powered zwave device between your lock and hub.

Also make sure the lock is paired with a secure inclusion. If the hub says something like ‘secure inclusion failed’ it will not work, and you’ll have to try to pair again.