[RELEASE] Lock Manager

smartapp_locks

(Bill) #893

This is a great app, thanks! I have a question…

I keep getting my main account locked out. “This user has been disabled. Reason: Controller failed to set user code.” I reset the setting for the user and the code works once, then locks out again. The only thing I can think of is this is the same code that I put on the lock itself when I programmed it. It’s a Schlage lock. Anyone had this happen?


(monty ferdowsi) #894

I think I got most everything that was needed to get the “Lock Manager” installed. Now when I click on my lock from Lock Manager app to show all the slots and program code it basically has an X next to all and Pending refresh note for all codes that were manually programmed on the lock. The only that show are the two that programmed via Lock Manager.

Any idea how to make the Lock Manager read the current lock codes and manage them?


(Kavery3141) #895

I searched for this before asking, but couldn’t find the specific issue, so if this has been addressed, just smack me. First of all, thanks for this, very cool. The install guide was great, and the app is fantastic. I did notice that Alexa can lock the door with a voice command through ST, but when I include locking the door in a routine, Alexa won’t run the routine and the notification states that it is because the routine includes a locking or security device that are unsupported by Alexa…I find that odd. Any insight?


Schlage 498 with lock code manager strange issue
#896

By default, Amazon has chosen to prevent the unlocking of doors. Since the Echo can respond to anyone’s voice, if you say left a window open someone could yell in to unlock the door.

As far a I have heard the only official lock that can unlock is the August through their Alexa app. But the invocation is not as natural as you must “ask August” and you must present an unlock code.

For SmartThings, Ask Alexa can be used which will work the same as how the August does above and offers a whole lot more.

You can also create a virtual switch that you toggle on/off and connect it with your lock through something like CoRE. Just remember that anyone who can talk to your Echo can then unlock (turn on/off) your door.


(Kavery3141) #897

I think you may have mistaken my observation. This is a “Lock” command. It
will lock via ST when I say “Alexa, lock the door”, however, if the lock
command is part of an Alexa triggered ST routine, it will not. Such as when
I run “Goodnight” i built the lock command as part if that routine and
Alexa refuses ti lock it. I just found that odd that it runs the lock
command when I tell her directly, but not as a part of a spoken routine.
Wondered if I was missing something.


#898

Ah yes. Any routine with a lock or security setting is unusable with the Echo for security reasons (unlock, disabling security). Unfortunately, there is no differentiation with routines for lock vs unlock and Echo usability. Maybe there will be in the future.

I have gotten around this with CoRE. Take the lock out of the routine and have CoRE lock it when the routine is executed. Or you can use the newer version webCoRE.


(Kavery3141) #899

That makes sense. I did spend last night getting my feet wet with Ask
Alexa. I’m not a coder by any stretch but was able to get it configured and
get the Lambda and Amazon Dev skills set up. It seems to be working well
with the lock and garage door opener. I ended up just making a duplicate
Alexa skill and using a special invocation name and only associated the
lock and garage with it, then use the other invocation name for everything
else. So I kind made two Alexa skills run from the same Ask Alexa app and
have a secret word to control the secure stuff. So far, so good. I’m going
to study that link as well. I’m new to this, but kind of like a kid in
candy store.Thanks for the info, and for the awsome work on the locks.

Cheers,
Ken


(Ryan) #900

Having mostly success with lock manager and really appreciate it! I was wondering if anyone else has run into the issue I am having. I have included a couple locks in the “I’m Back” routine and that seems to work. My issue is that if I unlock a lock manually(even one not in the I’m back routine) it automatically triggers the routine and an unlock command is sent unlocking the other doors.

Thanks for any help you can give and I am off to donate to Erik for all his hard work so far!


(Bill) #901

I’m still having some issues with this…for some reason, the main user keeps locking out.

I reset the lock to factory, then added the code. It works fine when the door is open and I lock/unlock, but for some reason when I open it from the outside, it locks the user out. Any thoughts?


#902

The Lock Manager app has been working great ever since I first installed it. But yesterday, I feel like it stopped communicating with the hub. Let me start off by saying the lock is installed in a vacation rental that we manage.

The last notification was yesterday afternoon when someone unlocked the door with a code. But that’s where it all ends. The person locked the door when leaving but I don’t see that in the “Recently” list. The door still showed as Unlocked and trying to issue the lock command did not work. I had someone check on the door and it was in fact locked. She also entered all the codes which still worked but it’s no longer notifying me or reporting any activity in the app.

I logged into the Developer portal and the lock shows up as OFFLINE. Is there anyway to bring it ONLINE remotely?


(Mike King) #903

@jacintoj That isn’t so much a Lock-Manager thing as it is a Z-wave thing. You can try running a repair zwave operation, it might help:


#904

My lock is a Zigbee type. Any tips on those?


#905

To reset your ZigBee mesh you need to take the hub offline for at least 15 minutes. I’m not sure how to do that remotely. There is no way I know of to disable the ZigBee radio temporarily either. Perhaps support could do that for you.

The other thing to check is that unsecure rejoin is enabled. If a device loses connectivity and tries to rejoin, secure rejoin will prevent it.

Also it’s possible there is some type of interference that recently began. Perhaps a new WiFi channel of a neighbor. If that’s the case you may need one or more additional ZigBee repeaters to try and compete with the interference. Even new batteries could possibly increase the signal strength.


Home security use case, best practice (?)
(Hernan) #906

I want to set ST for home security. Got not one motion, one door sensor, lights and the Shclag door lock (soon a siren).

I thought I try the ST Smart Home Solutions. Setup was easy, so I can get the motion to trigger a “event” and lights go out. cool. But:

How do I make it so it auto disarms when I enter the keycode? (any key code, don’t make me do it for every user). Is the best practice to trigger routines? feels scary to set a routines that disarms the security state, I would think there is something more direct, but I think I am missing it.


(Keith Wheeler) #907

I have a Samsung Smartthings and a Kwikset Smart Code 910. I am trying to set the codes for the keypad on the lock by using my phone/app… I have it the smart app and device downloaded and I can use the smartthings app to lock and unlock the lock. I can’t seem to get the app to change/add the keypad codes. How do I find out what I’m doing wrong?

I can not get the app to learn the codes.


(Keith Wheeler) #908

Did you get this figured out? I cant get mine to learn any codes at all.


(Eric Olson) #909

Hi,

( Sorry I see this was asked above, but no solution I have seen yet )

New to Lock Manager, thanks so much for the work. It seems like most of the functions I need are working from the automation tab. However from the main app area? it does not seem to be working quite right. I get Alarm Mode Loading… Auto Lock Loading… etc.

Any tips? I’m running a Schlage Connect. I believe I have followed the guide correctly and have the right smartapps installed.

FIXED - Just keep tapping on the panels as mentioned above until it loads.


(Derek Murphy) #910

Hi all, not sure if this is the correct thread to ask this, and I’m sure it’s been asked and solved many times but there are a ton of comments on this thread and I haven’t been able to find an answer.

I just installed my Yale yrd210 zigbee lock and looked into DTH and smart apps to get it working to the best of it’s ability. I believe I installed everything correctly, I’m using the Universal Enhanced Zigbee Lock DTH and the Lock Manager smartapp with it’s child apps installed.

I have not been able to update any codes yet. I deleted all the codes that I physically added to the lock and when I add more codes in through the app I get nothing. After a few minutes if I look at the lock slots it will say “controller failed to set user code”.

Anyone know what I’ve done wrong here? Thank you in advance for your help!


#911

Have you changed your lock device to the new DTH? You need to go into devices, select your lock, click edit, then select the Universal Enhanced ZigBee Lock DTH at the bottom of the list. After that select save. Then to be sure the DTH installed correctly, select force reconfigure in the phone app for the lock.


(Derek Murphy) #912

Thanks for the reply. I have the universal Zigbee DTH installed. It says so on my device list and I also have the ability to change sound, auto-lock, pricey, ect…