[RELEASE] Lock Manager

Only locks I’ve ever used.

As @jays said, when I updated from old app to Beta I screenshotted all my lock codes ( in case they got lost in the move) . Installed the new app/DTH through GtHub integration. Deleted the old apps and DTH from IDE. Then went into new app and programmed all the lock user codes into new app.

Stuck in child app loop sounds to me like the child app didn’t get installed ( or published ) correctly. Then again I AM NOT A PROGRAMMER/CODESLINGER so I am usually wrong on these types of things :wink:

@ethayer:

First of all, excellent application, next to CoRE, these APPs make SmartThings 100% productive. I have only a few custom routines that I am phasing out, since over the last 3 years, applications like User Lock Manager and now Lock Manager have been created.

I might be late to this Lock Manager discussion thread, but I just wanted to let you know that the “Global Settings” for notifications do not appear to affect all users as I had expected. I have 6 users defined without any notification settings and global settings of notifications of unlocking and locking did not send SMS or notifications.

I was able to individually set notifications and SMS on for each defined user, and now the Lock Manager APP is performing as expected. I do not get a notification message when the lock is manually opened or closed which would be nice.

Also, do you recommend CoRE for auto-locking the lock when a door contact sensor indicates that the door is closed after a period of specified time? I am using CoRE now for basic auto-locking after door closed, but just wanted your opinion?

1 Like

I just pushed some code to support keypads. This is implemented using a new child app ‘Keypads.’

It has come to my realization through writing the support for keypads that locks should also become a child app. This will allow me do offer things like linking a open/close sensor with a lock and automatically locking the door using a certain number of conditions and so on.

Were you using contact book? This should be fixed now… it’s working for me at least.

Working on this. Shouldn’t be too difficult but I ran out of time this weekend.

5 Likes

@ethayer: I do not have access to (or perhaps I have not enabled) the ‘contact book’. Is this something that I enable, load, etc? Let me know!

Thanks for such a quick response.

I’m not sure. It’s just on the app. Maybe it’s not compatible with Andriod or maybe they have some strange rollout process… It’s fairly intuitive though.

ST rolled out contact book and then pulled it pretty quickly. So if you got it during their roll out you got to keep it. Some people have figured out a back door to get it. Be warned if you enable it, you lose hub offline notifications.

Hmmm … I strange, I still get offline notifications with My Contacts enabled.

Uploaded a quick iOS walk-through of the Smart App interface, https://www.youtube.com/watch?v=IgwI1RB_fpY

Thank you for the efforts!

1 Like

I haven’t tested it lately, but last time I talked with support (8/16) about it they confirmed it was contact book that was preventing me from getting offline notifications. didn’t mean to side track the thread just wanted to point out that contact book isn’t officially supported right now.

1 Like

I went to check on the availability of the ST Contact Book on my iOS device, and voila, it has been activated. I have deleted all the individual notification settings for each user in Lock Manager and am I testing the global setting for notifications. I was able, for the first time, to create a contact user in the contact book.

I was using my Amazon Fire for accessing Lock manager and I suspect that the Android O/S ST version might not have this contact book ability.

@greg Thanks for providing the URL for the online contact webpage. I was able to access the ST contact webpage and was noticing that my “notifications” default value was set to False. I was able to edit my contact record and set the value to ‘True’. What does this ‘notifications’ value allow by default? Also, is there a way to use the contact book in other ST APPS or does the developer have to “enable” it in the application?

After setting this value to ‘True’ this is the message I received on my phone.

Kurt Sanders has added you as a contact in SmartThings. As a contact you will receive text alerts from
Kurt Sanders’s home monitors and controls. Text back KQEPMRD to opt-out of receiving these messages or “Deny” to opt-out of all SmartThings text messages.

Hello Ethayer.
I am using the new app that was posted around November.
As stated prior…
I am unable to delete codes. When i replaced a code with another it still works on the lock.
Burn and Schedules also do not work.
Able to enter a code though and get confirmations.
Thank you
Ryan

When i tried a burn test I set 2 unlocks. My phone did notify me saying the passcode was going to be burned but the code continued to work. Each time i opened the lock i received the same burn message/notifications.

Side note: how exactly do we donate? your time and effort is appreciated.

Thanks for your interest in donating. The old app had a donation link, but since I wrote this one I haven’t had time to create a readme and create a new link. I will soon! And then push v1 of this app also.

I’m not sure if this applies to the kwikset916 you’re using, but is the code to burn in slot 1 or 2? Some locks don’t let the user set these two slots to null, but slots 3+ can be deleted.

Currently there’s an outage at Amazon AWS, which I suspect SmartThings uses for some or all of it’s backend. This is probably causing ST service outages. I cannot access ST IDE or ST at this time.

I attempted slots 3 and 4 due to that possibly being an issue. same result though.
I do see that smart things app has recently stopped responding.

back up. let me know if any suggestions. once i can delete these codes i’ll be up and running with finishing out the smart home. this has been the last piece.

I just used the burn functionality and it worked. Have you updated recently?

Sorry but i can’t seem to find how to install the custm device type.

I have. I just set the permissions to burn after one try.
Still just keeps on working though.
Feel like so close to it working perfectly!

any suggestions? i’ve reset both the hub and kwikset 916. using slot 3 for that code that I entered from the app.