[RELEASE] Life360 - Refreshed Every Minute & All Places & More UPDATED 01/01/2019 All API Data available for webCoRE Usage

Yup correct

Also for a example of leaving a life360 place, I do if address1 changes to “No Data” and prevaddess1 is not “home”

This means that I have left a life360 place that isn’t home I then send a WhatsApp message to me asking if I want to put the heating on.

This is a smartthings thing nothing to do with this app

I feel stupid. Can we pretend like I never asked it?

Thanks!!!

Thanks, tried it today and it worked perfectly. However, in my system address1 changes to street addresses and address2 is the city where ever I am located so I never get the no data, I think that’s a United States only behavior and you get the no data in other countries

Also one small thing is the address fields are pretty big fonts so I can’t see the full address, I think I will go in and change it to a smaller font

I’m just starting to set this up now, since it appears the webcore presence no longer works. How can I say in webcore “when leaving work”? I only see address 1 and address 2.

Thanks!

So in webCoRE your best bet is

If address1 changes away from work
The UK is different to the US so this is just guessing I believe if you set a location in life360 for your work and call it “work” it will appear in address1 while your at that location

Thank you. A few things I noticed:
1.Clicking on the presence device on the new smartthings app doesn’t work, only on the classic. It says “can’t connect to device.check device and try again.”
2. While driving, the presence sensor did have the correct mph, but still said I was not driving.

Any help would be greatly appreciated.
Thanks!

The driving api doesn’t seem to be working any more. It stays false during all my testing during the last few weeks, it definitely worked when I first wrote this app.

I dont use the new app and won’t install it until smartthings kills the old app

Thanks for the update!

hi - very impressed with the app/dh - the amount of data made available is fantastic. I use a time-series database to store all the updates in my SmartThings devices. I can see the standard capabilities on the Life360 devices (battery, presence, etc.) but the lastActivity attribute is stuck at the time that I installed the devices and never updates. This means that the always get written to my database with the same timestamp. Any ideas?

LastActivity should be be the last time your device has contacted the life360 servers

You can see all the life360 by going to the following place in IDE
My Locations > Smartapps


Scoll down to Life360 (Connect) and click on it

Under members there will be all the data pulled from Life360 users

Thanks for responding. I removed and reinstalled everything to see if the problem continues. I still have the problem. I can see that events are being passed - the data is updating in SmartThings. However, the “Last Activity At” never updates. You can see my device - the lastCheckin updates as do all the other states but the “Last Activity At” remains equal to the “Date Created” and “Last Updated”. This is true for both the devices I have:
image

Is this normal behaviour or I am having a specific problem?

I have two methods of collecting data from SmartThings - one pushes the data out when events happen - this seems to be okay as the timestamp is generated by the event. The other is that I poll SmartThings, and here is where the timestamp always remains with the “Last Activity At” timestamp (I’m calling .lastActivity, which works for all other devices).

I understand now

Mine is working fine not sure why yours isnt

Hey - thanks for letting me know. At least I can try to investigate why it isn’t working for me.

Hi all!
I’m loving this DH and the additional info is really useful but I have a logging (influxdb) question.
I can see only Battery and Presence logged - confirm I can see all the states under each device in the ST IDE. Can I get all the other states to log to influxdb?

I am getting this same message “Something’s wrong we can’t load your screen right now” when I try to open the Life360 (Connect) smart app. I want to open it so I can delete the smartapp to try this new code. I was able to delete the presence sensors I had previously installed. I just can’t get into the smartapp to hit the remove button. I also looked in the IDE and did not see LIfe360 listed in the smartapps to try and remove it from there. What else can I try to delete the app?

Just to confirm, I’m also experiencing a similar issue, it appears that the classic app won’t allow me to remove the life360 smartapp installed from the marketplace.

Now, i do have the presence sensors that this device creates integrated with both webcore and actiontiles, but I don’t see why that would be an issue.

Any help?

(Note: my issue occurs when I hit the ‘remove’ button in the smartapp.)

ok, for anyone else encountering this, you must remove all references to the user devices from all pistons and smartapps before the system will allow you to remove the life360 smartapp.

I got the new SmartThings app to work with this code by adding the following to the metadata line:

, mnmn:“SmartThings”, vid:“generic-arrival”

I had to remove the devices and re-add.

Can you update your repo on Git with this update?

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.