SmartThings Community

[RELEASE] Leviton Decora Z-Wave Plus Dimmers (DZ6HD & DZ1KD)

leviton
dth_lighting
(Paul Grillo) #142

I upgraded in this way and all of those problems disappeared.

Now the big question that maybe somebody can answer is whether the stock ST dimmer handler will suffice. don’t get me wrong, I prefer this custom handler. but until they allow custom handlers to run locally, it is not my preference. this handler is the only remaining item preventing all my devices to not require the cloud.

can somebody confirm the “bugs” this handler fixed, leaving aside the enhanced features?

0 Likes

(Gonzalo Parra) #143

I migrated all these to Hubitat but before that, I was using the stock dimmer device handler for the exact same reason (wanted local execution) and it was working fine… I was only using the custom driver to configure the settings and then changing it back… you can really feel the difference in the speed…

0 Likes

#144

What is the latest Leviton firmware version Z-flash has?

Is there a tutorial somewhere?
Thank you!

0 Likes

(Jason) #145

Z-Flash User Guide: http://help.homeseer.com/help/Z-Flash/static/

The user guide has the included firmware listed here: http://help.homeseer.com/help/Z-Flash/static/#.firmware_included_with_z_flash

2 Likes

#146

Finally I bit the bullet to upgrade my switch firmware to 1.20 through Z-Flash. Overall I feel it’s worth the hassle, though it’s unfortunate we have to spend money for a firmware update that mainly just fixes bugs.

Most of the original issues have been addressed by the new firmware, so some of the workarounds in my original DTH are no longer needed. I have updated this DTH to work with both firmware versions. With the new firmware though, the value-add of this DTH is mostly around UI and configurations now.

For those interested, I used the Z-Flash software with a HUSBZB-1 stick and it worked fine. Didn’t need to buy the HomeSeer stick.

2 Likes

(Kirk Hilzinger) #147

I use your device handler. Is it updated in the repository where I can update it? I, too, have upgraded to version 1.20.

0 Likes

#148

Yes the DTH is updated in place. You can follow the usual steps to update from github.

0 Likes

#149

Just wanted to provide some feedback on your custom Leviton device handler. I recently purchased a leviton DZPD3 and had the problem where it would not remember the last dimmer setting. Even though your handler didn’t indicate this model, I gave it a try and it works great. It made my day. Thanks.

0 Likes

#150

Glad to hear it works!

0 Likes

(Jerz Dude) #151

OK… bought the Z-FLASH-KIT and it is truly a pain in the effing rump. I’ve got a bunch of the Leviton Decora Dimmers to update… is there a tutorial somewhere because I am getting nowhere. I’ve got the z-flash software installed but the HS3 web interface is giving me issues:

HTTP Error 404.0 - Not Found

The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

Most likely causes:

  • The directory or file specified does not exist on the Web server.
  • The URL contains a typographical error.
  • A custom filter or module, such as URLScan, restricts access to the file.

Things you can try:

  • Create the content on the Web server.
  • Review the browser URL.
  • Create a tracing rule to track failed requests for this HTTP status code and see which module is calling SetStatus. For more information about creating a tracing rule for failed requests, click here.

Detailed Error Information:

Module IIS Web Core
Notification MapRequestHandler
Handler StaticFile
Error Code 0x80070002
Requested URL http://192.168.7.71:80/deviceutility
Physical Path C:\inetpub\wwwroot\deviceutility
Logon Method Anonymous
Logon User Anonymous

More Information:

This error means that the file or directory does not exist on the server. Create the file or directory and try the request again.

View more information »

0 Likes

(Jerz Dude) #153

Nevermind… I figured it out. I had to delete my Honeywell Lyric as a secondary controller first. After that the usb stick was able to act as the secondary controller and it found my devices.

0 Likes

(Jonathan Cook) #154

If I have just bought my first Leviton Z Wave Dimmer switch, and plan to use it with a ST v3 hub … am I further ahead to just return it and go with GE, Zooz, or Lutron instead given this issue?

Thanks

0 Likes

(Ron Czapala) #155

@jasonxh

I discovered something interesting. I used your device handler for two DZ6HD wall switches so I could set fadeofftime, etc. Then I realized that the execution location was changed from local to cloud (since custom device handlers can’t run local).

Since I use Smartthings buttons and Smart Lighting routines, since they can run locally, I changed the device type back to “Z-Wave Dimmer Switch Generic” and now they are local again.

The interesting part is that the custom configurations like fadetimeoff still appear under “Preferences” in the Groovy IDE and even under the Classic app (although without descriptions) and can be modified.

0 Likes

(Bradlee S.) #156

Correct. This is true of any device that stores parameters. You can use a custom DH to set these parameters, then switch back to a default DH for local execution. The device will continue to process the parameters at the hardware level.

Even further, devices capable of direct associations can be set up the same way. For instance Jasco/GE/Honeywell switches and dimmers can be associated directly with other devices to trigger them without the need of the hub at all (once set up).

1 Like

(Jeff Andre) #157

I just purchased the HUSBZB-1 stick and Z-Flash to do exactly this. I’m having trouble getting things set up, though.

Since there are no built-in drivers for this stick, I downloaded and manually installed the CP210x drivers, but Z-Flash doesn’t seem to see the device.

What am I missing, here?

0 Likes

#158

I assume you downloaded driver from https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers. What I realized is that their most recent driver for “Windows 10 Universal (v10.1.4)” doesn’t work with the HUSBZB-1 stick (yes I’m on Windows 10). You need to install the driver for “Windows 7/8/8.1 (v6.7.6)” instead.

0 Likes

(Jeff Andre) #159

I was in fact trying to use the v10.1.4 driver. Didn’t think about trying the older one. On another board I had the following reference:

“For those having issues with Windows 10, I was able to finally get mine working. I had found another post on installing Axail server and grabbing the HubZ drivers from there. (Z-wave Switches Failing) I had to install using the “Unsigned driver” procedure. Not sure if HE uses different sticks, but the drivers listed here did not work. It would really be nice if Hubitat posted a link to the right drivers for the stick on their web site. I lost about 6 hours trying to get it working.”

This did work - I cannibalized the drivers folder from the Axail installation (then deleted Axail), and loaded the HubZ drivers - worked like a charm but they are unsigned. I’d rather be able to load signed drivers, so I’ll try swapping them out for the ones you suggest.

Thanks

0 Likes

(Jeff Andre) #160

Also, as a follow up - the whole reason for me doing this was to update my Leviton switches to 1.20 due to drop-outs, lack of status updating, and general flaky behavior in using these switches as triggers for any automation.

Initially, none of my Leviton switches were showing up in Z-Flash - they showed in the node inventory log, but were unresponsive, so not available to update. After killing the breaker they are on and “rebooting” them (they don’t appear to have an accessible air-gap mechanism) They did show in Z-Flash, and I updated them successfully. After that, they appear to be once again working properly. In fact, they appear to be responding faster than they were even when I installed them and they were working, before this issue cropped up.

All in, definitely worth the effort to update them - even with the frustration getting the USB hub working.

1 Like

#162

hey @jasonxh,

Does this work with the v3 hub? I tried and it didn’t seem to work. Just curious.

0 Likes

#163

I don’t have a v3 hub, so I cannot tell. But if they share the same app and cloud IDE, I’d be surprised if they are not compatible. What problem did you run into?

0 Likes