SmartThings Community

[RELEASE] Leviton Decora Z-Wave Plus Dimmers (DZ6HD & DZ1KD)

leviton
dth_lighting

(Bradlee S.) #122

I don’t believe SmartThings has any path in place to push Zwave updates even if Leviton provided an update to them.


(Gonzalo Parra) #123

I agree, the only one that can really say is @Kianoosh_Karami and I doubt he can commit to anything or that the feature is coming soon…

I would recommend you bite the bullet and use the HomeSeer Z-Flash with their USB dongle or one of the confirmed working ones (Zooz, Hubitat, etc.) to upgrade the firmware on your devices, no point on continuing to suffer when there is a somewhat cheap solution that will fix these problems for you…

Long shot, but if you live close in Mississauga (Canada), I could lend you mine…


(Kirk Hilzinger) #124
Two Weeks GIF from Twoweeks GIFs

#125

I did the HomeSeer Z-Flash and it made all of my dimmers much better. $50 for alot less frustration was worth it for me.


(Dale Munn) #126

Hi, had trouble adding leviton switch. Wouldn’t find your device handler and the one that it did would mess the switch up. Could you add
fingerprint mfr:“001D”, prod:“3501”, model:“0001”, deviceJoinName: “Leviton Decora Z-Wave Plus 300W Dimmer”
to your handler.
Thanks


(Boston) #127

Hi, I had some trouble too, but worked out my problem. I’m sharing to help find a fix.

Some background: I have two locations and two hubs. I have an older v2 samsung hub and the latest v3 samsung. I just added 3 DZ6HD dimmers to the v3 samsung hub and it worked with the default “Z-Wave Dimmer Switch Generic” type. When I switched to use jasonxh’s “Leviton Decora Z-Wave Plus Dimmer”, my smartThings app on my iPhone and iPad hung/crashed.

It turns out there’s a problem with the new SmartThings app and I’m guessing it’s the UI tiles jasonxh uses for the UI. When I switch back to the Classic App, it works just fine.

I was having problems with command echos using the default device controller, my wife threatened to have me rip them out! (They would toggle between 50% and 100% while she was trying to cook.) I just figured out the problem and so I have a work-around (using the classic app) and will be switching to jasonxh’s controller.

Thanks


(Bradlee S.) #128

Homeseer Z-Flash kit is on sale right now for $35.


#129

i don’t think the new app can do custom device handlers yet, can it?


(Bradlee S.) #130

Nope. Which is why no one should be using it until it’s complete.


(Boston) #131

Secondly, you shouldn’t be using the new app unless you’ve received a message specifically stating that your account is ready. Seeing that you are using a custom device handler, your account is not ready.

Seriously? “Shouldn’t be using the new app?” From this I gather you work for Samsung. I also want to point out that in a later post you say:

Yes there is a huge disconnect between support and engineering within most of these companies. That is simply a given.

Huge disconnect, yes. Why would you think folks would assume Samsung is able to and knows, tracks and communicates this level of detail with each customer. It’s much safer to assume that anybody playing with these devices would have already downloaded and started playing with the new shiny app without waiting for the “confirmation message” (which I did wait, for maybe six months until I just assumed the disconnect.) Better to communicate the status of the product development along with a roadmap of when such features will be available. If that was posted, I missed it.

Btw, I’m waiting for local execution of custom DTH’s, firmware upgrades for ZWave devices, and an app that supports custom DTH’s. Can you provide the roadmap plan for these features?


(Bradlee S.) #132

If Samsung wants to hire me, tell me where to sign!


(Boston) #133

touché Bradlee!


(Raj Srikrishnan) #134

How do you tell what firmware version is in the DZ6HD? I just recently installed mine on 10/29 and I’m now seeing the Offline issue, even though it never has problems responding to commands.

I’m trying out my first automation on this switch tonight, will see if the offline issue still causes trouble there.


(Bradlee S.) #135

graph.api.smartthings.com

Select location first, then go to devices. Found the switch, and check in it’s properties.


(Gonzalo Parra) #136

Please note that the version listed there in the api will not update after you upgrade the device’s firmware, that string only gets registered when you include the device for the first time. It does not really matter as you’ll get the bug fixes anyway but if you are anal like me and want this updated the only way to do it is to exclude and include the device again…


(Raj Srikrishnan) #137

I see that mine is v1.13. Obviously not upgraded, even though I just purchased from Home Depot on 10/19.

Do you think the functionality of firmware updates will ever work in SmartThings Hub v2? Am I forced to buy the HomeSeer ZFlash to fix this Leviton issue?


(Bradlee S.) #138

If you’re in the DC area, I have Z-Flash.


(Raj Srikrishnan) #139

I’m in San Diego :confused:


#140

What are our options to do the upgrade?


(Gonzalo Parra) #141

No one knows if / when ST will have Z-Wave firmware update functionality… Anything ahnyone says other than ST Staff is just speculation and they will not say either…

I recommend bitting the bullet and buying Z-Flash to do it, it’s well worth it and it’s on sale right now, only $15 of you have a compatible usb Z-Wave stick, or $35 + shipping for the combo.