SmartThings Community

[RELEASE] Leviton Decora Z-Wave Plus Dimmers (DZ6HD & DZ1KD)

leviton
dth_lighting

(Gonzalo Parra) #102

Yes, I use it for one I have and works well…


#103

Thanks for the reply. I’ll give it a try.


#104

So I built a new house, and have about 40 leviton smart switches in it, mostly DZ6HD-1BZ and a few DZ15S-1BZ, with several of those having remotes for 3 ways. I set the dimmer switches up to use this custom device handler.

I’m having some issues with several of them where the on/off status of the switch is not reported correctly. Smartthings can toggle the dimmer thru scenes, or it can be done manually, but the app always shows it as on. Any idea how to fix?


(Blaine M) #105

This is a well known issue. We believe that Leviton has firmware to help, but they won’t send it to you and SmartThings doesn’t support OTA firmware updates for Z-Wave devices.


#106

I was actually able to fix this last night by using the air gap on the switch. It might only be a temporary fix though, because one of the switches did have the issue again a short while later, but the other ones have not.


#107

As nice as this custom device handler is, for whatever reason it seems to allow the firmware issue you are seeing to occur way more frequently than using the “Dimmer Switch” handler. I’ve been using the built-in “Dimmer Switch” device handler for about 8 months now and have seen this issue maybe once and I have 9 dimmers.


#108

So, it possible to buy another device and use that to upgrade the firmware on these leviton switches?


(Kirk Hilzinger) #109

You can get the Homeseer Smartstick+ and software license for Z-Flash and it comes with the firmware for the switch and dimmer.


(Gonzalo Parra) #110

Hi All, this is to confirm that flashing the 1.20 firmware using the HomeSeer Z-Flash software does fix the problem of them not reporting status change when manually triggering the remotes…

I can’t believe these Leviton @#$@#$#*! had the solution all this time and didn’t share it with their customers, I have exchanged at least 10 emails with their support agents and managers, talked to them on the phone and they always said there was no solution yet and their engineers are working on it… The Z-Wave certification from 9/7/2016 does list the certified firmware as 1.20, the support manager from Leviton told me that it was the same firmware when it obviously wasn’t… I’m so pissed of about this whole thing yet so happy these things are finally working properly as I spent a lot of money and effort installing them… Last Leviton product I’ll ever buy for sure…


Problem with Z Wave Plus not updating status?
(Bradlee S.) #111

It seems though now that you have a solution to your issue with these switches, you’d probably want to purchase more.

Yes there is a huge disconnect between support and engineering within most of these companies. That is simply a given. Glad you’re issue is resolved though! Perhaps you could help others instead of ranting.


(Gonzalo Parra) #112

Well, I already spent about $3k on switches and dimmers and replaced all of them in my house so not sure why would I need more…

Also, sure I’m ranting but the main point of my post was to let everyone know there is a solution, so, what’s your problem? Do you work for Leviton?


(Bradlee S.) #113

$3k on switches!? If I had a house that large, I’d probably have someone else handling these issue for me.

Wish I worked for Leviton! Actually, I wish I worked for Jasco so I could get them to implement new features in their products as I certainly prefer them.

Like I said, congrats you found a solution to your problem.


(Kirk Hilzinger) #114

By my math, at $50 a pop on switches (and they are less when you buy in bulk), that is 60 of them.


(Gonzalo Parra) #115

About 50 of them although I have not installed them all yet… I do enjoy doing things myself just not enough free time… That’s Canadian dollars BTW, so about 30% more but equaly hard to make though… :unamused:


#116

Where did you get the firmware files from? Did it come with the HomeSeer software?


(Gonzalo Parra) #117

Yes, the 1.20 version comes bundled with the Z-Flash Software…


#118

Do you know if the software works with Aeon Z-Stick Gen5 to update firmware?


(Gonzalo Parra) #119

Not sure to be honest, User guide suggests it does (mentions the Z-Stick but does not say the word Aeon or specify compatibility… I have not tried it myself but I think I’ll work with most z-wave USB sticks.

There is a Zoos USB stick that specifically says it works with the Z-Flash software and claims to be the first stick to support the S2 security protocol so that’s a plus:

I would ask HomeSeer support to be sure, or if you already have the Aeon one then buy the software only and try it, you can instantly download and use it and if it does not work then buy the stick too and you only lost the $10 saving on the combo…


#120

The S2 stick works with both the Z-Flash software from HomeSeer and the Aeotec software update tool. Thanks for posting the link!


#121

I have been in contact with the Leviton support team.
They supposedly have been working with Smartthings to push this OTA firmware update to their DZ6HD line.

Every-time I contact them, I am told “yes, we’re on it, it should be ready in 2 weeks”. This has been going on since July… Maybe if enough people ping them they’ll actually get things moving