SmartThings Community

[RELEASE] Leviton Decora Z-Wave Plus Dimmers (DZ6HD & DZ1KD)

leviton
dth_lighting

#1

This DTH is for the Leviton Z-Wave plus dimmers (DZ6HD & DZ1KD). It improves over the generic Z-Wave dimmer handler in the following areas:

  • Fixes the bug where the device and SmartThings get out of sync when level is adjusted while the switch is off.
  • Fixes the bug where it always switches on to 99%.
  • Adds shortcuts to low/med/high levels.
  • Exposes advanced device configurations in the preferences page.

I’ve been testing this DTH on a DZ6HD, but everything should work on the sister model DZ1KD as well. Please let me know otherwise.

For easier updating in the future, you can add my Github repository to your SmartThings IDE: (FAQ: Github Integration How to Add and Update from Repositories)

Owner  - jasonxh
Name   - SmartThings-jasonxh
Branch - master

Leviton Dimmer advanced options - how to configure?
Leviton Z Wave Plus Devices Advanced Features
Need Help Making a Device Handler for Leviton DZ6HD Dimmer
Leviton DZ6HD-1BZ showing offline
[BETA] Leviton DZ6HD Dimmer Device Handler - cube1us
Dimmers remembering the previous brightness level
(Younggunna777) #2

Hello @jasonxh! I just started using your DTH and everything appears to be working flawlessly with my DZ6HD. Can you explain the 99% bug? When i tap the High button for example it turns the light on to 99% only. I can raise dimmer to 100% but am not sure if the high button should behave this way. Thank you in advance!


(Brent ) #3

Awesome thank you for your efforts! I still continue to be impressed by this community.


#4

The 99% bug was a different one. The generic DTH always turns on the light to 99%, irrespective to the previous level it was set to. The issue you noticed was a result of the discrepancy between zwave level range and smartthings level range. I’ve put in a little tweak to smooth it out.


(Younggunna777) #5

Just updated from your repo and the switch now goes to 100 and not 99 when hitting the High button. Thanks again!


#6

You are welcome. Glad it works.


(Chad Skinner) #7

Thank you for providing this! It improves on the standard handler significantly!


#8

I’m trying to link smartthings to the github repo but I can’t manage to.

Shouldn’t the settings be:

jasonxh
SmartThingsPublic
master

?


(Jay Jaeger) #9

I don’t think you can do it thaty way. When I linked github to smartthings, what I did was link using my github email address, etc. (I already had one because I had collaborated with someone on anohter project.) Then I created a SmartThings repository, and made it public.

They way to get jason’s code would be to use his link to github.


(Chris Guigliano) #10

Is anyone still having issues with these switches even after this new device handler is installed. I have reset to factory specs and changed the device handler to this but the switch constantly says it is offline. when i go into it if I change the dimmer level it kicks back up but fails to sync the status in ST.


(Jay Jaeger) #11

Did you install mine, or the one from jasonxh? If Jason’s I can’t speak to that. If it is mine, I’d suggest grabbing a copy of the Live Log and posting that, or messaging me with it. Also, which dimmer do you have? I expect mine would only match a signature from a DZ6HD, so I would not expect it to be selected if you have a DZ1KD.


#12

I’ve run into this once, when the device just doesn’t send any response to the hub, even though it seems to be taking commands just fine. It recovered after I power cycled the dimmer (breaking the circuit). Seems to be a dimmer firmware issue.


#13

Is there a custom DTH for the Leviton DZ15S / DZS15 ?


(Chris Guigliano) #14

thanks, i will give it a try tonight and update on success or not.
“Success is more a function of consistent common sense than it is of genius.” – An Wang, industrialist


(Chris Guigliano) #15

Thanks Jason so far the power cycle looks like it set it straight.


#16

Has anyone tried to fix the switch rattle?

My Leviton Z wave Plus switches are very lose and rattle. I’m OCD and that annoys me. I’m gonna try a bunch of different things to hope stop it.
Tape, glue, caulk, whatever it takes


(Mike) #17

My leviton switches are acting up. I am using this DTH for 4 of them, and all were working fine on day 1. Shortly after they all show “unavailable”. No matter what I try (reboot hub, kill app, reset zwave network,…).

However if I go in the switch settings then click done (no need to modify anything), then it becomes available and I can control them until I move out of this screen.

Anyone having these issues?


#18

Same issue here, both showing unavailable.


(Mike) #19

Same issue here


#20

I looked at the live logs, and the devices that show unavailable do not return anything back to the hub (regardless of the command: no confirmation/acknowledgment).
For example, here’s the refresh command with no answer whatsoever:
11:43:00 AM: debug Refreshing with commands [2502, 2602, 7204, 700501, 700502, 700503, 700504, 700505, 700506, 700507, 700508]

@jasonxh, does this never happen to you? Do I have bad switches?