[RELEASE] LANnouncer with IFTTT

My Lannouncer is on my network. The devicetype works and I can get speech synthesis working. However, I can’t seem to make it show up in my smartapp options. I have two VLCThings on my network using BigTalker. I wanted to add this device and it doesn’t give me the option. Any suggestions?

Did you install the SmartThings Device Handler, following these steps? Once that’s done, you should be able to see the device inside SmartThings.

1 Like

Yeah. Here’s my setup.



And here’s the problem

It works from within smartthings, but the device doesn’t show up as a TTS.

Same issue here, unable to get LANnouncer Voice Synth to show up in the latest version of Bigtalker. Anyone looking at this?

Quick question. I’m just getting started with possibly using this to replace my Ubi for IFTTT voice notifications. Since I can’t explain what I’m looking for, I’ll just give an example and go from there.

Currently, I have an applet that notifies me via my Ubi when my hockey team starts a new game using ESPN. What I really want to know is whether you can pass variables from, say, the ESPN “IF” to the MAKER “THAT” so that the applet is adaptable based on what the “IF” is saying. This way, rather than my LANnouncer saying “Buffalo Sabres game has started” (which I can program in using the speak envelope), it would say “Buffalo Sabres at Washington Capitals has started”.

Sorry if that was the long way around, but I couldn’t describe it up front without giving an example. Any assistance would be greatly appreciated! Thank you all!

I following this steps

Installing LANdroid/LANnouncer into SmartThings

http://www.keybounce.com/lannouncer/integrating-with-smartthings/smartthings-installation-steps/

After I created Device by IDE - Step 7, on Step 8 when I click “edit preferences” my screen is different

Then I try Step 9 - Do this by APP no Android.

My Home-Things I cant see this new device, I click +Add a Thing, show the screens below

I click save then

Please excuse my long thread…newbie just getting started.
So my house is light config is setup with Hue and Caseta which are controlled by Homekit/Siri and Amazon/Alexa. Works perfect.

Smarthing Hub I have doors and motion sensors config and working. This past week after lots of reading I installed Lannouncer on an Samsung S6 connected to a bluetooth speaker. I installed Bigtalker smartapp also. Works good.
Installed VLC thing also on a computer and connected another bluetooth speaker, this also works great.
I am using VLC/Bigtalk to announce open and closed door events.That all I need it for.
In SHM I have 2 problems.

  1. I am using Lannouncer as a Siren when my house is armed but the volume is very low. I set Lannouncer volume to loud but still. I even coonect my Lannouncer device wired to speaker and still low volume. Connected it to my bluetooth stereo receiver and still low volume… How can I increase the siren to be loud enough?
  2. Why am I only seeing lannouncer in my SHM config as only a siren? In the lannouncer thing I can test all the different effects( strobe, siren, speak, tone etc) and it works. I would like to atleast use tone and speak in SHM also.
    Thank you.

Hi folks… am I missing something obvious? I’ve got LANnouncer up and running, but I can only get it to give me the audio notifications when the android app is running in the foreground. If my phone has any other App up, or if it is asleep, it does not notify. Once I open up the LANnouncer App, then it catches up with all the notifications that come through at that time… is that expected behavior? (I’m on Android 7.0)

Can’t really help with a solution, but I can report that is not expected behavior. Mine, on three different platforms, speaks when LANnouncer is in the background.

A few ideas…

  • Don’t exit LANNouncer (don’t hit “back” until you’re out); just hit your Android home button (little button in the middle of the bottom of the phone with a circle or house on it), which should take you to your main phone screen, and launch another app. Or switch apps with the task switcher. But don’t exit.
  • Ensure LANNouncer is not “battery optimized” in settings. Really that shouldn’t matter, but under the conditions you’re having, perhaps it does.
  • As in the LANNouncer Trouble Shooter, ensure the network is set to stay on when the phone is sleeping.
5 Likes

Thanks!

I tried the first two things (made sure I wasn’t exiting, and I changed the “battery optimized” settings) and it works as expected now. Appreciate it!

1 Like

I can’t seem to connect to my Fire tablet. I put in the ip address and port and it just stays grey. I tried redoing the whole thing with no luck. It worked then my power cut out and it doesn’t work anymore.

One possibility - If the tablet did not have a static ip address, when your power came back up it may have been assigned a different IP address when it reconnected. I would verify the address of the tablet.

I got it to reconnect and was setting up some core pistons and big talker and all of a sudden can only use speak setting. Did I do that on accident maybe?

When you were setting-up/configuring Big Talker, did you set the switch on the first configuration page to OFF? It defaults to Music Player and not Speech Synthesis. For LANnouncer it needs to be on Speech Synthesis.

Could I do both? When it was setup to default music player it did speech and chimes. Could I maybe have two of the same device one setup as voice synthesizer and the other as a music player to get both benefitsm

I get spoken event notifications from Big Talker set to speech synthesis through my tablet with LANnouncer. I use CoRE to ring a chime on the tablet via LANnouncer when a door sensor is opened or closed.

Have you been to http://www.keybounce.com/lannouncer/ or the other thread below?

http://www.keybounce.com/LANdroidHowTo/SmartThingsInstallation.html

Wha? Is this what I’ve been missing?!

I simply want Big Talker to say Please Let The Dogs Out. Without having to do complex CoRE pistons. Will this work for that?

Ok I feel really dumb and maybe because I kinda am with this stuff. I don’t really know what in doing. I add the device handler. I then go to my devices. Add new and I can find LANnouncer on the bottom. I select it but it looks nothing like the walk though page. It wants a name and device Id and a hub or home? I can get to step 7 and that’s it. Step 8 doesn’t look like anything I see

Almost got it. Seems to be working pretty solid now. Just cant get the chime to work in core. How do you have your core setup?