[RELEASE] Konnected Security 2.0 - Connect Wired Alarm System Sensors and Siren to SmartThings - big update and new name!

dth_security
smartapp_security
esp8266
project_security
project_sensors

#526

Not yet.

Does that mean it is on the ’ to do ’ list?


(Neil Oakley) #527

Why wouldn’t you just connect all tamper wires in series and wire to another pin on the board? It’s just like any other open/close switch - if the tamper wires get cut then it opens the switch and it goes off. All it would need on ST side is to monitor that sensor even in Home mode.


(Richard Cheung) #528

Hey Nate,
Just wanted to give you some props. I had opened a ticket for this issue on your site as well. My ticket read pretty much the same as my post. I got a reply from you that you were sending me a new unit. I was really pleasantly surprised. I thought this would be a support issue where I would be walked through the steps of trying to fix it on my end, which is usually what happens before most other companies would issue a replacement. I’m assuming that you could tell from my description that it was a hardware problem and didn’t need to go through all that with me. Most other companies would have spent several days having me troubleshoot before taking this step. Since this is a security issue for my house, I’m really glad that you are so on top of it! This was by far the fastest and best customer support I’ve ever received on a product.

Thanks so much!


(Rob Lisska) #529

I just started having the same issue. Was the only fix to replace the whole thing?


(Apexdestroyer13) #530

I have posted on other forums with this question but I haven’t received a solid answer.
I’m working on keypad control for Konnected and my question is about common grounds.
See my post here for details


(Richard Cheung) #531

hi rob. I think so, since nate just went straight to sending me a replacement. Im assuming its a rare issue. id suggest putting in a support ticket on their site.


(Richard G) #532

Nate -

How will Konnected have to change with the recent decision to depreciate the current way of doing things?


(Ben Lebson) #533

I obviously can’t speak for Nate, but the new system should increase the ability to interface with the SmartThings API and will allegedly give developers even more tools to create their integrations.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy; NOT a SmartThings Employee.) #534

Konnected is currently serverless; and the new API moves the cost and responsibility of “SmartApp” hosting onto the developer.

The magnitude of this cost will vary significantly based on the complexity of the “SmartApp”. Also not speaking for @heythisisnate here, but I speculate that the “SmartApp” may be able to execute on the NodeMCU module(s), thus incurring no hosting costs and be inherently scalable … but adding certain risks and complications that will take some effort to determine and handle appropriately.

It’s been said in the relevant Topics: The new API offloads substantial resource cost off of the SmartThings Cloud and onto the developers, who may need to pass this on to their Customers. This improves the stability and growth potential for the SmartThings Cloud, but puts the onus of optimization and cost management on developers which is a new impediment to power-users, non-profit projects, and startup companies. I encourage everyone to not panic over this because (a) There’s nothing we can do about it. Screaming won’t change the minds of anyone at Samsung or SmartThings; (b) There’s still substantial time before the change will be mandatory or inevitable, and (.c) The practical implications may be much less of a burden than speculated.


(Ben Lebson) #535

Thats for the info Terry, I must have missed that part. I wonder if SmartThings/Samsung will try to monetize this change by opening up cloud storage accounts for developers for a monthly/yearly fee…


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy; NOT a SmartThings Employee.) #536

Revenue channels for Samsung are an ongoing speculation, ever since they acquired SmartThings.

I believe at this point “nothing is off the table”; that includes everything from internal revenue only (Samsung Smart appliances and electronics and phones), data sales, advertising, hosting, commissions for device and app integration, PaaS for IoT transaction usage, partnerships (ADT, Amazon). and things I can’t even think of.

My concern is that if Samsung stumbles around looking for revenue (since it is difficult for them to predict a small number of successful strategies), the casualties will be small businesses (and their customers) that temporarily have to pay overly high fees for experimental, but mandatory, features.

But that’s just worrying for the sake of worrying. As I said… there’s nothing we can do about it.


(Dan) #537

Well, there’s always something people can do about it… Users can always switch to another platform :wink:

I believe Nate has been spending some effort on trying to support one of the open source platforms, like Home Assistant or OpenHAB. The easiest port would be over to Hubitat, since the same groovy code would run with minimal changes (although we still need ActionTiles for Hubitat!!! Come on Terry! :slight_smile: )


(Simon Knight) #538

I’m struggling here… I had a working setup with 3 nodeMCUs controlling various aspects of my security system. The board controlling my garage doors/sensors stopped working, with a constantly flashing blue light. I had a spare, so I swapped it out with a new board, but now I can’t configure or remove either of the boards through the Konnected Smartapp. I have deleted all associated devices already via the app.

The new board is working and I can see the status page. However, if I hit “next” and select either the old or new board and try to remove, I get “An unexpected error occurred”. If I go into the config by clicking “next” and press “remove”, I get the same error. If I try to reconfigure the pins on either board, I get “Error saving page”.

The “remove” commands don’t seem to cause any error in the logging console. Trying to update the pin configuration of either board gives the error

java.lang.NullPointerException: Cannot get property 'mac' on null object @line 318 (doCall)

Any ideas? Is there a way to completely forget a board and start from scratch?


(Apexdestroyer13) #539

@Simon_Knight
Follow these steps. Mine just started blinking again when I was testing out the backup battery. I left it alone and the next night, my siren randomly went off. Scared my wife. lol
I’m planning on re-flashing it tonight and redo my setup now that I have almost all of my components on hand.


(Simon Knight) #540

I have the device formatted and the software reinstalled. The problem is that I don’t seem to be able to set the board up through the Konnected smartapp. I can’t save anything to either device, or remove the devices. I can see the status page with no pins set up in the smart app.

Where is the history of connected boards for the smartapp stored? Is there a way to manually remove both boards and start from scratch?


(Simon Knight) #541

OK - I have it working to a fashion. If I make sure that all 4 boards are up and connected, I can update the settings of all 4 at once. I can’t set the boards individually, and I can’t delete the individual boards or the smartapp for some reason…


(Simon Knight) #542

So it seems that it is not currently possible to update from older versions OTA - the process fails, as described by Nate here: https://help.konnected.io/support/solutions/articles/32000022488-ota-update-failure

To get things back up and running properly I had to remove all Konnected devices in Smartthings, delete the smartapp from my mobile phone, then remove the old smartapp through the ST web interface. I then updated all of my boards with the latest firmware and Konnected software, and reinstalled the SmartApp through Github. Deleted and reinstalled all device type handlers through github, then set up the boards from fresh. All now working as it should again!

I also took the opportunity to do some rewiring and tidying up. I have now completely removed my old alarm panel, installed a new siren/strobe outside and 12v siren inside, as well as a 12v mini-UPS backup battery. I have also automated my garage door openers using relays, some cheap wired open-close sensors and a bit of webcore magic. These can be controlled via a Flic button in may car through IFTTT.

For those in the UK - parts I used are as below:

12V UPS Battery
Siren/strobe
12V indoor siren


(MacTechGenius) #543

I plan to use ST_Anything on a D1 Mini Wemos to connect a momentary push button and a electric door strike. I want to assign rules so the momentary push button only powers the relay (connected to the electric door strike) in certain SmartThing’s mode (i.e home mode).

However, if my internet is down or SmartThing’s cloud is down. Can I have the D1 Mini Wemos automatically activate the relay when a push button is pushed?

So somehow program the D1 Mini Wemos to work in a offline state if it is unable to communicate with SmartThings cloud??

If Konnected can offer this feature…I would be willing to use Konnected instead…since what I am trying to accomplish can be done with either platform.


#544

I’m having a problem with my smartthings phone app (android app, the app is in the latest version). It started when I tried to name a pin (open/close sensor) I haven’t used before and I got an ‘Error saving page’ message.
If I try to rename one of the old defined pins it doesn’t work either. In the Live Log I get ‘physicalgraph.exception.ConflictException: Device still in use. Remove from any SmartApps or Dashboards, then try again’ - but the input pin (device) is not used or defined in any rule (the web page says that).
The information in the cloud (web page) and the one in the phone app are not in sync. If I rename the same sensor in my Devices pages then I can rename it, but that’s not get refelected in the phone app. To make things worse. the names I entered in the phone do not get away after I got the error and discard the changes. I tried to uninstall and reinstall the phone app and the new entered names are still there, and not in sync with the cloud, so I assume they are still somewhere in the phone even after I unisntall the phone app.
I have no idea what’s happening here. is this all the same problem? please help.

As a side note, when re-installing the phone app I have to sign-up as a new user, then after entering my credentials I see my devices. If I try to sign-in as an existing user it asks me for the hub code and I think that will reset my hub and all my configuration.


(Apexdestroyer13) #545

@erz
Are you loging into your shard in the SmartThings API on your web browser? Shards are a little confusing and there is a possibility of adding smart apps and things in the API and they are not going to work. This may not solve the problem but it’s worth a shot. Clear browser junk and log into your API https://account.smartthings.com/login
Do not use graph.api.smarthings.c o m