[RELEASE] Konnected Security 2.0 - Connect Wired Alarm System Sensors and Siren to SmartThings - big update and new name!

dth_security
smartapp_security
esp8266
project_security
project_sensors

(derek.mayowski@gmail.com) #506

Thanks, it is all pins. I have tried formatting the board in the past but I guess it is worth another shot.

I disconnected all wiring except for one open/close sensor and my buzzer just to make sure nothing was crossed and I also tried reinstalling everything from the beginning.


(Apexdestroyer13) #507

I’m working on a keypad that integrates with Konnected.
Check out my progress so far.
I know my video is not as professional as @heythisisnate’s but I did my best.


(Apexdestroyer13) #508

Did you try Nate’s suggestion of reinstalling the Konnected App and reconfig the OAuth?
If the buzzer works, you could try to assign another pin to the buzzer handler and see if that works. If it does you could try and remove all of the device handlers and re-add them.

Can you connect a pin directly to a ground pin using a jumper? Does that show as open/closed when you remove it?
Do you have a multimeter? You can try and test the pins to see if this is a hardware issue.


(derek.mayowski@gmail.com) #509

yes I did, also tested all pins on buzzer and it works. Tried to jumper a pin to ground to simulate a switch and nothing changed.

tried deleting all the device handlers and installed by copy pasting the code from github instead of updating from github and they add fine but still do not update for open/close.

I am running a mesh network with netgear Orbi routers, could this be my issue?

Thanks


(Nate Clark) #510

It really sounds like an OAuth issue, not a local network issue. Could you follow the guidelines here to connect the device to your computer. Please post the output from Esplorer when the device boots and when you simulate a sensor open/close.
https://docs.konnected.io/security-alarm-system/troubleshooting/serial-debugging/


(derek.mayowski@gmail.com) #511

Thanks I will do this and paste the result.

I have managed to get an open/close to register in the smartthings app now after manually pasting in the handler code but the sensor has to remain open or closed for 5 or so minutes for it to register. Progress?


(Dan) #512

Derek,

Did your Konnected problems happen to start around the same time you implemented the mesh router/WiFi configuration?


(derek.mayowski@gmail.com) #513

NodeMCU 1.5.4.1
Konnected Security 2.0.5
build 20170825 powered by Lua 5.1.4 on SDK 1.5.4.1(39cb9a32)
Heap: 41464 Initializing Konnected
Heap: 37248 Version: 2.1.0
Heap: 35496 Connecting to Wifi…

Heap: 39632 Wifi connected with IP: 192.168.1.48 255.255.255.0 192.168.1.1
Heap: 36048 UPnP: Listening for UPnP discovery
Heap: 35632 HTTP: Starting server at http://192.168.1.48:17163
Heap: 35280 Loaded: server
Heap: 31888 Initializing sensor pin: 1
Heap: 31840 Initializing actuator pin: 8 Trigger: 1
Heap: 31632 Loaded: application
HTTP client: Disconnected with error: -11
HTTP client: Connection timeout
HTTP client: Connection timeout

ets Jan 8 2013,rst cause:2, boot mode:(3,6)

load 0x40100000, len 24580, room 16
tail 4
chksum 0xa2
load 0x3ffe8000, len 2268, room 4
tail 8
chksum 0x7d
load 0x3ffe88dc, len 136, room 0
tail 8
chksum 0x89
csum 0x89
„ãìe‚'ä“{Ãóo<äldld`Äã;›$ŒdŒþ


(derek.mayowski@gmail.com) #514

When I connect as you posted it outputs this over and over like it is resetting and rebooting?


(derek.mayowski@gmail.com) #515

I had the mesh routers before I set up Konnected so I have never been able to use it without mesh.


(Dan) #516

How about this… Can you disable (i.e. unplug) the extra mesh access points so you only have the main router station active? If the ESP8266 is close enough to connect, it would be interesting to see if it would stay connected and start working. Just an idea for troubleshooting…:slight_smile:


(Nate Clark) #517

Ah, oh I have seen this issue before. The dreaded Disconnected with error: -11 :scream:

Every time I’ve seen this it was caused by a cable modem that was provide by a cable company. Do you have one of those? I know this sounds crazy, but I don’t actually know what exactly the problem is. It is some low-level HTTP or TLS error that only affects an estimated 1% of people out there with some cable modems. The fix is pretty simple but annoying: replace your cable modem.

Sorry.


(derek.mayowski@gmail.com) #518

haha ok that sucks! I do have a cable modem. Is it specific to the modem or if I get a new one from my isp it could potentially fix it? Thanks so much everyone for helping I really appreciate it!


(Nate Clark) #519

It doesn’t seem to be a specific modem brand or model. I’ve had customers who have had the cable company replace it with the exact same model and the new one works. Ask them to replace it with the latest model. Or if you’re paying a modem lease fee it’s better in the long term to buy your own anyway.


(Apexdestroyer13) #520

Wow that’s odd. I never would have thought that it was the modem.

@dsMayo what part of the world are you in? I have a DOCSIS 3.0 Surfboard cable modem for cheap that I used for about a year.


(derek.mayowski@gmail.com) #521

Thanks Apexdestroyer13 but I am in Northern Canada, my isp (shaw) gives me a modem with my internet plan.


(ATeixeira) #522

First, I’d like to reiterate what so many have said—this build and integration is awesome! I successfully flashed, uploaded and integrated a new board, but I’m having trouble upgrading my original board (from v1), specifically with the wifi step. I’ve successfully flashed the current firmware and uploaded the src files (after formatting). The system broadcasts the wifi signal, but when I connect and go to 192.168.4.1, it does not load properly. It reads as something like:

¿½+fhYenduser_setup.html�V�n�0�͞�[5MÚš%@`�¤e�ZÚ•Z�g��u�,6 ï¿

I have tried multiple browsers, devices, firmware. I have also formatted/re-uploaded several times. The same exact procedure worked perfectly on my first system.

NodeMCU 1.5.4.1
    Konnected Security 2.0
     build 20170712 powered by Lua 5.1.4 on SDK 1.5.4.1(39cb9a32)
    Heap: 	39912	Initializing Konnected
    Heap: 	35536	Version: 	2.1.2
    Heap: 	33848	Connecting to Wifi..
    Heap: 	33408	WiFi not configured
    Heap: 	33376	Entering Wifi setup mode
    Heap: 	21808	WiFi Setup started

Thanks in addvance.


#523

When you use your old PIRs, is there any sort of anti-tamper protection with Konnected?


#524

Not yet. You’ll have to just leave your tamper cables disconnected for now. At least that’s what I did.


(Richard Cheung) #525

Hi Nate,
I need some assistance. My konnected panel suddenly disconnected from my network today. I did not make any changes and it had been connected within the hour before it went offline. My router is next to it and typically it is at 80-90% connection strength. I’ve manually pulled the power to reboot. I also rebooted my router, but the konnected panel is still blinking blue. The app just gives me the webpage not available message.

After being disconnected a couple of hours, the alarm suddenly sounded randomly. I had to pull the power to stop the siren, since it was still disconnected from my network.

Has anyone experienced this problem and have any possible solutions?