[RELEASE] Konnected Security 2.0 - Connect Wired Alarm System Sensors and Siren to SmartThings - big update and new name!

dth_security
smartapp_security
esp8266
project_security
project_sensors

(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy; NOT a SmartThings Employee.) #484

I can’t say for sure. You can probably pull up the electrical code for your region and do a whole lot of reading.

The only precaution that I’m aware of off the top of my head is that you can’t mix low voltage (3v ~ 12v) and high voltage (120v) in the same box. But the code can sure get complicated.


(Simon Knight) #486

This is a fantastic project and I have 3 boards set up - one for my old wired alarm sensors, one for a 12v siren, and one to control relays/sensors for my 2 garage doors.

I am having an issue with my garage doors - the WiFi on the ESP8266 interferes with the RF receiver on my doors meaning that my existing key fobs no longer work unless I am standing right next to the door.

Is there a way to reduce the RF power on the 8266 when using the Konnected firmware?

Thanks


(Tyler Durden) #488

It seems to me if the wifi signal was interfering, your household WAP would already be causing problems. Have you ruled out that it’s not the power source for your ESP that is causing interference?


#489

Both are 2.4ghz thats your problem. I had the same issue, you can try changing wifi channels but your best bet is to position the ESP further way from your garage door opener. A metal shield between the opener antenna and the ESP could also help.


(Simon Knight) #490

@tyler - the ESP is powered directly from the 24v supply of the garage door opener.

@david_van - it will be tricky to move as there is a lot of cabling. I may try a metal shield to see if it helps.


(Bobby Hill) #491

Woooosh.

And it’s “lose”, dude.


(Paul) #492

This is awesome and I have implemented everything except my motion sensors are wireless. I have a Ademco Vista 20p. How do you implement wireless motion sensors?


(Nate Clark) #493

Sorry Paul, it doesn’t work with the old RF wireless sensors. Your best option is to replace them with Z-wave or Zigbee capable motion sensors.


(Paul) #494

Thanks Nate, once again this is an awesome solution. It was depressing having the alarm system sitting there collecting dust. Now I have complete control of my home. This combined with SmartThings and Alexa is the ultimate in home automation. It was a lot of fun getting it up and running. I actually made a big mistake of connecting the NodeMCU ESP8266 to 110V and it promptly started smoking but guess what, it still works even after that. These boards must be well made.


#495

After a recent power outage, I can’t seem to connect to the device anymore.

I noticed that it was back to blinking the blue LED and broadcasting its konnected-security_XXXXX wifi signal, so I though I just needed to re-setup the wifi. However, when I connect and try to go to the 192.168.4.1 page, it won’t connect using either my phone or PC?

It had been working great before the power outage. Any thoughts?


(Apexdestroyer13) #496

@lightiv Yikes! Be careful with that 110 bro!


(Apexdestroyer13) #497

@SpiritTamer
I had a similar problem. @heythisisnate sent me some instructions on reflashing. Worked like a charm.
Try formatting the device with the following method. You have to do it quickly before the application initializes:

  1. in ESPlorer, with the device connected, click the “Format” button. A confirmation dialog will pop up. don’t click Yes just yet.
  2. now press the small “RST” button on the device itself (next to the USB port)
  3. immediately after pressing RST, click “Yes” on the confirmation dialog to re-format the device

This should successfully format the device so you can re-flash and re-upload the latest software.


#498

Thanks for the reply! I was able to RST the device and re-flash the firmware (or at least PyFlasher verified the hash). But, now when I try to upload the src files, I’m getting an error that looks like the firmware won’t take…

PORT OPEN 115200

Communication with MCU..Got answer! Communication with MCU established.
AutoDetect firmware...

Can't autodetect firmware, because proper answer not received (may be unknown firmware). 
Please, reset module or continue.
ÄbŒóogŸl'oÜãì#xŒ�l{l{$‚{û›oà#ão#x

(derek.mayowski@gmail.com) #499

I have been struggling with my Konnected for a few months and spent the morning today for the 5th time ripping everything apart and re-doing it all. I have narrowed my issue down to my pins on my nodemcu not updating. Even if I jumper a D-pin to ground it does not update my open/closed status it just always says closed. I have changed NO and NC settings and still nothing. I re-uploaded everything to my board along with all the src files and set up a whole different nodemcu and had the same issue. I have checked my wiring and confirmed my physical open/close switches with a multimeter. I feel like I am missing something simple but I am at a complete loss and have been considering just abandoning my konnected setup. Does anyone have any suggestions? Thanks in advance.


(derek.mayowski@gmail.com) #500

I just wanted to add that output to a buzzer works.


(Apexdestroyer13) #501

@dsMayo
Is it all of the pins or just certain ones?
Were you able to successfully (completely) format the board? (you have to do this part quickly)
Did you accidentally cross voltage between any pins?

Maybe try to update the device handlers from repo or reinstall the app.


(Nate Clark) #502

@dsMayo it sounds like your OAuth token is out of sync, so SmartThings is rejecting the status updates from the device. Try deleting and re-installing the Konnected SmartApps following this guide:


(Apexdestroyer13) #503

@SpiritTamer make sure you are quick when following the formatting steps. I had to do this twice because I didn’t do it fast enough.
Try formatting again and reset module.


(Nate Clark) #504

Toggle the RTS button in ESPlorer and it should get past this error.


(derek.mayowski@gmail.com) #505

Thanks I actually stumbled on that video this morning and did just that. I even made a new smartthings account and re-installed everything but still not working. This is what my smartapps screen shows