[RELEASE] Konnected Security 2.0 - Connect Wired Alarm System Sensors and Siren to SmartThings - big update and new name!

Awesome! I’ll do that. Great product, BTW. Thanks!

Oh excellent! care to leak some deets? I’ve left my keypad unpowered in place and looking into ActionTiles and a tablet to run off the power - but keen to see what you’ve come up with.

Just getting around to posting this. We had an extended power outage the other week (Hurrican Irma area). The power was restored about 3 days later. When it came on - my siren was blaring. I ended up unplugging my power source and disconnecting the battery and waiting for my entire network to get online before plugging things back in again.

My question is - is this expected behavior?

Is your siren connected to pin D8? There was a bug in an early version of the software that did have this issue with pin D8 unexpectedly triggering when recovering from a power failure. It has been fixed in software version 2.0.2, but I think some of the very early devices may have had an issue with the software update, too.

John, could you tell me what software version you’re on? You can find this by going in the SmartThings app to Automation -> SmartApps -> Konnected -> scroll down to “tap to view device status”

I am using PIN D8 for the siren. I just checked, my devices are running software v2.0.2 - what they were shipped with.

I need some assistance. I just had a brief power outage. After the outage my konnected device is unreachable even though I can see it on my wifi network. I’ve gone back to my app and tried to set up the device again. It updated to the new ip address lease so it is communicating it is non-responsive to any commands and I can’t reach the device status page.

Hahaha! I realized after posting it that my question wasn’t so smart. I just thought there was a standard but after browsing the net, looks like I’m ok with either. I prefer the warble tone too. Thanks.

Nevermind. I got it back. But in case anyone else runs into the problem. Here’s what happens. When there is a power outage, the router renews all the devices, so the konnected goes to a new ip address. But it looks like the smart app points to the old ip address. So I had to go to the smart app and reset the device. This updated it to the new ip address. Then for whatever reason, the device disconnected itself from the network, so I had to go down and power cycle it to get it working again.

Great job, konnected dose support_ wireless sensors

Nate can confirm but I believe there is a program running that checks for the devices every 3 hours and updates the IP addresses automatically. In other words if you waited a couple hours it would have fixed itself.

I just decided to set it to a static ip so I shouldn’t have this particular problem again.

Power outages are actually rare where I am, and I usually don’t work from home. So if it would have fixed itself in a couple of hours I never would have noticed it. But I’m glad I did. With a static ip, it should reconnect immediately and I wouldn’t need to worry about being without security for a few hours.

Yeah, I did the same thing…put in a DHCP reservation for my hub, both ESP8266’s, and the ESP32 I’ve been playing with for ST_Anything. Same reason also…don’t want the slight chance of it being down at the wrong time. Although I also have my devices on battery backup.

Hey, First of all, great product.

Is it at all possible to trigger a low level relay?

I have one connected to D6, configured as a Siren. It is a 5v type and it is connected to the 5V power. When i connect the IN to D6 the relay triggers immediately. If i then toggle the siren on or off in the app, nothing changes.

I did notice that if i moved IN to another pin (say D5) it would remain un triggered, if I then set D5 to a siren after the device updates the relay would trigger again.

I found the option in the settings to select it as a ‘low level trigger’ but this did nothing either - after configuring a pin to ‘Siren’ the relay is always triggered.

Perhaps it’s just the relay I am using? I live in the UK and I purchased these. https://www.amazon.co.uk/gp/product/B00ZR3B252/ref=oh_aui_detailpage_o06_s00?ie=UTF8&psc=1 (the description says High level trigger but the pictures and PCB say otherwise).

I am running 2.1.0 SW

Thanks
Matt

Yes, you should be able to use a low-level trigger and I would expect that those that you linked would work. It sounds like you found the (as yet undocumented) setting for low level trigger by tapping the gear icon on the device screen after you’ve set up the device initially in the Konnected SmartApp.

One thing to check is to make sure that the device receives the low-level trigger setting. When you change that setting, your SmartThings hub should send a request to sync the trigger setting to the device. You can verify if the device has the right trigger setting by going into the device status page (Automation -> SmartApps -> Konnected -> tap to view device status). Scroll down to the actuators section and verify the trigger for the pin you’ve assigned. Trigger 0 means low-level and 1 means high.

Lastly, pin D8 only works with high-level triggers. D1, D2, D5, D6, and D7 can be used with low-level trigger relays.

1 Like

Yep, found the super secret setting.

When i slide the toggle in the app I can see the blue lights flash (as if it’s rebooting) and I did see the actuator array was set to 0.

I sort of think this is a software problem I am seeing just because on bootup the line must be high by default (because the relay is off) after it boots the relay is triggered and then no amount of turning it on and off in the app will change it. Also if I connect to a currently un-used line (after boot) the relay will not trigger (line must be high by default?) but when I configure that pin to be a Siren, it’s at that point the relay triggers and nothing I have tried can make it untrigger. hence a software problem as something must be able to configure those pins to work with this relay at some point in time :slight_smile:

This brings me on to my second point - I started to try and look at the code and was wanting to change it so that it would be able to auto-update from my own fork (so i can play with it and contribute to the project more easily than taking everything off the wall and flash it manually - although i know i would need to do that at least once) but wasn’t sure of the procedure I found a few things;

  1. need to change the repo in update_manifest.lua
  2. need to commit a valid manifest file (i assume the script in the scripts folder creates this for us)
  3. need to officially create a ‘release’ - not 100% sure what this involves or if a script could help?
  4. anything else?

It should work. I’m using several low-level relays at home and I don’t have this problem. It could be an issue with the relay module that you’re using.

But of course you’re more than welcome to play with the software and submit back any improvements you make!

You’ve got the right idea about OTA updates. I’m sorry this isn’t documented (yet):

  1. yep, update the repo in update_manifest.lua
  2. after committing your code changes, run ./scripts/build-manifest to generate the valid manifest then amend the commit with git commit --amend to add the updated manifest to the commit
  3. you don’t need to create a release. For rapid development workflow, just force update the device to your branch/tag by making a GET request: http://[your-device-ip]:[your-device-port]/settings?update=true&force=true&commitish=my-branch-name

Ah, excellent. Thanks for the info about OTA.

On thinking about it more today the GPIO pin /must/ be toggling so it’s got to be down to the relay I am using. Just out of interest are the low trigger ones you use 3v or 5v?

In the meantime a 5v high/low trigger one, more similar to the ones you suggest is in the post and I can try that one out when it arrives.

I know very little about electrical engineering so forgive me if this is a stupid question but is there a possible issue with the fact the GPIO pin will be 3.3v when high but the other wires are connected to the 5v circuit? Is there some sort of net potential difference and so the relay will never read 0V and so will never trigger low (unless you just disconnect it)?

Oh I had that backwards - it’s always triggering low - which is the problem. I found this link which seems to indicate we can not do what I am doing with a low trigger relay??. https://www.raspberrypi.org/forums/viewtopic.php?t=36225. not sure if this is applicable to the nodemcu baseboard.

I realised i could just try the 5v low trigger relay using 3v and it worked fine. The super secret setting to toggle the logic works fine.

I’m guessing that low trigger relays will not work if powered from the 5v.

Thanks for all the help, my system is fully functional at the moment.

Hi. New to this conversation and first time home owner. The house came with a security system and its components are wireless (door and window sensors, motion, etc). Reading about this solution to integrate the existing home security system into ST is what I hope to complete.

Question: if my system is using wireless sensors, will this solution work? If not, what options are out there for a non technical person?