[RELEASE] Keenect V1.2.0, optional separate vo settings for cooling, vent obstruction auto clear

Can you update the logging level to detailed?, then paste the log output when saving the zone, that should help find the issue.

User error. I tried adding zones via keennectZone. The correct way is:

  1. Configure thermostat via Keenect under Marketplace > My Apps
  2. Go into your list of installed SmartApps
  3. Select Keenect and make zones there

I still might move to Ecobee because of the open API and it seems popular with ST. I would need to install a custom device handler to make the Ecobee sensors appear as sensors on ST, correct? I still will keep my Iris sensors, but since they are mounted on the windows, the temperatures wont be accurate depending on how much sun.

I can’t answer the Ecobee question as I don’t use one. I have heard that the ecobee remote sensors are slow to update ST, if that is still the case, using them to manage temperatures within a configured Keenect zone isn’t going to work well.

Is there an issue using the stock Ecobee ST device handler? I havent seen the last results update. I refreshed the IDE when my AC is on and Keenect doesnt get out of the idle mode. Is it because of the thermostatStatus value or is it the poll rate of the Ecobee?

Ecobee: thermostatStatus: Cooling to 78 F
Keenect: mainState idle

Edit: I started using @StrykerSKS code and everything seems to be working now!

1 Like

All, I keep having an issue that I can’t figure out. I have a 2 story condo, and I have over the years gotten all the rooms upstairs balanced well with each other. My ongoing issue was that I had to adjust one vent downstairs constantly to balance temps between the 2 stories.

To fix this I got a keen vent to put downstairs to balance the air flow upstairs and down stairs. I installed the latest apps via github integration. Everything installed fine.

Here’s the issue: when the upstairs needs more a/c than downstairs and the ac kicks on, the vent opens sending all the air downstairs. When it’s cooler at night, the vent closes sending all the air upstairs. Basically, it’s running backwards. I’ve played with offsets, but that doesn’t help.

Edit:maybe of note, the ct100 thermostat is downstairs and is being used as the setpoint temp sensor

Any suggestions?

UPDATE: A resolution in case someone comes across this in the future - I opened the keenectzone app, went to lines 524-549 and flipped every maxVoLocal to min and vice versa. Now the vents open/close correctly for MY situation. Holding steady right at my requested temp for 2 days straight!

Interesting…, I think you’re the only person that’s needed this, but glad it worked out.

Which makes sense to me. I’m varying a vent in one room in order to redirect more air to another room. It’s the opposite of what 99% of other users use. It perfectly balances upstairs and downstairs for me with only one smart vent though!

1 Like

Hey Mike, Thanks so much for this app. Everything is works great but I have a few questions. I’m still balancing out the system and making changes to several of our vents and a bit of duct work as part of a main floor renovation so this is very much a project still in progress! I’ve attached a few screen shots of my setup and the reports from the app. My question is that of you look at the current state report for “Kitchen Vent 1” it shows a response time of 33364.1s and that translates to ~9.2 hrs. The vent seems to be functioning like vent 2 in the same area and closes when the cycle is done. I’ve only seen vent 1 in the Kitchen report these long response times. Is this possibly a communication error issue between smartthings and the vent? This is the furthest vent from the hub and I do not have any keen hubs in use for repeaters. I am curious of Hue Lamps (zigbee always powered devices) would act as repeaters for the vents or are they dedicated to the Hue system. I’ll have to bounce that question of of the Keen home folks to see what they say. I did buy a couple vents off Ebay that are supposed to be arriving soon with a Keen hub the through in so I will try it as a repeater to see if it helps. I’m using an Ecobee t-stat with multiple sensors along with sensors and could not get anything to work with the Smartthings ecobee integration but it all seems to work well with the app updated by stryker (sp?). Thanks again for this app and any comments you have would be greatly appreciated. Michael

Regarding the response times, obviously a response time of 9x hours is improbable. I use smart power outlets as repeaters for my zigbee devices. I at times get large response times that make no sense from time to time.
It’s likely a bug in the code, haven’t felt the need to spend a great deal of time sorting that out.

Thanks for the follow up! I added a repeater near the far end of our house and the times dropped down to a few seconds.

this seems like it would amazing. I might have to look into getting some of these vents as i have a older house and the HVAC system was added later on so heating and cooling can be spotty at times.

my question is do you need to order the hub when you order the vents?

Keen’s hub is not required if you’re using this app.
The vents pair directly with smartThings.

I’m only using the Keen hub as a zigbee repeater since I don’t have any other zigbee devices on the far end of the house.

Thanks, Michael

Hi Mike,
Firstly thanks so much for the time and effort that must have been involved with putting together the keenect app. It’s really appreciated.

Unfortunately I can’t get it to work properly and I don’t know what I’m doing wrong. I’m trying to integrate with Nest and using the latest version of Nest Manager. Nest Manager seems to be working OK.

I’ve installed Keenect twice and had the same problems both times. Firstly I constantly get the error “Failed to save page: main” when hitting “Done” on the main config screen.

And secondly I am seeing almost nothing reported on the “Zone reports” page.

I’ve tried a bunch of different settings and seen any changes. It’s not clear to me if problem 1 is related to problem 2 or not. The “failed to save page” error seems to be something that has been come up before and discussed in the community, but I haven’t seen a definitive answer to this.

I would really appreciate some guidance from you and/or the community as to where to look to sort this out.


or if you do get the keen hub or have a spare, you can use it as a zigbee repeater by paring it with ST…

For me this happens if my Nest isn’t in auto mode.

1 Like

OMG…I feel like an idiot. I think changing to Auto mode on the Nest has worked. It’s 90deg outside…never occurred to me to be in auto mode!! thanks @celblazer.

1 Like

I’m trying to install this for the first time and I am getting an “Error saving page” error when I try to add my Thermostat and Thermostat temperature sensor. I am using Nest and the Nest Manager app.

What am I doing wrong here? Seems pretty straight-forward. I have read the 2 years worth of comments above but may have missed where this has already addressed.


Looks like I am getting the same thing as virus86 except I cannot find a problem with how the Nest is named. Doesn’t mean it isn’t there - I just can’t find it…

5d00a45c-371d-4002-8ed9-7ddc189601c2 12:50:27 PM: error java.lang.NullPointerException: Cannot invoke method toFloat() on null object @ line 69
5d00a45c-371d-4002-8ed9-7ddc189601c2 12:50:27 PM: debug Updated with settings: [isACcapable:true, tempSensors:Nest Thermostat - Upstairs, tStat:Nest Thermostat - Upstairs]
5d00a45c-371d-4002-8ed9-7ddc189601c2 12:50:27 PM: debug Installed with settings: [isACcapable:true, tempSensors:Nest Thermostat - Upstairs, tStat:Nest Thermostat - Upstairs]