[RELEASE] Iris SmartPlug Z-Wave Repeater with Diagnostics

Is the led on your hub blinking when you’re trying to pair?

Yes, I reset the device and the blue LED starts to blink slowly. I have waited a couple of times and I watched it for a 15 or 20 seconds and it continues to blink slowly. Almost as soon as I click add a thing in the ST Classic APP, the LED will flash quickly for a second or two and stop. On every other hub I paired it to this is when it paired. The Classic app just spins and never finds a device, I also downloaded the new app and tried it with the same result. Except in that case you get a percentage wheel and I let it go until it said it could not find a device.

I had a very difficult time getting one of mine paired as well. After many attempts slowing down pushing the button ended up working for me after many tries.

“Assuming your trying to add the Zwave part of it, and you added and published the handler in the IDE.
I read 2 ways for pairing the zwave. Hold the button down while plugging in the plug. That didn’t work for me. Other was quickly pressing the power button. At first that didn’t work either. I noticed that it wasn’t turning the switch on and off each time. So I slowed down and made sure it turned on and off quickly each time. At the same time I had smartthings searching for a new device. It eventually showed up as a Zwave device.”

I am not trying to pair the Z-wave part.

Not the led on the device. The led on the hub.

Yes it does as well.

1 Like

Well, you’re not alone I have the exact same thing happening on one of my iris plugs that once paired but it no longer does. It also behaves just as you described it. I tried pairing the Z-wave repeater and that worked, just not the Zigbee part.

I guess it’s good to know I am not the only one, I just got an email that a new firmware update is coming, guess I will wait until that shows up and try again.

When mine was paired before, I used it for a short while and then I unplugged it and stored it away for a few month. I decided to use it again but before I did so, via the classic smartapp, I removed the device (maybe I shouldn’t have) because it didn’t seem to be working. I’m wondering if the device didn’t get totally removed but it’s in limbo land somewhere so when I attempt to re-pair it, it looks like it does but doesn’t show up because the device is in limbo land. Like you, I’ll wait for the hub firmware update and cross my fingers.

This is exactly my experience as well. We moved and I removed all my devices at the old house and then re-paired when I came over to the new place. We have been having work done so some I didn’t need right away as we had some furniture in storage… We finally got all our furniture in and now I need the plugs, but they will not pair.

The four I hooked up right after we got here work fine and I had no issues pairing them, that was around Aug-Sept of last year. The last three, have been in storage until now. There was a firmware update in Dec so maybe that messed it up. Although I know there are many people bringing V2 smartplugs over to ST from Iris since they are shutting down, so apparently not everyone is having this issue.

Well the new firmware has arrived but unfortunately, it didn’t help my situation at all. While I was poking around my IDE, I did notice that I had two extra “home” locations which I was able to remove. There were no hubs are devices attached to those locations. I don’t know where they came from but I was able to remove them. I thought they might have something to do with my problem pairing but it didn’t seem to make a difference. I tried one more time pairing but this time I downloaded the new Samsung Connect app and tried using that program but it didn’t help either. It did however find the Z-Wave repeater … twice … and without me pressing the button repeatedly eight times to pair that part of the device. I don’t know what is up with that but now I have a ghost Z-wave repeater along with what looks like a working one. Oh well, I’m about to give up on this one.

I’ve been messing with this for a few days now, and I still can’t get it to pair. I can get the plug into pairing mode, but as soon as I tell the hub to search, the led in the plug flashes quickly a few times and stops. ST never finds anything.

This is annoying as I have a few if these and I’d really hate to have to get rid of em.

Try deleting and re installing the device handler. There is a problem with custom DTH going stale.

I have the same issue I have changed all mine from this DTH to the standard local smart Power outlet DTH. I deleted this DTH so deleting and re installing as suggested doesn’t seem to help. I have 4 on my system that I paired several months back that work great.

I guess I will try support again. I sent in a ticket and a Jennifer got back to me fairly quickly but as I figured she gave me a canned response on how to pair and reset the plug. Although I had clearly spelled out that I had done all that. I even mentioned I was using the classic and not the new app and of coarse she gave me the instructions for using the new app. I was polite and told her, again, I had done all that and asked for a more in depth analysis she said I should try using the new app. Even though I have been avoiding installing it I went ahead and installed and tried with new app, it made no difference. I again asked for more options and she has never responded back. Apparently I hit the limit of her helpfulness.

I tried the new app as well, twice it would find the Z-wave repeater part but not the Zigbee on/off switch.

Same here, but I did it with the classic app. I never tried to pair the Z-wave portion with the new app…

It was really odd for me, when using the new app I wasn’t even trying to pair the Z-wave portion either (quickly repeatedly pressing the on/off button about 8 times). I was doing the usual pairing of the Zigbee portion and the Z-wave repeater shows up. I don’t know what is up with that.

That was the same for me the first time. I was trying to pair the Zigbee side and I saw a device pop up. I thought at first that it had started working again. I named the device and then when I went to set it up in my routines I could not find it. It took me a minute to realize it was the Z-wave portion that had paired and not the zigbee, I was using the classic app at the time. On a couple of later attempts after the zigbee portion would not pair I went through the Zwave portion to see if another would pair and they did.

I called support and the guy I spoke elevated it to next level support and I am supposed to hear back from them in 24 to 48 hours, We will see…

I have 12 of these showing up as devices that I control and as z-wave repeaters for a total of 24 devices.
To make them work follow these steps.
Go to add a device.
Select IRIS.
Select plug.
Hold the front button in as you plug it in and release it when it turns blue. It should flash blue a few times and eventually pair as a device
Make sure the blue light is on and go to add a device again.
Select IRIS.
Select plug.
Push the front button eight times fast and wait for a while and it will pair up as a z-wave repeater this time.
Repeat these steps if it doesn’t work the first time.

I have 4 that work, i paired them about 6 months ago, and I know the procedure. I can pair these plugs to three other type hubs, but not to ST. These plugs use to be paired to ST., before I moved and stuck them in storage.

On a side note what a POS that new app is.