[RELEASE] Iris Smart Plug (3210-L) Zigbee Plug with Z-wave Repeater

Can you elaborate? I first managed to get the plug and repeater recognized. Then I deleted the plug by mistake, and on every reset the device was recognized as a “Z-wave Device”. After a few deletes and resets the hub will now not even recognize the Z-wave device. I found this for Z-wave Device exclusion
Z-Wave Device Exclusion
but it is far from clear (to me) what needs to be done. I am pretty comfortable around computers, used to program for a living and still write the occasional code, but I must say that SmartThings has a looong way to go until it becomes accepted by the average Joe. If it stumps me continuously, there is no way it does not stump the average consumer.

I had this issue, and did the factory reset so to speak on the device by holding the button while adding.

The key was I had to reboot my hub though, first, after removing the badly configured devices from the first effort.

After zigbee done, I then did the zwave include, which I think was by hitting the button 8 times consectuviely a few times. did a different blinking pattern and then it was found again.

For ZigBee devices you need to reset the actual device after you delete it from the system. To do this, hold down the button while the plug is unplugged and then plug it in while continuing to hold it down. Release the button once the light starts to blink. At this point it will be in discovery mode and you should be able to add it back into SmartThings with the app.

As for the Z-wave repeater, you didn’t need to delete and re-pair it but if it’s not allowing you to do it now you will go through the Z-wave exclusion process and then hit the button on the plug 8 times rapidly. At that point the hub should say that it successfully excluded the device and then you should be able to add it again.

Let me know if this doesn’t work for you.

I have done the reset more times than I can count by now, with and without reboot of the hub. Just did it two minutes ago
a) Power down the ST hub and let it sit 5 mins
b) Power back up
c) Delete the Z-wave device
d) Hit “Connect new device” on the ST app
e) Hold down the button and plug device into outlet. After a few seconds blue light comes on, then offf, then on again at which point I release the button
f) Device discovered is once again the “Z-wave Device”

I have double and tripple checked the DTH in IDE. I do have “blebson : Iris Smart Plug” as one of the published DTs, with capabilities “Actuator, Configuration, Power Meter, Refresh, Sensor, Switch”. For good measure I deleted it, rebooted the hub, then added it again. Still no go.

And I am still not clear how to run Z-Wave Exclusion. I follow the process here I see the message “Please follow manufacturer’s instructions to remove the Z-Wave device from My SmartThings” but can’t find what the Iris process for Z-Wave exclusion is.

P.S. The Raw Description of the Z-Wave Device in IDE is
0 0 0x0F01 0 0 0 7 0x5E 0x72 0x86 0x5A 0x73 0x85 0x59

Don’t delete the z-wave device, if it’s paired as “Z-Wave Device” then it is all set and you don’t need to touch it again. You need to release the button as soon as the LED comes on the first time. Try that and let me know if it doesn’t work.

1 Like

Cha-ching… that was it. When I released the button as soon as the blue light comes on the plug was discovered properly. Now I am off to YouTube to leave disparaging comments on Iris’ own video on how to reset the plug, which explicitly says to hold the button until it blinks Iris

Generally I think of “Until it blinks” to be as soon as the light turns on the first time, though I do understand the confusion. I’m glad you were able to get it working :slightly_smiling:

1 Like

When I try to access the groovy script at the top of this post for the IDE devicetype I get a 404 error. Does anyone know where the script has been moved too?

I sent him a pull request renaming the directory so you can directly use his Github in the IDE:

  • owner blebson
  • name Iris-Smart-Plug
  • branch master

Which is better than copy-and-paste from the new location:


Sorry about that, I updated the link in the OP so it should work now. Thanks @jlv for pointing them in the right direction :slightly_smiling:

When I try to update it via the GitHub integration I am getting the following message:
"Updated 0 devices and created 0 new devices (1 skipped due to errors)"
Any idea how I can see what the error was?

I tried the following 2 approaches:
First - device type does not exist, I go to “Update from Repo” and select the “Iris-Smart-Plug (master)”, after that from the rightmost panel “New (only in GitHub)” I check the devicetypes/blebson/Iris-Smart-Plug.groovy and click the Execute update button.
Second - device type created from code, then I go to device settings and change the repository from None to the “Iris-Smart-Plug (master)”, then I try “Update from Repo”, but it still shows in the “New (only on GitHub)” section and if I select it I get the same error.

Sorry, this is because I didn’t do a complete job when renaming it, and I didn’t test it before I made the pull request. :flushed:

I just sent a pull request with the fix: Iris-Smart-Plug.groovy needs to be moved to iris-smart-plug.src/iris-smart-plug.groovy


I’ve never dealt with the IDE integration so thanks for setting it up!

Thanks! Now it is OK.

Hey Bud, you might want to update the thread with the new link above also, as your old link is now dead.

Sorry about that, thought I already had. Should be all set now.

no man thank you, i just connected it thanks to your thread and its working like charm!

1 Like

[quote=“kurtsanders, post:32, topic:31028”][quote=“kicko, post:30, topic:31028”]Where is this list of devices that run locally? How do you check that? Is it in the app or on the website?[/quote]Only in the IDE. The link to display the local devices your V2 knows about is below: https://graph.api.smartthings.com/localInstalledSmartApp/list
[/quote]Is this even linked to from the IDE? Or it is just another non-intuitive link hidden somewhere?

I believe it’s a hidden link, I’ve only ever found it on the community forums.

Got one of these (accidentally) when I ordered the sammy smartthings outlet. Might keep this though…

Out of curiosity, what is meant by “running locally”?