[RELEASE] Iris Smart Plug (3210-L) Zigbee Plug with Z-wave Repeater

Does anyone know what the slider is that goes from 1 to 100 on the zigbee device does? It won’t retain values. Maybe it is supposed to be a dimmer for devices that support dimming?

That should not be there for this device. It sounds like you have the wrong device type handle defined for your plug. Double check in the IDE, and make sure it says “SmartPower Outlet”.

FYI, they just added both the switch and repeater fingerprints to standard device handlers. So these should pair out of the box now.


I just set up 2 of these last night. They indeed paired out of the box. with no custom DH. I can also confirm that there is no slider on the outlet.

Paired the Zigbee outlet by holding in the button then plugging in the device and letting go. Paired the Z-Wave Extender by tapping the button 8 times. Once set up, the Extender is not visible as a device in the app. I checked in the IDE and it’s there, but also says Cloud control (Zigbee outlet is Local). So it seems that the handlers are the same we’ve been using, but are now integrated.


@bradlee_s if you do a zwave repair do you see the zwave radio in these 3210-L units responds back to the hub?

So then no events should show up for this device either??

Do these contain a confirmed off bit? I’m contemplating using one to automate flushing my well filter, but I need it to flush, turn off, and then be able to confirm its off. Obviously don’t want to be running the well dry…

i have three of these outlets, with the latest firmware (25.00026) i noticed one of the repeaters was not responding to a z-wave network repair. I removed all three plugs (zigbee and z-wave side) and re-added them. DH for the zigbee now shows as an irs labled device handler, and the repeater now picks up a z-wave repeater device handler and no longer appears as a dump device on my ST App. They now respond to network repair.
interesting thing is it only took 3 or 4 rapid presses to include the repeaters. there may have been a zigbee firmware upgrade on these a while back as they show they show the firmware is up to date.

Sounds like one or both sides of the device are picking up a custom device handler. For those of you having issues, try re-publishing all of your custom device handlers (if you have any). There is a cloud cache bug where custom DTH are being marked as stale and it cause the device to act as joined, but it never shows up in the IDE or app.


I appreciate your input, but I don’t understand why I need to learn to write code to make a $25 Smart Plug work. It should be plug it in and it matches up with the hub. What am I missing?

You don’t need to anymore. I believe this device handler was written before SmartThings added official support. Some people still use it because it has energy consumption over time, whereas the default SmartThings one only has live energy reading.

Hi Mark,

I see the Z Wave Range Extender device type, but I also see Relay device type. Any idea if these are the same thing, essentially? When I choose Range Extemder, the device does switch to Cloud. If I choose Relay, the type stays Local but is also still visible in the ST app.


Can you please post the link to Ben’s zigbee DTH. Thanks

I’m having some issues with one of these. I’ve successfully gotten 3 set up, but the 4th I can get all the way to naming the repeater, clicking ok, and then the device doesn’t appear. The outlet piece works fine, but I haven’t found a combination of resets and exclusions that will make the repeater actually add as a device. Any idea why it might be found and recognize the device, but not show up on my list of things?

Have you looked in your IDE? I have noticed that the default device handler has something set so that it shows in your IDE, but not in your app.

Has anyone recently tried to add the zwave repeater recently. I have tried the 8 rapid presses, that didn’t work. I have reset the plug many times. The plug setup was very easy. So when I do the 8 rapid presses, should the plug be turned off or on? I have tried 4 presses and 5 but the light stays solid. When I do get it to work is the light suppose to blink differently then when I setup the plug portion? I have firmware version * Current Version: 0x16015010. These plugs were from Comcast, bought it on Amazon, maybe they have old hardware? TIA

If I press once and then hold, the light will blink steady but nothing like what others mention when doing zwave repeater pairing.

Thx! Hope all is well

It does show on the “new” app, but def doesn’t show on Classic.

That’s correct.

1 Like

I just saw on Classic is shows up in rooms, but only after you have it organized in New: