[RELEASE] Iris Smart Plug (3210-L) Zigbee Plug with Z-wave Repeater

FWIW :grinning: I concur - “SmartPower Outlet” is what I use (based on an earlier study of this thread).

1 Like

So I’ve had an interesting issue since I installed the two plugs I just got…all of my printers kept falling off my network, and my Nest thermostat wasn’t connecting/reporting reliably, and a couple other issues.

I’ve heard of Wi-Fi interfering w/Zigbee, but can it also go the other way? The addition of the plugs may be coincidental, but it seemed like the issues and the arrival of the plugs were too closely timed to not be related, and there have been no other changes to my network.

I’ve moved my router channel 1 from 9. My Hub is using Zigbee channel 24 which is up close to 9 as far as I understand.

I am so frustrated. I CAN NOT get the Z-Wave part working. I have done the Device Exclusion thing, Held the button, pressed the button, Unplugged, re-unplugged, stood on my head and even did a chant with a bloody chicken foot. This thing will not go into pairing mode. :frowning:

Make sure it didn’t get picked up already as either a ‘Thing’ or a ‘Z-Wave Plug’. I agree, the Z-wave side is very finicky. It honestly took me a good few tries before I got it to pair myself.

I think you have to use the whole chicken…:grinning:

I created a DTH to help deal with the fussy Z-Wave module in this. You can read more about that in this thread.

There is a significant change in behavior on the newer retail plugs. They are shipping with firmware 0x20085010. That update contains updates for the Zigbee and Z-wave portions of the device. It also changes how it pairs too; there is no longer visual feedback from the LED with Z-Wave discovery is active.

Here’s what I would do, I say this because I just recently updated all 44 of my plugs using my Iris hub then reconnected them to ST.

  1. Install the DTH for the Z-Wave repeater. (This is seperate from Ben’s DTH which handles the Zigbee outlet functions).
  2. Remove the SmartPlug from SmartThings.
  3. Completely reset the plug. Unplug it from the wall, press the button and plug it back in, but hold the button in until the plug turns on and back off, about 8 seconds total.
  4. Unplug from the wall again and wait 2-3 seconds.
  5. Plug it back in. Once you see the LED strobe once, press the button on the plug rapidly 3 times.
  6. Add the device in SmartThings. Wait until 2 devices are discovered; one will appear as a SmartPlug, the other as an “Iris Z-Wave Repeater”. This may take up to 5 minutes, depending on how finicky the ST cloud is.
4 Likes

I didnt get picked up as a Thing. I installed the device handler first and it found it just fine as an Iris Smart Plug. It looks right to me in the IDE. I then tried to pair for Z-Wave, didnt work so I did the Exclusion thing, Tried again, didnt work. I am amazed this is so difficult to do.

@bne - OK I just tried this to be sure and it didn’t work either.

@SteveWhite . Thanks Steve, I’ll give this a try.

Well, I got the plugs to pair to both for Z-Wave and Zigbee. I am not sure if it was the chants, the burn offerings or the Device Handler… but its working great so hopefully now, I’ll have a strong mesh. Thanks for the help everyone.

@zonomo: You may already know this, but you have to rebuild your Zigbee and Zwave meshes to integrate the new Zigbee and Z-Wave repeaters in the plug.

  • ZIgbee: Unplug ST hub and remove any batteries for 20 minutes. Then plug in again.

  • Z-Wave: Initiate a Zwave repair from the mobile app (might want to do this when you are about to go to sleep - it can take a while). In SmartThings app, menu>Hub is Online>Zwave Utilities>Repair Z-Wave network. If the Z-Wave repair doesn’t run from the mobile app you can do it from the IDE. That’s what I had to do. In your IDE click on your hub, scroll down and click on View Utilities, and then click on Repair Z-Wave Network.

@Danabw Thanks - didn’t even think about that!

OK, this doesn’t look too good. Is there anything I can do? I am not even sure what this really means. I have 1 IRIS Plug downstairs and 1 upstairs. The ST Hub is upstairs in the middle of the house.

Totally new to this and am on day three working with Smarthings.

I purchased the Iris Smart Plug for it’s Zigbee/Z-wave repeater functions. Following the instructions from the original post, I copied the code into the device handlers, saved and published it successfully.

The plug pairs very quickly, but it shows simply as “Thing” within the app. When I save that in the app it shows up in the list but, instead of the expected ON/OFF only says “PLEASE WAIT”

Appreciate any help…thanks!

You’ll have to go into the SmartThings IDE and manually assign the proper devicetype, looks like it didn’t automatically detect it.

Thank you for the reply!

I’ve been spending the past hour trying to apply your suggestion but afraid I am lost.

The “Thing” is not showing up under “My Devices” I am only seeing those devices I have previously/successfully linked to.

Perhaps I’m not going to the correct place? Apologies for my ignorance with ST… I’m (hopefully) learning!

Thank you for your help!

If it shows up in your SmartThings app, it should show up in the IDE under My Devices. Did you rename it?

I did an online chat support with Smarthings and the tech was fantastic. Turns out that, in my infinite ability to confuse things, I was logging in to the Smartthings app on the phone, but the Samsung account on my PC. Once I got on to the correct account, everything was beautiful.

It’s the simple things…which often eludes me. Things like this remind me of when I was a kid in the 50’s. My father had a sign in his workshop that said: THINK…there must be a harder way.

Thank you for your help…and your patience!

Just in case: I did a pull request adding basic electricity cost calculations: https://github.com/josea/Iris-Smart-Plug.

2 Likes

Thanks for your contribution. I’m not maintaining this DeviceType anymore but please feel free to offer the modified version on your GitHub. I just ran into issues before with merging in code which caused lots of errors on the platform side.