[RELEASE] Iris Smart Plug (3210-L) Zigbee Plug with Z-wave Repeater

Wow. Bonus feature not expected.

So when all this is done and the SmartPower Outlet device type is used, does the power monitoring features improve? Does it go from reporting power level only when turned on/off to reporting when changes >1W also? And every 10 minutes? The ST Outlet does that with this device type.

It should work exactly like the SmartPower Outlet, I haven’t actually used the outlet other than setting it up so I’m not sure how the power reporting works.

1 Like

Wow. @blebson, I got the more advanced SmartPower Outlet functionality working now following your instructions. I wanted it with energy reporting on energy changes. Apparently when I added the device the first time, adding it under device type SmartPower Outlet, I got it stuck doing dumb energy reporting (only upon on/off event), even if I switched to device type Iris Smart Button and back.

I reset my Iris Smart Plug and followed the directions on the 1st post on this topic. Worked great at getting the great energy reporting functionality. I did set the device handler to SmartPower Outlet at the end of instruction #1.

However I couldn’t get the Z-Wave Repeater to connect in instruction #2. Definitely the plug would not go into pairing mode and make the light blink. I held it up to 10 seconds with no success. I tried other ways to get it to blink but no success. @blebson, do you have any other detail on how to do this?

@Paulrus, I sympathize with you. I struggled with resetting this. I swear it doesn’t work a normal way. I finally got it to reset by holding the button down while its plugged, but releasing the button about 1-2 seconds later immediately after the light just starts to blink. It then goes into blinking state, ready to pair. Can’t hold it until it blinks. Have to release after the first blink. Strange. Try that out. BTW, I think the Z-Wave Exclusion instructions are irrelevant unless you got the Z-Wave repeater paired and need to remove it to start over.

@Paulrus, also if you have already set this up as a plug and need to clear it out, remove the device in the app first (frees up the hub to pair to this plug again) before starting the pairing mode on the plug. Also I noticed my hub light was not blinking green when trying to connect (pair). I had to reset it.

If you had previously had the z-wave repeater added to smartthings then you’ll have to run a z-wave exclude before pairing it back to the hub. Once it’s in pairing mode (light blinking) it should automatically find it.

@blebson I know this thread is specifically about the 3210-L, but do you know if any of the other IRIS V2 devices work and or if they need custom device types? Where did you find this device type, I note that Smartthings themselves authored it.

Hey Kraig,

@mitchp has created devicetypes for pretty much all of the other Iris v2 devices. I created this devicetype by modifying the standard Smart Things SmartPower Outlet devicetype to include the 3210-L fingerprint (allowing it to automatically assign itself during discovery). See below for a list of other threads with devicetypes:

1 Like

I just got my plug in the mail today. The zigbee part worked like a champ. As for the zwave… I can (occasionally) get the plug into a pairing mode (more on that below), but my hub can’t find it. If I go into exclusion mode and poke the little button off/on repeatedly, it will eventually tell me it excluded an unknown device. But nothing shows up when looking to add a device. I tried for about half an hour and eventually ran out of time & had to give up for now.

To get it into pairing is a bit fidgety. I pull the plug from the wall, hold down the button for a few seconds, plug it into the wall (while holding the button), and start rapidly poking the button (faster than the once-per-second instructions you can online find for the old version of the plug) until it does the flash-flash, pause, flash-flash bit.

2 Likes

Try getting it into pairing mode by simply holding the button until the light starts to blink. That’s the way I got it to pair and it was almost instant.

I held the button multiple times for over 30 seconds… all it does on mine is toggle the state on/off.

Did you hold the button after you excuded it? For me the light starting blinking at a constant rate after entering pairing mode for the z-wave portion (which didn’t exist in the old version, so that pairing instruction should have no bearing on it).

@blebson, I finally got the repeater to pair. I needed to Z-wave exclude it first. I believe I needed to get the device real close to the hub and wasn’t doing that. Thanks!

1 Like

@benjaminellison, I don’t recall clearly what the key was for me to pair the z-wave. My brain is mush from struggling with this stuff. I think I needed to get the hub within an inch of the device and just press the button repeatedly a bunch of times. It didn’t need to be in pairing mode. Try that.

I can confirm, perform a general device exclusion first, then unplug/replug the smart outlet. quickly press the button 4 or 5 times. It will start blinking in pairing mode. if it doesn’t do it immediately, just keep quickly pressing in groups of pushes, it will eventually get in pairing mode.

and actually for the zigbee join, I used the SmartThings instructions to hold the button while plugging in and wait for the light blink once, and then let go,

3 Likes

Great code. Worked like a charm and it is $20 less than the equivalent Smartthings device!

$20 less AND has the z-wave repeater, hard to beat! :slight_smile:

1 Like

I am using this device type with two Iris 3210-L smartplugs.
The plugs work fine, they report power use, but only when I refresh them.

I can’t get them to automatically report power use for notification purposes.

Ideas?

Finally got this device for $35 at our local Lowes and it was very difficult to pair. Tooks several attempts with several exclusions. I followed the instructions and added the custom device app provided at the top of this post.

Two devices are added, the Z-Wave Outlet first, and then after another pairing the Outlet appears and function perfectly as a controllable power outlet with wattage display.

According to the Lowe’s Iris Device Support page for this model, it will handle up to 1,400 watts. I currently have it connected to my supplemental kitchen electric baseboard heater and it was pulling 1,250 watts.

I have the ST power monitor app installed which insures that if it exceeds 1,300 watts, it will turn off. I also installed the SmartAPP that turns it off after X minutes. Hopefully the ST cloud will function to perform these functions should we forget and leave the heater on for longer than X minutes.

@blebson: One question: When I check devices that run locally, it does not show this device in the list (actually I do not any devices in the list) and I changed the device type to “Smart Power Outlet” as you suggested and rebooted the V2 hub. I am guessing that I have one of the following issues:
For a little more clarity there are 3 things needed to run an app locally.

  1. The app is able to run locally
  2. The device itself is able to run locally
  3. The official device has been added to local execution in appEngine

If one of those three things is missing it will run in the cloud.

I don’t really know how to fix this using the custom devicetype but I’ll look into it. This is currently how mine works. You could always use Pollster to refresh the device at a specific interval.

When I changed my devicetype to the SmartPower Outlet it made it so the device was handled locally and shows on the appropriate list. I’m using it with a SmartLighting automation which also properly shows as a locally running SmartApp. Not sure what is preventing yours from running locally (I’m already assuming you’re using the v2 hub.)

Where is this list of devices that run locally? How do you check that? Is it in the app or on the website?

Edit: I found this post with a link to the locally executing smart apps: Local Processing in Hub V2, is that the place where you check?

These links will show you what devices and SmartApps are running locally (at least for the US v2 Hub).

1 Like