SmartThings Community

[RELEASE] Insteon Hub 2244 and 2245 Dimmer and On/Off Plugs/Switches/Bulbs

dth_lighting
insteon
dth_misc
#131

Having the same problem with the same exact error. Tried with straight IP address, no dice.

0 Likes

#132

I did some digging and looks as a June 20th update broke API access for a lot of other 3rd party applications. The firmware is labeled 1016. Supposedly if you email support with your hub ID and account ID, they’ll push a rollback and everybody recommends blocking your hub from updating again.

https://forums.homeseer.com/showthread.php?t=196335&page=7

0 Likes

(Colfax Upton) #133

Hey thanks for posting this! Save me a ton of time troubleshooting.

0 Likes

#134

Hi all, I have SmartThings setup with a few monitoring devices. I have an ISY and purchased an Insteon Hub. What is the easiest way to make Insteon work with SmartThings?

0 Likes

(Scott Kuester) #135

@mfranzel You’re in the right place. The easiest way to integrate your Insteon stuff is by using the device handler linked in the first post. Should be fairly straightforward to set up, but let me know if you have problems.

0 Likes

#136

I troubleshooted the dead Insteon issue today, and found that the problem is that the hub now requires https, which isn’t supported. By coincidence, Insteon happens to be updating the firmware to 1017 today to fix the issue! Keeping my fingers crossed!

0 Likes

(Dave) #137

Did this resolve the issue for you?

0 Likes

#138

Yes, it did!

0 Likes

#139

@kuestess Thanks for the hard work here. I’m using the device handler and ST’s Smart Lights SmartApp to mirror the settings of an Insteon switch with non-Insteon devices. The issue I’m facing is a lang time that occurs when an Insteon wall switch is manually toggled. The ST app sometimes takes 20-30 seconds to show a status change which means the SmartApp function is also delayed. The same is true with toggling the wall switch off, takes about 30 seconds for the other devices to power off. Is there any way around this? Are you familiar with IFTTT or Stringify delays, I imagine they’d produce a similar issue. Thanks again.

0 Likes

(Scott Kuester) #140

@supervsn The DTH only checks status every 3 minutes via the poll function. If you change the delay in runIn(180, refresh) to some shorter duration (180 is the poll frequency in seconds) that should update status quicker. Hope that helps.

0 Likes

#141

I realize this is old thread but, I am attempting to add some existing Insteon devices to my smarthings. I have copied both DHLs, edited the password, login, IP (should it be local or Public, I used local 192.168) and then edited the individual devices, using the Insteon ID example 3A.3C.84 and entered as 3A3C84 as you did not have any.
I am not able to recognize any of the device, I obviously missed something. Can you help.

Jack

0 Likes

(Scott Kuester) #142

@millsjq The ip address for your hub should be the local address, so based upon your example that looks correct. Make sure that you specify the port (25105 by default) and use the username and pass from the Insteon app. This is NOT the email and password that you use to login, but inside the app got to Settings->House and its the ‘Hub username’ and ‘Hub password’ at the bottom of the page.

0 Likes

#143

kuestess, Thanks .

I was using the correct port and IP, but wrong username and password. I have edited the hub Device Handler, should there be any edits in the switch handler, I did not see anywhere needed. I must be daft as I still do not have any devices showing, after correcting, saving and publishing the handler should I use the smarthting app “add a Thing” or something else.

Should I have a device in the handler as 3A.A6.2B or AA6C?

0 Likes

(Scott Kuester) #144

@millsjq No need to edit the DTH directly. Easiest way is to use the IDE - after you login, go to the ‘My Devices’ tab and click add new. In the resulting page, select the DTH from the dropdown in the ‘Type’ field. Fill out all of the other required info and click ‘Create’. In the next screen, edit the preferences to add deviceid, username, pass, etc. Save that and you should be good to go.

0 Likes

#145

Scott, Obviously I was way off. I have added a new device, selected hub, and assuming this device if the hub put in the Insteon ID for the hub, selected the DTH for the hub. Then I edited the ip, port, username and password. Then I added a device for the switch, added the Id for the switch etc. Apparently I still missed the boat as I still can see any devices in SmartThings app, believe it should just show up, but have

0 Likes

(Scott Kuester) #146

@millsjq Sounds like you’re doing everything correctly. If the device doesn’t even show up in the app, you might try going to ‘Add a thing’ in the app (at the bottom of ‘Things’) to force it to refresh. Mine usually shows up without doing that, but it sometimes needs a refresh. The device should show up, even if its configured incorrectly.

0 Likes

#147

I am going to re copy the DHL incase I screwed up something when I went in a edited the hub info manually. One additional question when adding a device in the IDE for the Insteon Hub, after I select Insteon hub for the type, in the bub section do I leave blank or select SMARTHINGs from the drop down.

0 Likes

#148

I have put myself in circles. I realize I was using finik DHL not yours, I deleted everything and started over with your Insteon Dimmer switch and Plug, dated 2017-12–30. I used the device ID for the switch on both the added device and when editing the hub info. I now show the device, but it shows always on and will not turnoff and has no effect on the switch. The IDE logs show ( below) show the Command is timing out, so I tried my local and external IP in the URL field in the edited portion of the add device.

Should I be using a different DHL version and start again, I am obviously over my head on this but keep thinking I am one edit away from success and then trying another.

2b701312-f08d-45f3-b761-c74468a52979 10:09:28 AM: error org.apache.http.conn.ConnectTimeoutException: Connect to 192.168.1.17:25105 [/192.168.1.17] failed: connect timed out @line 163 (getStatus)

2b701312-f08d-45f3-b761-c74468a52979 10:09:18 AM: debug [uri:http://user:pass@192.168.1.17:25105/3?02623AA62B0F1900=I=3]

2b701312-f08d-45f3-b761-c74468a52979 10:09:18 AM: debug Polling…

2b701312-f08d-45f3-b761-c74468a52979 10:09:18 AM: debug [uri:http://user:pass@192.168.1.17:25105/3?02623AA62B0F1900=I=3]

2b701312-f08d-45f3-b761-c74468a52979 10:09:18 AM: debug Polling…

2b701312-f08d-45f3-b761-c74468a52979 10:09:08 AM: error org.apache.http.conn.ConnectTimeoutException: Connect to 192.168.1.17:25105 [/192.168.1.17] failed: connect timed out @line 125 (sendCmd)

2b701312-f08d-45f3-b761-c74468a52979 10:08:58 AM: debug Sending Command

2b701312-f08d-45f3-b761-c74468a52979 10:08:58 AM: debug Turning device OFF

2b701312-f08d-45f3-b761-c74468a52979 10:08:58 AM: debug Sending Command

2b701312-f08d-45f3-b761-c74468a52979 10:08:58 AM: debug Turning device OFF

10:07:46 AM: info Waiting on events…

10:07:46 AM: info For past logs for individual things go to the My Devices section, find the device and click on the Events link on the device information page.

10:07:46 AM: info This console provides live logging of your SmartThings.

0 Likes

(Scott Kuester) #149

@millsjq You may want to edit the last post as it has your hub user/pass in it :slight_smile:. It looks like the DTH is working, but not connecting to the hub for some reason. To figure out what the problem is, paste the commands below into a terminal window (sub in your user/pass). It should give you an error message indicating what the issue is. If these work ok, then we need to look elsewhere.

Turn on:
curl[user]:[pass]@192.168.1.17:25105/3?02623AA62B0F11FF=I=3

Turn off:
curl[user]:[pass]@192.168.1.17:25105/3?02623AA62B0F1300=I=3

0 Likes

#150

Scott, Thanks again. I inserted my hub name and password to match the app, and I get, no match.

Tried resetting the Insteon Hub, now with different local IP. No dice, changed my hub name and password and still get no match.

I went into IDE and changed the device to match the new IP, etc. the thing in ST stays as “on” but on a curious note when I did this my Insteon app would not work, with message that something was wrong. I went to the device and put in a bogus (the old IP) the Insteon app resumed working. Something must be happing but beyond my technical ability.

0 Likes