[RELEASE] Initial Setup for Ecobee3 & 4, Smart-SI, EMS, Smart-02 thermostats - My Ecobee Device

OK, I understand your dilemma better now.

If you have multiple motion sensors in your home, then using ecobeeSetZoneWithSchedule would help you in setting your home to away or present w/o having to change your holdType parameter.

You could then use the smartapp with motion sensors and associate your ecobee schedules (Home, Awake, Sleep, any custom ones) to given schedules within the smartapp and run them only for specific ST hello modes.

The ecobee Sleep’s associated schedule in the smartapp should only run when you’re at home, not when your ST hello mode is away.

I hope that you understand my point: in brief, ecobeeSetZoneWithSchedule is very flexible and can combine a given ecobee schedule with some specific ST hello mode(s) if required…

Anyway, if you need further help, you may want to hire my services as a consultant. See http://www.maisonsecomatiq.com/#!home/mainPage for more details… :grinning:


Nice! I can’t think of someone more qualified than you to consult on things like this! If it comes down to it, I’d love to compensate you for all the help you’ve given me and for your super awesome ST integration.

I am trying to delete this smart app so that I can move over to the new v2 hub but it errors on both on the mobile app and ide. IDE says it cannot delete because it’s install on the mobile device. Mobile device simply says “An unexpected error has occurred.”. Any help would be greatly appreciated.

Hi @3one5,

  • I suppose that you’re talking about MyEcobeeInit smartapp…

  • If it’s the case, you need first to click on MyEcobeeDevice under Things (or under the right room if you have upgraded to the new UI), click on the gear at the upper right corner and check which smartapps use the device (you can do the same under the IDE by clicking on the device under https://graph.api.smartthings.com/device/list)

  • You’d need to uninstall each smartapp first before being able to uninstall MyEcobeeInit.

  • You can also click on https://graph.api.smartthings.com/ide/logs for more trace.

Please support the developer!

That did it! Thank you Sir!

I’ve been getting constant exception errors for the last few hours. I don’t know a lot about the Smart Things programming language, but is there a way to write an error handler for this so it doesn’t send notifications for each one?

@flashburn, if you do not want any notifications, just say ‘no’ to ‘Send a push notification’ in the last page (called Other settings) of MyEcobeeInit (just before pressing done).


1 Like

Nice, thanks Yves. That’ll do until Ecobee can get their act together.

@yvesracine Hey there, just got a ST v2 and used your awesome work to link my Ecobee3 so thanks for that. I just got it running a few hours ago and just got a message of too many exceptions. I see someone else had a similar issue so I went in and turned on the logging. Its running now but nothing out of the ordinary. GOing to let it run for a bit and report back.

Question though , on the prefs side there are other prefs such as appkey, ecobeetype, and thermostatid. Do I need to be filling this in in order for it to work right? I didnt see it mentioned in your guide but maybe I just missed something. I did confirm that when I set the temp it did update the web portal for ecobee (since I’m at work at not in my home)

Thanks again!

HI @Roach, I had a high number of exceptions myself and it looks like this is due to slow response times on the ecobee servers side.

Since I created the MyEcobeeInit (service manager) smartapp, the above preferences do not need to be populated anymore as they are set by my service manager.


Please support the developer!

Hello and thank you very much for you work on this!

The instructions got me up and running in no time – but (there’s always a “but” isn’t there?) I’m not seeing a way that I can use the ecobee vacation scheduler to manage my ST mode. Am I missing it somewhere? In general, I’ve been happy with their scheduler and I appreciate its ability to handle recovery times. Is there some reason this would be a bad idea?

Hi @Tracy_S_Fitch,

I’m not sure that I understand your use case here…

Why would you want to set your ST hello mode based on your ecobee vacation schedule?

Usually, people would associate their ST “Away” mode with their ecobee “Away” program…

The ecobee Vacation “schedule” is normally for few exceptional events throughout the year that are outside of the realm of ecobee programs such as Home, Away, Sleep, Awake, or any custom ones that you define.

Anyhow, my smartapps just handle the ST modes associated to the regular ecobee programs, but nothing prevents you to use My Ecobee Device to code your own smartapp according to your requirements.

Please support the developer!

P. S. FYI, in MonitorAndSetEcobeeTemp & ecobeeSetZoneWithSchedule smartapps, the ecobee ‘Away’ program is automatically set when there is no motion at home according to a threshold in minutes that you define… As those smartapps constantly run and wake up, this usually takes care of most of the requirements out there for switching back and forth between the ecobee Away and at Home programs.


Is it possible to increase the 3 Ecobee max limit in your App?

Hi @mkaplan2534,

This is no ‘hard’ limit constraint on the number of ecobee thermostats that My Ecobee Init (Service Manager) can manage…

However, it is recommended to not select more than 3 ecobee3 therrmostats per instance of my Service Manager in order to avoid the ST platform rate limiting issue as specified here:

especially, if you have many remote sensors and you want to expose them thru my ecobee3RemoteSensorInit smartapp.

If you do have more than 3 ecobee thermostats, you just need to create another instance of MyEcboeeInit by specifying a different name at the last page (Notifications and other settiings) when prompted (see following parameter below)

	section([mobileOnly:true]) {
		label title: "Assign a name for this SmartApp", required: false


Thanks for the help. Another question I had which is if I set the temp to, say 80 when I leave, and then have it set to 75 when I get home, I find that it sets the settings to 75 AND HOLD. How, instead, can I not feed it the 75 temp and instead tell it to just resume its schedule? Or can I have do 75 until the next point that I have it set to change. (ie at 1030 at night I have it drop another degree, but it wont do this on hold)

Thanks again for the awesome work

Hi @Roach, Please read the very beginning of this thread where I’ve explained the different scenarios and smartapps that you can use for your use cases.

Please look at my ecobeeResumeProg smartapp.

Whenever you change the ecobee heating/cooling setpoints outside of its regular schedule/climate, this will create a ‘hold’, there is no way around it.

If you want the hold to be temporary till the nextTransition, please set the holdType parameter accordingly in My Ecobee Device. This is also explained at the beginning of the thread.

Bye for now.

And,.please support the developer :grinning:

Thanks again. I will go back and look back over that. :smile:

Hello! New to SmartThings (First post) and just set up my system a few days ago. Also just bought my ecobee. I’ve added MyEcobeeInit and it does show up in the SmarApps marketplace under MyApps… But, when I press passed the first page with “About” Etc, it gives me a blank screen and doesn’t allow me to put in my ecobee credentials. I saw in your instructions that you said OAuth had to be enabled, but I can not find this option anywhere in the new App (I never had the old app). I’m trying to set this up away from my house, so it could be that I need to be next to the hub and thermostat to get this going? Thank You!

Hello, I’m glad that your first post is about My ecobee device…

You need to enable Oauth in the IDE when you click on the smartapp. Please follow the readme at my github…


Found it! Thanks so much… once I get this up and running I’ll definitely support the developer :slight_smile: Planning to set this up with ecovents which I believe you’ve written a smartapp for as well! Thanks for your work on this.