SmartThings Community

[RELEASE] Improved Mobile Presence (Android only)

android
presence
dth_presence
project_presence
webcore

#141

Sorry about that. Had to update the server but I ran into some issues. Should be back up now.


(Rich Heimlich) #142

Hi John,

Thanks a ton for attempting this, as I find it much better than the default method like others have mentioned. I am having some trouble getting the app working and in an attempt to solve these issues I updated to 1.5 by signing up to the “Beta test” in the play store, as well as reinstalling the app. Unfrotunately this has put me in a dead end as there seems to be no way to add a network in 1.5 unless I am missing something. There is just the default location “Home”, which after selection gives me the bar to edit the locations name, the “Home Location” check box, and the text that says “Check the networks that you would like to include in this location”, but there are no networks shown below that and no way to add any as far as I can tell.

Before this on 1.4 everything was entered with no problem: New device with type “Improved Mobile Presence” added (coming from the github server) in ST, and the “device ID” option under the settings for the device set to the ID generated in the Presence Sensor app; however, the device seemed to perpetually be marked as “Home” in the Smart Things app with only two notifications at the same time stamp saying “[Name] Arived” that happened when I first pressed the refresh button. Pressing the refresh button every other time after this simply gave a “Update successful” notification and turning off the Wi-Fi resulted in a serious of “Update error #2” notifications, all the meanwhile the device status in ST still showing “Home”.

I was never asked for any kind of permissions, nor did any appear as an option under the application manager for 1.4. In 1.5 I have ticked off the “Location” permission.

I am not sure if I will still have the same issues under 1.5, since as I mentioned before I seem to be stuck without anyway to use the app. I am not sure if an pop-up is supposed to appear that isn’t showing itself, or if there was an oversight in 1.5 for people that reinstall (relying on the networks added in 1.4 or something). Either way I would love to see if I can get this method working so let me know what you think when you get a chance.

Thanks.

Phone: Galaxy S7 Edge
Android: 7.0


#143

They WiFi networks should all have been put into the home location after updating. Do you see anything listed in there at all? When you open it up, it might take like 10 seconds for networks to come up since its scanning.

Did you enable to optimization white list? If not then that can cause Android to block network connections in the background. What do the errors say after “Update error #2”?


(Rich Heimlich) #144

In the application manager under battery the app is indeed set to “Not Optimized”. When selecting Home I just get this screen that never populates any kind of network list:

In terms of the error, I do not remember exactly what it said as I no longer can use the app because of the above issue. Additionally, the information after the error title was so long that it was cut off in the notification. Of the part that was visible, it was some kind of Java error saying something about there not being a Wi-Fi connection, which is funny since the Wi-Fi dropping is part of the functionality of the app. Clearly a strange issue.


(Dana ) #145

This unfortunately has never worked well for me…

I just got home from being gone from 6:30 - 9:30 and while it says I’m home, the most recent activity in Recently is left at 10:41, back at 3:05.

So it hasn’t updated to show my departure at 6:30, nor my return at 9:30. The day before it shows me arriving once and never departing. Similar pattern on other days. Not sure why - I’ve turned off battery optimization as requested by the app, and the app has no trouble finding my home network.


#146

For those who need an alternative, I’m using Automate (Tasker would work too) to call Webcore endpoints which set to away or home mode upon Wifi connection or disconnection.

Unfortunately, it doesn’t work 100% because for some reason Automate misses some of the connections/disconnections. But better than nothing.


#147

For anyone that is having issues with the app, there is an update that I have been working on. Everything seems to be working on 8.1. If everything goes well there should be an update some time this week.\

Edit: Patch is now available under download links


#148

Did you have any issues with previous versions of the app?


#149

If we have the IFTTT app on our phone, why not just create a Smart Things switch that turns on Presence?



#150

After applying the patch and the current beta, it detects the wifi change and updates accordingly, but only if the app is already running in the background, from what I can see. I also ran into some cases of “no connection” errors when disconnecting wifi, but that’s not consistent.

Otherwise nothing happens till I open the app and do a manual push, like before.

The tasker/automate method has been working very reliably after I added a second check that doesn’t wait till a state change, but to make it simple for other users IFTTT might be a better option, trying that now.


#151

IFTTT could be very slow to respond - Couple of times now it took 30 minutes+


(Tony B.) #152

@johndc7
Are you doing work on the server?

Response has error: Failed to complete. Message was: connection timed out: st.callahtech.com/68.51.51.173:443


#153

No, but i’m currently having some internet issues. Working on it now so it should be back up soon.


(Tony B.) #154

Where is the beta link for the Android App? Or, is it just published not as a beta?


#155

Internet is back up but my IP changed so everything should be fully functional as soon as my DNS changes go through. About the beta… you should be able to opt in if you scroll down to the bottom of the page in google play. Try this link if that doesn’t work. https://play.google.com/apps/testing/com.callahtech.presencesensor


#156

johndc7 I installed the latest beta and the 8.1 patch and I am getting a notification with an update error. I have attached a picture.


#157

Does it work if you hit refresh it in the app? Looks like the error says something about ssl but I’m not getting it on my phone which is weird. I was doing some work on the server earlier so maybe that caused it.


#158

Yeah if I refresh it in the app it works.


#159

Ok. Probably just caused by me doing some work on the server earlier then. Try turning off the WiFi to make it update and see if it does it again.


#160

This is the error that it gives me after turning off the WiFi and turning it back on again.