[RELEASE] Improved Mobile Presence (Android only)



No, once you create the device there is a setting in the SmartThings app.


Got it. I would just add to the instructions on top that you have to go back to the IDE to the device you created and update the type to improve mobile which will be towards the bottom of your list

(Gary Clark) #43

Real noob question but how do i update this from Git hub Please.

(Bob) #44

Are you in the UK or US?

(Gary Clark) #45

im in the UK

(Gary Clark) #46

im not sure how to add a repsitory?

(Bob) #47

(Gary Clark) #48

Oh… Ok… lol.

Is the posted device up to date the same then? if so that will do.

Many thanks

(Gary Clark) #49

@ johndc7.

looking forward to this Hope it solves my headach with the presence issue.

Thx a lot

(Bob) #50

Once you have github integration you do the following.
Go to the code in github.
You will then see an icon that says ‘Fork’. Top right.
Click on it.
Then in the ide go to device handlers.
Click on settings.
Click on add a new repository and fill in the fields with the following.
Click on Save.
Now in the device handlers, for the Presence DH click on the 3 lines on the left.
Now click on the Dropdown for Github Repository and select the repository that you just set up.
Now click on update.
It should now change to black italics and look like this.

If it has a magnifying glass next to it, open the DH, click on save and then publish, for me.
If the DH is now updated, the DH will change to a blue colour. There will also be a magnifying glass. Click on the magnifying glass to update the DH.
Hope this all makes sense. :slight_smile:


Thanks for the directions, I’ll be adding this to the setup instructions. :slightly_smiling_face:

(Gary Clark) #52

Super Lesson. Now i understand. Many Thanks


Sorry it’s not working right now. It should be back up in around 3-4 hours. Having some internet issues in my area.

(JIm) #54

I installed everything and got it configured. Seems to work. But… Wanting to do some testing. So I was trying to look at the time it changes my presence. But there is nothing in the recently tab. And the time on the presence device shows the current time I looked at it, not the time it changes. Which doesn’t tell me much.


I haven’t been having any problems with that. I looked through the device handler and I don’t see any reason for it to do that. Check the logs and see if its trying to update the presence. The only time the presence time should change is if it tries to update the presence again.

(JIm) #56

Apparently when I copied the ID a dash at the end didn’t copy. I manually added that and now it looks better. In the log I notice it is checking once a minute. Is that normal? And if so, is that the quickest response time if I connect to my wifi?


It checks the server one per minute but that doesn’t have anything to do with when the app updates the server. Most of the time it takes less then 30 seconds from when you get home but it shouldn’t take more than a minute.

(anh ho) #58

created the new device but couldn’t find the device id setting in the SmartThings app. please help


Sorry for the late reply. The setting is in the SmartThings app. After you create the device online from the device handler.

(anh ho) #60

Thank you for your response. I am new to this stuff, still learning. I only got the option to change the device name, but not last three options as shown in your image. I probably did something wrong. What do you do with the device handler in your download link?

Thank you