SmartThings Community

[RELEASE] Improved Mobile Presence (Android only)



Everything should be updated and there are currently no known issues with the setup.

Let me know if you have any issues with it and I can update the instructions if needed.

(Rob L.) #322

I am trying to use this device. I believe I have followed the instructions, but when attempting to add the Presence Sensor from the My App under SmartThings. After selecting to Create a new device, and giving it the name of “Rob”, I get an error that says: “There was a problem processing your request. Please try again.”
It does create a New Device Id.

If I then click in Pair this Device, and open the tab in the browser, I get the following error:
Update Error #3.
And, in the notifications on my watch is says:
“Unable to locate linked SmartThings account. Linking your account again should resolve the issue”

Where does it need to be linked?

I am using a Galaxy S9 (SM-G960U1) running 8.0.0 with the latest update security update.

Thanks for any assistance.


That would make sense since it doesn’t save in the SmartThings app.

Do you see any errors in the logs (online under live logs) when you attempt to save in SmartThings? I assume OAuth was enabled correctly and everything right?

(Rob L.) #324

Yes, OAuth says “Yes” under SmartApps. I did have it Refresh the Client Secret though, in case that would help.
I also uninstalled the app on the phone, cleared the cache and re-installed. As soon as I launch the app, I get the Error #3.

I guess I’m going to start over.


The issue is with the SmartApp not saving. When it saves it updates the server with a token to be able to sync with SmartThings. If it’s not saving then its not sending the token to the server. Then when you sync the Presence Sensor app it gives you that error because the server does not have the token to sync with SmartThings.

Reinstalling the SmartApp and everything might help. Let me know if you still have that issue after reinstalling.

(Rob L.) #326

So, I uninstalled the SmartApp and Device Handler from my hub, and uninstalled the app from my phone.

I then started back over from Step 1 of your instructions. Everything went well until I went to pair the new device.

I went to the Classic App, Marketplace, My Apps, and then Presence Sensor.
I clicked on New Device box and typed in a name - “P1”
Then, the options for Pairing showed, and I selected “Pair this device”.
It launched the browser, and I could see that it went to your server, and then went to the Presence Sensor, and immediately gave the “Update error #3

I tried several browsers - Firefox, Samsung, Chrome to see if that step was the problem.

Not sure what else to try.


When you go to presence sensor in the marketplace, make sure you hit save before doing anything. Then go to SmartApps under the automation tab to pair devices.

This is important because it will not authorize the server to connect to SmartThings unless you hit save.

(Rob L.) #328

That was the issue!!!

Had to hit the Save button BEFORE I tried to give it a name, etc. I missed that in the instructions - 4 item under Step 5.

Now it is showing I am at Work. Have to go home tonight to set the WiFi SSIDs there, and then to hopefully getting this to work instead of the one built into the Smartthings app.

Thanks so much for the help!!!


Is there a way to set it up so that NEST would use this for it’s presence sensor as well as ST? How about Arlo? I have trouble with presence sensing on all 3.


Unfortunately, I do not have nest or arlo. There might be a way to do it but currently it only works with SmartThings.


Saw this for Arlo. Maybe this might be helpful.

(Samuel) #332

I also have problems installing the Presence Sensor.

I have installed the code from Github and enabled OAuth in the IDE.

I go to Marketplace/SmartApps, My Apps and select Presence Sensor. I change nothing but just tap Save.

I get the “Succesfully added…” message.

I tap the Presence Sensor app in Automation/smartApps. I tap New Device. I tap Device name, give a name to the device and tap Save. I get the error message: “There was a problem processing your request. Please try again.”

Don’t see any related log entries in the IDE. A device is created and a device id is visible. When I try to pair it (Pair this device), Chrome opens and launches Presence Sensor app which reports the “Update error #3” (An unexpected error occurred.)

I have tried refreshing the OAuth tokens. I also tried to install the SmartApp using the IDE’s simulator but got a bunch of errors:

grails.validation.ValidationException: Validation Error(s) occurred during save():
- Field error in object '' on field 'state': rejected value [COMPLETE]; codes [,,,,,installedSmartApp.state.validator.error.state,,installedSmartApp.state.validator.error, '[notify]' is, '[notify]' is required.state, '[notify]' is, '[notify]' is required,installedSmartApp.state.Input '[notify]' is,installedSmartApp.state.Input '[notify]' is required.state,installedSmartApp.state.Input '[notify]' is,installedSmartApp.state.Input '[notify]' is required,Input '[notify]' is,Input '[notify]' is required.state,Input '[notify]' is,Input '[notify]' is required]; arguments [state,class,COMPLETE]; default message [{0} does not pass custom validation]


You should just be able to select a pairing option after typing the name and hitting enter.

Do you receive that same error every time you hit save?

(Samuel) #334

Yes, same error every time. I have tried with three phones. (Oneplus 3T and two Nokia 5 models.)

And same error also when I just enter a name for the device, tap enter and select “Pair this device”.

What should happen in the pairing process when the Presence Sensor app launches? A new presence type device should appear in the SmartThings Classic app?

(JIm) #335

I just installed everything as stated. Everything says its ok, id matches, no errors, etc. But it always shows as present even with wifi on phone turned off.


Sorry for the late reply (had some family stuff going on). To answer your question, yes, you should scan the QR code and the device should appear in SmartThings.

Just to confirm, you said the device is created in SmartThings?

Also can you please PM me your device ID so I can check the logs, etc.

(Scott) #337

I just installed the Smart App and handler. When I try to pair my phone it goes to a website… and nothing ever happens on the web page. I am running Android 5.0 and I have no ad-blocker running. I’ve tried both the Samsung and the Chrome browser and the result is the same. Is this app still active?


It should open in the Presence Sensor app. I can look into it a bit, but you should still be able to pair it with the QR code method (pair different device).

(Scott) #339

@johndc7 I go into the MarketPlace. I choose SmartApps, then MyApps. I choose Improved Presence Sensor. I give it a name under new device. I touch SAVE. I then do the “Pair” this device after selecting my cell phone. It then runs off to the st.callahtech website where it gives me a “Parameters Invalid” error.


Hit the option to pair the current device, then PM me the full URL it sends you to.