SmartThings Community

[RELEASE] Improved Mobile Presence (Android only)

android
presence
dth_presence
project_presence
webcore

(Kevin Rowe) #221

Another data point to note, switching from one wifi to another does in fact change state to Away, however changing from Home wifi to mobile data does not change state to Away


#222

Any connectivity related issues would give you an error notification. It should at least give you some type of notification letting you know that it is waiting for an internet connection once it detects a network change (as long as status notifications are enabled in the app settings). It sounds like that could be where your issue is since you said that it is detecting a change if you connect to a different WiFi network.


(Scott) #223

Got a new phone so reinstalled the app. It’s showing my device id is null. I’ve tried reinstalling it. The 8.1 patch does generate a notification but sometimes it’s the Data one but othertimes it’s ‘Error checking for updates’


(Fred) #224

I’ve tried several times to load the app and the patch on my Moto Z2 Force phone, but the app does not generate a device id, all I get is. “Your device ID is: null”, any suggestions?


#225

Forgot to fix that after updating the server. Should be working now.


(Scott) #226

Thanks! Working now


(Fabio Cardoso) #227

Hello, I am trying this out and followed all steps but when I try to authorize presence sensor I select the location and the divice but it says that it can’t verify the link. Any suggestions? Thank you very much for your time and help


#228

What is the exact error you are getting. Make sure you check your spelling as IDs are case sensitive and not all lower / uppercase (if it says device ID invalid this is most likely your issue).


#229

I am getting the same error when I try to enter client id and secret, I get the message
“Unable to verify link status.”

I made sure to copy/paste info so it is not an issue with upper lower case or anything like that. any thoughts?


#230

Looked into it a bit more. Looks like it was an issue when only linking one device. Should be working now.


#231

Thank you, working now! I hope this works better than Stock Presence with Oreo… Thanks for all your work on this.


#232

I’m always getting AWAY status , even when at home and connected to Wifi.
Oreo 8.1 , with patch running and reporting Received Data : Test Data. any clues ?

3a1fad89-c900-48c5-b5e1-4b4a68d9d479 10:43:19 PM: debug Previous Location: Invalid ID

3a1fad89-c900-48c5-b5e1-4b4a68d9d479 10:43:19 PM: debug Current Location: Away

3a1fad89-c900-48c5-b5e1-4b4a68d9d479 10:43:19 PM: debug Recieved “{“id”:“XXXXq3”,“present”:false,“location”:“Away”}” from server

3a1fad89-c900-48c5-b5e1-4b4a68d9d479 10:43:19 PM: debug leftCounter: 2

3a1fad89-c900-48c5-b5e1-4b4a68d9d479 10:43:19 PM: debug setPresence(false)


#233

Did you get any errors when linking in step 6?


#234

Yes, I put the same number as the network ID #, but i read through your post and found my error. Repair to the correct number and now i’m getting AWAY all times…


#235

Make sure you have everything correct. Copy and paste from the app to SmartThings. I looked for your device ID in the server and it does not appear to be linked correctly. You can PM me your full device ID to be sure but it does not look to linked correctly. Also if SmartThings is not updating with the presence sensor app, even if you hit refresh in the app, something is most likely spelled wrong somewhere.

If anyone has any ideas on how to make this process more user friendly, please let me know as I am aware that it can be a bit of a pain.


#236

I have the same problem as
krowe001KEVIN ROWE

Going from Home to AWAY does not showing AWAY unless you i do refresh in the android APP
Going from AWAY to HOME works perfect

any ideas ?


#237

Do you get errors or does it just not update at all?


#238

No errors are displayed in the Android App., the icon color even changed to Grey. After pressing refresh everything is updated and Away status is displayed in Smartthings.
It will display Home otherwise.

Ideas?


#239

I though that everything was fixed after uninstalled and re-install the Android App.
Presence sensor seems like working and showing all states without errors.
But after few hours the same happened again. Going from Home to Away is working only after refresh…
No refresh --> status stays at Home
Please advise…


#240

Any errors and what version of Android?