[RELEASE] Improved Mobile Presence (Android only)

I get to the point where I’m putting my device ID into the ST device and when I hit Save, it just keeps saying “please fill out all required fields” but everything is filled out.

Sorry for the late reply. Didn’t see the notification. I had that issue a while ago but it’s an issue with SmartThings. Try and remove the device and add it back again.

Removing it and adding it again didn’t fix it for me, but entering the ID in the Device on the IDE did the trick.

Ok let me know if you have any more issues

John - I appreciate your continued development on this app. I’m having the same issue reported by multiple folks (mark2k, DrChops) above, re: presence sensor app detects me leaving my home WiFi network, but isn’t automatically notifying the server. With status and error messages turned on in the app, I see no notifications when connecting and disconnecting from WiFi. The location icon in Presence Sensor turns from blue to gray, so it seems like the app knows that I’m coming and going, but it isn’t automatically posting the activity. Using the manual refresh button in the app, I get the expected “Update successfully posted to server” notification. After using the manual refresh button everything seems to work fine for a while, and then the app reverts to the aforementioned unexpected behavior. I’m experiencing this issue on 3 android phones all running version 1.5 of the app on two different SmartThings locations. Let me know if I can forward any data to assist in working this issue. Thanks again for your help!

Unfortunately this has stopped reporting correctly. It’s showing me at home when I am away. I removed and replaced added the ID.

That is an issue with Android 8.1. Are you having that issue on anything other than 8.1? I’m working on it but I don’t have any devices with 8.1 to test on.

Yes, one of the devices is running Android 6.0.1 and the other two are on 6.0.

Ok I might have something with Android 6. Not sure. Just to be sure… You did allow all the permissions it asks for right?

I’m also looking for 6.0.1 help if you are able.

Yes, sure did. The only permission it asks the user for is “Location” but it’s getting all of these additional requirements as well:

  • view network connections
  • connect and disconnect from Wifi
  • change network connectivity
  • view Wi-Fi connections
  • full network access
  • run at startup
  • android.permission.REQUEST_I

Also of note - I’m running the app with error notifications enabled and I don’t get any errors during the periods of unexpected behavior. It seems as though the app is functioning normally as far as detecting if I’m home or away based on my WiFi connection. It just isn’t automatically posting the update to the server.

if remote access to an 8.1.0 android device will help, let me know. I’m on a Pixel XL.

Thanks for working on the device handler for the community. It has been working great for me since you released it. Although, like others posting recently it’s been erratic lately. The gf has a Galaxy S6 with 7.0 (pretty sure). Looking at the logs whenever I try and manually update the device via the ST app tries to poll the device location status and there are many errors.

Response has error: Failed to complete. Message was: Connection refused: st.callahtech.com/68.51.51.173:443

Sorry about that. Had to update the server but I ran into some issues. Should be back up now.

Hi John,

Thanks a ton for attempting this, as I find it much better than the default method like others have mentioned. I am having some trouble getting the app working and in an attempt to solve these issues I updated to 1.5 by signing up to the “Beta test” in the play store, as well as reinstalling the app. Unfrotunately this has put me in a dead end as there seems to be no way to add a network in 1.5 unless I am missing something. There is just the default location “Home”, which after selection gives me the bar to edit the locations name, the “Home Location” check box, and the text that says “Check the networks that you would like to include in this location”, but there are no networks shown below that and no way to add any as far as I can tell.

Before this on 1.4 everything was entered with no problem: New device with type “Improved Mobile Presence” added (coming from the github server) in ST, and the “device ID” option under the settings for the device set to the ID generated in the Presence Sensor app; however, the device seemed to perpetually be marked as “Home” in the Smart Things app with only two notifications at the same time stamp saying “[Name] Arived” that happened when I first pressed the refresh button. Pressing the refresh button every other time after this simply gave a “Update successful” notification and turning off the Wi-Fi resulted in a serious of “Update error #2” notifications, all the meanwhile the device status in ST still showing “Home”.

I was never asked for any kind of permissions, nor did any appear as an option under the application manager for 1.4. In 1.5 I have ticked off the “Location” permission.

I am not sure if I will still have the same issues under 1.5, since as I mentioned before I seem to be stuck without anyway to use the app. I am not sure if an pop-up is supposed to appear that isn’t showing itself, or if there was an oversight in 1.5 for people that reinstall (relying on the networks added in 1.4 or something). Either way I would love to see if I can get this method working so let me know what you think when you get a chance.

Thanks.

Phone: Galaxy S7 Edge
Android: 7.0

They WiFi networks should all have been put into the home location after updating. Do you see anything listed in there at all? When you open it up, it might take like 10 seconds for networks to come up since its scanning.

Did you enable to optimization white list? If not then that can cause Android to block network connections in the background. What do the errors say after “Update error #2”?

In the application manager under battery the app is indeed set to “Not Optimized”. When selecting Home I just get this screen that never populates any kind of network list:

In terms of the error, I do not remember exactly what it said as I no longer can use the app because of the above issue. Additionally, the information after the error title was so long that it was cut off in the notification. Of the part that was visible, it was some kind of Java error saying something about there not being a Wi-Fi connection, which is funny since the Wi-Fi dropping is part of the functionality of the app. Clearly a strange issue.

This unfortunately has never worked well for me…

I just got home from being gone from 6:30 - 9:30 and while it says I’m home, the most recent activity in Recently is left at 10:41, back at 3:05.

So it hasn’t updated to show my departure at 6:30, nor my return at 9:30. The day before it shows me arriving once and never departing. Similar pattern on other days. Not sure why - I’ve turned off battery optimization as requested by the app, and the app has no trouble finding my home network.

For those who need an alternative, I’m using Automate (Tasker would work too) to call Webcore endpoints which set to away or home mode upon Wifi connection or disconnection.

Unfortunately, it doesn’t work 100% because for some reason Automate misses some of the connections/disconnections. But better than nothing.

For anyone that is having issues with the app, there is an update that I have been working on. Everything seems to be working on 8.1. If everything goes well there should be an update some time this week.\

Edit: Patch is now available under download links