[RELEASE] HousePanel Dashboard for SmartThings and Hubitat

When you select devices to include in HO be sure to click on the bulbs you want under the bulb section.

Hello
I had Housepanel 1.8 installed on a Rpi.
A while ago I decided to upgrade to the latest version using the installer.
Now when I open the webpage I have to give a username and password.
I do not remember setting a user name or password in the past.
Is there a way to reset this and open the page?
I found the solution for this!
I had to run
http://yourip/housepanel.php?code=reset

1 Like

Glad you found the fix. The code=reset is currently undocumented but I think I will add it to the official website documentation since a lot of people seem to be getting locked out.

I hope you enjoy the new features in V2.109. A lot has been added since version 1.8 in addition to the passwords. For a full list go to Options and then expand the History by clicking on the history button.

Unfortunately V2.109 is not working for me.
I get an “This page isn’t working HTTP ERROR 500” error.
When i run phpinfo.php I can see “cURL support enabled”
I searched in the php.ini but I only found curl in
;extension= php_curl.dll
I removed ; and also tried and changed .dll to .so with no luck.

Was it working when you did the code=reset ? If so then what changed since then? Can you see all the files in the right place when you ssh into your rPI?

It did not work at all after the upgrade. At that time my problem was the password. When I found the solution for this I edited my post immediately not to bother you.
Then I faced the next problem but I thought it would be a curl issue and I didn’t updated my post.
Can you please tell what should be in the php.ini file regarding curl? I am using pi 3 and I have installed php7.0.

just do this from the rPI command line:

sudo apt-get install curl php-curl

that should reinstall or fix your curl installation

I had already done that, and I get the message that curl is already in the latest version.

Hmmm can you show me a screen shot of what you get when you try to launch it?

And you are sure you installed it into a folder beneath your default webpage location?

The installation path is /var/www/html/housepanel
This was also for the previous version I had.
I am attaching 2 screenshots.
I want to thank you in advance for all the job that you do and also for the help you are providing to me!

I am adding 2 more screenshots.
One is when I run the code=reset command, and the other is Index of housepanel

Finally I found what was going on.
When I run code=reset after the upgrade it seams that I changed timezone to Europe/Thessaloniki.
Now I change it to Europe/Athens and the page is working!!!

1 Like

I am trying to widen a slide on a tile for a dimmer switch. I am able to widen the tile but I have not been able to widen the slide. I can hide the level slide. What am I missing?

Also, how do I get the tiles to stay in place after I have placed them where I want them?

Is there a place where this information is posted so I can look through it?

Wow… thanks for sharing that. I will put in a try/catch block so that bogus timezone names don’t bring the entire app to its knees as it was doing for you. Glad you got it set up and working.

By the way, several people have had trouble with logging in so I am doing a rewrite of the login logic so that all options will now be on the options page and the hub registration page will just have the hub stuff on it. That way new users can get started without any passwords and they can add one later if they want. This will also enable password management to be done on the Options page where it belongs instead of on the hub auth page. That will be in a future release coming soon.

Anyway, glad you got it working.

I noticed that you have the hub refresh timer set to 60000. I know this is what I recommended as the default, but I have found that this makes the panel sluggish if you have lots of devices. You might double that to 120000 for better performance. You could even go to 300000 (this is what I do) because the hub pusher is set up and working quite well so full refreshes are not needed very often.

You aren’t missing anything. I just tried to do this myself and I see that only the slide background is changing with the tile width. The slider itself should also be expanded. This is a bug. I will fix it, but in the mean time you can edit your .css file directly to set the slider width. To do this, find out the tile number by inspecting your page and look for the “p_xxx” in the class. Lets say xxx is 125 and you want to make the width 230 pixels, then the style block to add is:

div.p_125.level { width: 230px; }

Add this to your customtiles.css file. Elsewhere in that file you will find a block that says:

div.overlay.level.v_125 {
width: 230px;
}

I would add it just under this block. Here are screen shots of my test example (tile 376) to help you.

This is what it looks like in the Chrome inspector once manually fixed
image

Tiles will stay once you click “Operate” near the bottom right of the screen. They will reorganize only when you either remove a tile or use the Reorder function.

Everything is documented at: www.housepanel.net

I am not sure what happened but I do not have the buttons running across the bottom of the window any more. I have been editing tiles and I added 2 more tabs. I tried to add another custom tile and it just kinda stayed there where I dropped it but it did not ask me if I wanted to add the tile. I tried to delete a tab but nothing happened. The screen refreshed and all of the button “Options, Refresh, etc…” are gone. I tried clearing my cache and changing the name of the customtiles.css. How do I get them back?

Yikes – you have a lot going on that doesn’t sound quite right.

First - let’s make sure your hmoptions.cfg file and folder are writeable. If they are not then your edits will not stick since they have to be written into the hmoptions.cfg file. They also are copied to hm_userxxx.cfg where userxxx is your username. Bottom line is the folder has to be writeable using sudo chmod 777 folder

You may also have gone into Kiosk mode by mistake. To turn that off you will have to manually launch the options page using the following:

housepanel.php?api=showoptions

On this make sure the checkbox for Kiosk mode is off.

Not sure how else to help you recover what you lost. I suggest spending some time playing around with it and reading through the docs at housepanel.net. The editing features are powerful and complex so take your time.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.