[RELEASE] HousePanel Dashboard for SmartThings and Hubitat

[RELEASE] HousePanel V2.090 - changes Hubitat HubId to the actual HubId instead of using App ID as before. This was done to support the second change which is reporting of use by Hub ID to my central server. At present I don’t do anything with this info but I might in the future. It just gathers anonymous usage stats by taking a hash of the each HubId authenticated. From an end user perspective this doesn’t change any functionality of the code other than you will end up adding a new Hubitat hub. You can delete the old one if you like from the auth page but it can hang around too if you don’t want to bother.

edit… I just realized that for ST the HubId was always done correctly so the extra hub won’t be created. The new use stats will apply to both types of hubs.

1 Like

I have tried this process on 2 different linux machines. I can get to authorize the smartthings hub, but when I press the done authorizing, it sets me back to the authorize main page.I have tried with and without a password, I have set the housepanes folder to 777 and changed ownership to pi:pi. Iam downloading dietpi for a pine64 board to see if that makes any difference, but would like this to work on my VM. Any suggestions?

This happens when the settings don’t get saved in the hmoptions.cfg file or if cookies are not enabled on your client. Make sure you have cookies enabled and make sure your hmoptions.cfg file is set to read/write by the www user. The simplest way to do this is to just set it for everyone to read/write it using chmod 777 hmoptions.cfg

If both are set and it still happens, let me know and I will try to troubleshoot your issue further.

Within the folder make sure the file hmoptions.cfg is also set to 777 and user pi:pi - although most Linux installs use www-data as the web app user. It won’t matter if you use 777.

I have tried 3 different browsers, making sure the cookies were enabled. I have changed ownership to www-data, and the whole folder is 777. I added the file hmoptions.cfg for the main housepanel folder, as well as in the HousePanel-master folderand ensured the permissions are at 777. I notice on the smartthings log that the rPi address is blank. Other than that, I’m somewhat lost

Check your server to see what the “config” section of the hmoptions.cfg file looks like. It should have a section called “pword” and look something like:

“pword”:{
“user1”:"$2xxxxaaaaa12224YOnXvB/ac5S3GZ2L38Zuvp0gkY2SL1dFm",
“user2”:"$2y$10$zzsHyQBBA709E3hIwdHy8Ock26kZc2aURr.CfRxQrI/Q8len86HS"},

the values on the left are your user names and the values on the right are your hashed passwords. The values above are bogus examples.

If you want to bypass the process you can make a section that looks like:

“pword”:{“user1”:""},

this will allow user1 to log in without a password. With this added to your file, upload it to your server. My guess is that for some reason your server is not saving this info to the file.

[RELEASE V2.092] Minor updates including tweaks to album art and inspection location on screen adjusted when close to right edge.

This version also marks a major update to the documentation on www.housepanel.net

I just got this going about 3 minutes ago. I started a new VM with debian. I added user and group pi, used node.js version 10 and made sure phpinfo gave the right indicators. I then ran the script. I got an error for line 48, but other than that, it went through. chmod to 777 and ran the housepanel.php That brought back a hub id, and I now have some content in hmoptions.cfg file.
Now I just have to see why the ubuntu VM would’t take the system, whether it’s a finger problem, or it doesn’t like the version of node (8.10) or the cast-web-api service

Thanks for hanging in there. It appears that setting up HP on anything other than a rPI is always an adventure. I will have to look into the line 48 error. Can you post what the error message was? Enjoy the system now that you have it running. The updated documentation on housepanel.net is now reasonably complete enough to show you most of what HP can do.

nisupdate = “n” shows up as an error. It didn’t stop the install as far as I know

1 Like

Thanks… the blanks shouldn’t be there. It only impacts the default answer so if you typed n or y the error won’t matter. I will fix this in the next release later today. Good catch.

I finished an important new feature tonight that enables each user to use a unique skin. This way you can enable one dashboard to look totally different than another one. Previously all users in the same home had to use the same skin and could only change the icon selections and locations. Now the whole look and feel of multiple users in the same home can be different.

I also added user custom tiles set using the Tile Customizer to user specific option files. This way each user can have their own set of customized tiles. And finally the active user shown in the upper right corner can now be clicked to quickly log out so you can log in a new user without going to the reauth page.

It is not posted yet but will be later tonight. Found and fixed some bugs too as usual. This update cleans up how skins are handled. They no longer are copied to the main folder rather used in the skin folder. This is more efficient and robust than the prior handling.

[RELEASE] Version 2.100

This update includes the noted features in the above post. The skin selected AND all changes made to tiles in the Tile Customizer are now specific to a given user. This enhances the flexibility of the dashboard such that each user can now have a totally unique look and feel.

I also made performance improvements to the Album Art so that more things show up, including radio stations requested via TuneIn.

Finally, if you click on the username in the upper right corner now you can quickly log out so a new user can log in. Beware that if you log out you will need to know a valid username/password pair to get back in.

Here’s a screenshot showing my customized control panel and an Album Art example. This example also shows a customized tile that combines a door and a light into a single tile. To upgrade to this version you will need to replace the updated files on your server and restart the housepanel-push.js service. Enjoy.

Hi All,
I just started over the weekend and housepanel up and running on my RPI3. I have been playing around trying to customize the UI to fit my family. A few things, I am looking for some suggestions and/or guidance on.

I will start here:

  1. How do you exit Kiosk Mode? Once I am in there, I am unable to return back to other main mode
  2. How are folks handing video from RING cameras? Is there a way to have these displayed in HP?

Thanks,
Sean

Launch this in your browser:
…/housepanel.php?api=showoptions

This is on my to do list. If you add a Ring as an other device you will see the ring video stream address.

[EDIT] I just did this and what it returns a rstp reference under the field name “OutHomeURL”

I tried loading the returned RSTP into a browser and it didn’t work. I think you will need to also provide the Ring account access token. Again, I have this on my todo list to automate this and pipe it into a video icon for you. I don’t know if it is doable but I will try.

1 Like

@kewashi Thanks for this and trying to get the RSTP stream from the ring.

Another another topic, I have my water sensors pulled into HP, how would I go about having the text “DRY” replaced with a image (one for dry and one for wet) ? I would think this would be addressed in the css ? I took a look but was unable do find anything for the moisture/water sensors in the housepanel.css file?

Suggestions?

Use the built-in tile editor
Take a look at www.housepanel.net for full instructions

I don’t have default icons set because I don’t personally own any sensors of this type so I had no way to test it.

If you really want to do manual CSS editing, add a new styling block using:

div.water.wet {
blah blah blah
}
div.water.dry {
blah blah blah
}

Thanks Ken, was tried both ways to get this working. I was able to get the code updated and added into the CSS.
I am able to see the in the live log as well as the events history the state changes so the data is getting sent to homepanel, however the icon doesn’t change when the state changes. Any ideas what I might be missing here?

Here is what I added into the housepanel.css

/*Water Sensor Styling */
div.water.wet div.custom.water.wet {
background-image: url(‘http://cdn.device-icons.smartthings.com/alarm/water/wet@2x.png’);
}
div.water.dry div.custom.water.dry {
background-image: url(‘http://cdn.device-icons.smartthings.com/alarm/water/dry@2x.png’);
}

I made a virtual sensor and testing the following and it works. Will add it to the base code as the default in the next update. Until then, try the code below in your housepanel.css file

div.overlay.water div.water.wet {
background-image: url(‘http://cdn.device-icons.smartthings.com/alarm/water/wet@2x.png’);
background-color: rgba(204, 255, 204, 0.6);
color: rgba(255, 255, 255, 0.01);
}
div.overlay.water div.water.dry {
background-image: url(‘http://cdn.device-icons.smartthings.com/alarm/water/dry@2x.png’);
background-color: rgba(226, 234, 40, 0.6);
color: rgba(255, 255, 255, 0.01);
}

And put this in your tileeditor.css tile:

div.overlay._wet, div.overlay._dry {
display: none;
}

Your version might work if you replace the space with a comma after the first .wet and .dry but the above is tested and works.
image
image

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.