SmartThings Community

[RELEASE] HousePanel Dashboard for SmartThings and Hubitat

project_dashboard
(HousePanel Author) #1524

Macros branch updated. Here’s the doc info for this new feature:

Macros are a more powerful alternative to automation than the RULE system
provided by the Tile Customizer. With Macros you can string together any number of action calls that HousePanel supports and connect it to any field on any tile. The catch is there is no GUI for defining Macros (yet). Macros must be hand-written and saved in your hmoptions.cfg file, so this is a feature only for power users. Macros are defined in a section of the hmoptions.cfg file called “macros”. That section looks something like:

"macros":{
"custom|custom_4|test":
[
  ["-","adcd1-12345-4a33-c111-11223ea123","switch","switch","toggle"],
  ["-","dcba9-54321-4cda-a222-223344abcd","switch","switch","off"],
  ["-","dcba9-26371-5cda-b333-65432abcda","switchlevel","level","on","60"]
]
}

The keys are a string composed of the type, the id, and the field, separated by the “|” symbol. The type|id pair is the “connected tile” that is used to trigger the macro. This should be one of the tiles listed in the “index” section of the hmoptions.cfg file. The field specified is the field that is clicked on to invoke the macro. An array of arrays follow. Each array entry has up to 6 fields. The first array element is the hub id. If “-” is entered, the hubid of the connected tile is used. The second element is the id of the thing to automate. The third element is the type of thing. The fourth element is the field to control. The fifth element is the command or value to pass to HP.

For example, it could be “on”, “off”, “open”, or “close”. A sixth element is attribute that is sent for some tiles to be controlled. For example, level can be sent this way.

Any number of macros can be defined and they can be tied to anything, including custom fields as is shown in the above example. The only restriction is they cannot be mixed with RULE custom fields.

(HousePanel Author) #1525

[RELEASE] HousePanel V2.020

Merged macro feature into master branch and tagged for release.

Cleaned up old tags.

Misc bug fixes.

#1526

Thanks for your help.

#1527

Hi can anyone tell me how to update to V2, i couldn’t find in the documentation unless I missed it somewhere

(HousePanel Author) #1528

You didn’t miss it. I still need to write a how to update doc. Basically you need to replace the groovy code and then replace the php and js files on your server. Also make sure you replace any updated css files. There may be a few updated icons too in the skin-modern and skin-housepanel folders. Basically update anything that is new and keep your customtiles.css and hmoptions.cfg files as is.

Then do a Refresh on the panel.

(Rlane85) #1529

Just got HP up and running last night and I have to say it is amazing! Just what the wife and I have been looking for to display and interact with our ST.

One of my first priorities was to integrate my webCoRE pistons but for some reason they are not appearing in the HP options. I have double checked it is enabled in the smart app settings on my ST classic app, as well as re-authorized through HP to see if this helps - to no avail.

I have HP installed on my rPI (the same device I use to run a plex server).

Any other suggestions? Any help would be appreciated. Thanks so much again for this amazing service!

1 Like
(HousePanel Author) #1530

First of all, welcome to the ST community and to the world of HousePanel. I’m glad you like it.

I just enabled pistons to check that they are still working and they are. I don’t use them often. The three steps to use pistons are 1) enable Use Pistons in the legacy app as you did. Make sure to save. 2) Hit Refresh in HP. No need to reauthorize. 3) go to Options and check the Pistons checkbox in the top area so they show up. Add the ones you want to any room.

To confirm they are there you can open the ShowInfo page. You can also open a log page to see if an error is happening when you do the Refresh step.

1 Like
(HousePanel Author) #1531

By the way, if you are using the skin-modern skin there is a formatting problem that I just noticed for the first time. Will fix that in the next release. Until then just use the editor to change the icon size. All pistons can be set at once by changing the scope selection in the editor.

1 Like
(Rlane85) #1532

Thanks for the reply! They still aren’t showing up - I’ve been doing live logging on the ST IDE and I just realized the HP Smart App isn’t actually listed at all (except under my Smart Apps). Even tho the tiles I do have seem to be operating just fine (mostly lights and my Amazon Echoes). I’m guessing I’ve got something configured incorrectly. I’ll keep poking around and see if I can get this resolved and report back!

Update: I managed to get House Panel to appear in the IDE logs and List Smartapps (not sure how exactly but I published it again). Everything appears right as far as I can tell but still no pistons

(HousePanel Author) #1533

After you published it again, try opening HP in the legacy app on your phone and make sure Use Pistons is selected. Hit save. Go back to the HP web app and do a refresh.

1 Like
(HousePanel Author) #1534

[RELEASE] HousePanel V2.030 with bugfix for HSM and SHM to enable them to change state upon clicking. This version also fixes a few styling issues with piston tiles and the modern skin. And as usual i found a few other minor bugs that I squashed in this version. With this version to upgrade you will need to replace the groovy file in the SmartThings API. As usual you should update the housepanel.php and housepanel.js files and any other file that was updated. Be sure to keep your customtiles.css and hm*.cfg files so your config settings are retained.

(HousePanel Author) #1535

Sharing a screen shot of my use of the modern skin plus the Tile Customizer. In this screen shot you see that I linked a piston into a motion tile and I added a Rule to my closet light tile. I also created a custom tile and linked two switches into this single tile. Mainly trying to show the flexibility of HP here. Enjoy.

2 Likes
(Brad) #1536

Updated to 2.030 on my pi and the smart app and my setup basically went blank. Tiles are all gone and my ST devices no longer show up in the Thing list. I tried a Re-Auth, but no luck. Any ideas?

Edit: Things are now showing up, but all my pages are blank, including the custom backgrounds, which is odd (they were showing up before I did the re-auth). Looks like I have lost my whole setup. I must have overwritten something I shouldn’t have, but can’t figure out what.

(HousePanel Author) #1537

First - I’m super sorry this happened. The skin logic sometimes does this by overwriting the customtiles.css file with a blank one. See if you have an old copy - and if so, copy it to your skin folder and your main folder.

Also, make sure you saved your hmoptions.cfg file and that it has permissions set to write for www-data or chmod 777 works too.

(The Master) #1538

Im trying to install on an existing Ubuntu server. I get a error that the page is not redirecting properly in the browser. Firefox has detected that the server is redirecting in a way that will never complete.

Any ideal whats causing this.

HTTP_HOST 192.168.0.20
HTTP_USER_AGENT Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:65.0) Gecko/20100101 Firefox/65.0
HTTP_ACCEPT text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,/;q=0.8
HTTP_ACCEPT_LANGUAGE en-US,en;q=0.5
HTTP_ACCEPT_ENCODING gzip, deflate
HTTP_REFERER http://192.168.0.20/housepanel/
HTTP_CONNECTION keep-alive
HTTP_COOKIE _ga=GA1.1.40781009.1553197734; _gid=GA1.1.2005002721.1553197734
HTTP_UPGRADE_INSECURE_REQUESTS 1
PATH /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
SERVER_SIGNATURE Apache/2.4.18 (Ubuntu) Server at 192.168.0.20 Port 80
SERVER_SOFTWARE Apache/2.4.18 (Ubuntu)
SERVER_NAME 192.168.0.20
SERVER_ADDR 192.168.0.20
SERVER_PORT 80
REMOTE_ADDR 192.168.0.20
DOCUMENT_ROOT /var/www/html
(HousePanel Author) #1539

The referer looks like the folder without the php file. Try adding /housepanel.php to your URL in the browser.

(The Master) #1540

The refer says that because i browsed the directory before loading phpinfo. I have since upgraded to ubuntu 18 and it broke my php install so im gona just start over and reinstall everything.

(Bob5731) #1541

how install in windows 8.1?

(HousePanel Author) #1542

strongly recommend you don’t try.

If you insist, start with searching the web for how to get an apache web server set up on Win 8 with PhP working.

Then install HousePanel by unzipping the folder in the html directory.

Trust me, you will be much happier if you sheelnout the $35 bucks to buy a rPI to use. Adafruit website has a good description of how it works.

(Bob5731) #1543

Thanks for all the hard work.
Took me several hours to figure out how to set this up. Some better instructions would be nice please.

My door lock is also showing this extra crap I don’t want to see. Is there a way to remove it.
clear

8 unset

{“1”:“Brandon”,“2”:“Sandra”,“3”:“Mom”}

Complete

30

3

clear

lock

unlock

reloadAllCodes

unlockWithTimeout

alarmToggle

sensitiveToggle

disableKeypad

enableKeypad

enableAutolock

disableAutolock

disableAudio

enableAudio

disableOneTouchLock

enableOneTouchLock