SmartThings Community

[RELEASE] HousePanel Dashboard for SmartThings and Hubitat


(HousePanel Author) #1143

The logging should show up in the web page where you are viewing live logs from the graph.api website. If you open a live logging page after loading the newest version, a HP refresh should show you what the getSwitches call returns.

Looks to me like your groovy code is crashing on a piston that is confusing it. I have not seen that before but let me investigate.

(Chris Wilson) #1144

Hey Ken,

Just a quick update. Short story everything seems to be working smooth again. Long story I do not know what was going on last night. While I was playing with everything I noticed I was getting serious lag. Whether through the dashboard or directly through the web interface it was getting ridiculous.

So one more time.deleted all the files on the server. Uninstalled the housepanel app from the hub. This immediately made the hub responsive again. Added the app back more lag. Uninstalled the app again. Deleted the code. Added it fresh from github again. Gave the app a different name this time. And what do you know 24 hours later everything seems to be good again.

No idea what the issue was but once again thanks for your patience and support.

(HousePanel Author) #1145

Well I am glad you have it working. I haven’t seen the behavior you describe and I stared at the code for hours to convince myself it was right.

Let me know if you run into any other problems.

(Chris Wilson) #1146

Is anyone else having trouble with tile edits not sticking from the editor? Seems a refresh resets everything every time here… NM fixed it – seems permissions were not right…

(HousePanel Author) #1147

Updated the wiki today to include documentation for Hubitat installations. Enjoy.

(Babar Khan) #1148

First of all thanks for such a wonderful looking and useful app, as I can foresee.
I have similar problem as of @kalwa above. Installation went smooth, ST IDE was logged in automatically, authentication done, devices checked and authorized, page returned to HP, BUT no devices showing up. All permissions are correct, double-checked, hmoptions.cfg show default options without my devices added and refreshing doesn’t show any error log in ST IDE.
Do not know where I went wrong. Help will be appreciated.
(I checked and double-checked all your suggestions to @kalwa above)

(Babar Khan) #1149

btw, I have installed HP on RPi as advised and have a single ST Hub and authorized all my devices.

(HousePanel Author) #1150

I think there is an issue with reading pistons. I will try to disable them and you can try again.

(HousePanel Author) #1151

Okay - try it now… pistons now will be ignored by default. To enable them you have to use the mobile app and toggle the option at the bottom of the screen and then do a reload.

(Chris Wilson) #1152


Hey ken, Is there currently an api call available that can trigger the refresh all action? I am using api to deliver a status report to alexa. I would like to call a refresh on the devices before she call for the device status. (I know nitpicking housepanel actually updates pretty quickly, I just want to try and get the most up to the second info I can).

(Babar Khan) #1153

Thanks for all the effort - but - no luck!
I even deleted everything, started afresh, installed smartapp and HomePanel, granted permissions, authorized, but still the same - just the default page with no devices of mine.
Another thing, forecast.html is missing.
I appreciate your efforts. :slight_smile:

(HousePanel Author) #1154

Try useajax=refresh

But… when a status doquery is done it reads the sensor latest status from groovy so you probabaly do not need to do this.
[EDIT] I checked and this API call does work, but it will also redirect whatever called it to housepanel. Should be okay if you are invoking it from a child process.

(HousePanel Author) #1155

First - on forecast.html - OMG, I totally missed adding this to the git library. It is now there. Sorry about that. Be sure to edit it to change the city in two places from Ann Arbor to wherever you live.

On the tiles not showing up, if you open a SmartThings IDE log window, and then reauthorize your system, you should see something that looks like this:


Can you check and see if that is happening? I assume you are able to log in okay. Also, I haven’t tested HP with the new Samsung account types so let me know if that applies to you. Finally, I assume you are able to log into and authenticate you account okay. Are you also using Hubitat? If not, make sure those parameters are set to false in the clientinfo.php file.

That’s about all I can think of to check for now.

(HousePanel Author) #1156

After this debug logging listing you should then see another list showing Number of switches = 2 for the above example. It should look like the prior post. If you are not seeing this then something is wrong and I will have to do further troubleshooting. let me know.

(Chris Wilson) #1157

Ah there is the bit of info I needed I guess. I was not sure if it was retrieving the info from the hub when making this call or not. I was kind of thinking it was reporting the current state noted on the dashboard. if this is the case the need to make the refresh call is moot. The refresh call does work though.

(Chris Wilson) #1158

Hi Ken, Not sure how hard it would be - just another suggestion.

For the multi attribute sensors that will report temp like this - could the default be changed to show small text at the top of the tile? Similar to how the battery indicator is displayed?


Also I rather like how the lock tile is styled. With no header on text on the left.
I do not know if these would be easy or hard changes - or if the options would be simple to add to the tile editor or not.


A little playing with the css gets me this.


Cant seem to get it to the left though.

aha got it.

(Babar Khan) #1159

No such log shown - devices being populated.
Tried almost everything in book.

(Babar Khan) #1160

In the log, when re-authenticating, it shows like this:
HousePanel: debug: Installed with settings: [myswitches:…
and a list of things that I selected (Not enumerating or without any get etc)

(Chris Wilson) #1161

Seems we used to be able to change room names from the options page. I do not seem to be able to do this anymore. Was this option removed?

(HousePanel Author) #1162

That old feature never worked so I removed it. The plumbing for a version that works is now in place. I just need time to wire it up. You might notice the hmoptions file now has an optional name. That is the plumbing.

[EDIT] I was confused. You are right - this feature was broken so I disabled it. I will fix it soon. The plumbing noted above is for renaming individual things.