[RELEASE] HousePanel Dashboard Beta 1.0 Under Open-Dash Brand

project_dashboard

(Darren) #442

I would have to double check but 1 of the ones failing is the ST plug, however the issue maybe how errors at captured ie if one fails all in the group fail , instead of letting the good ones thru.

The reason I say that is the st plug was one of my initial 2 devices, the second device is using a custom DH, all right.

I can test that scenario tomorrow, I’m no longer on my network.


(Edward Niedziejko) #443

So it’s not specific to custom handlers. My suspicion is that it has something to do with device identification, but you’ll probably have to get help from someone more familiar with the back end stuff.


(HousePanel Author) #444

This is hugely helpful … looks like an issue with reading in your switch. So we know the issue is with the groovy code. Let me take a look. What kind of switches are you adding?


(HousePanel Author) #445

I’m staring at the groovy code and it must be somewhere in the getThing routine, but nowhere in this routine is there any Number processing… I am stumped at the moment. It can’t be output devices because thermostats and Lights are also output devices. In fact, Lights use the exact same function as Switches so this is super weird. Contact also uses getThing. So does Motion. Only thing I can think of is some oddball field being returned by getThing. Need to sleep on this and debug more tomorrow.

If you’re feeling brave, it would help if you could sprinkle a few log.debug print statements into the getThing routine in lines 354 to 369 in HousePanel.groovy and then report back what they say and the order relative to the java error.


(Edward Niedziejko) #446

I thought that too what is the difference between “bulb” and “light” exactly? And “temperature” isn’t a thermostat, it can just be a temperature sensor, so single direction.

The initial devices are listed in his error log, a Kasia - Power Outlet - ST, and Landing Milights - Z2

Is it possible there’s a syntax difference in connecting to the European Smartthings hub? I know it’s on a different firmware cycle than the NA hub v2.


(Darren) #447

@Kenwashi - I have all sorts of switches, Belkin WeMo, TP, ST, Xiaomi. However I have other devices that report as switches which are not actual switches in the real world sense.

Taking @Edward_Niedziejko train of thought further I removed one of the switches and left the single ST switch ticked and it came over (YAY), the second switch did not. Therefore it looks like when it crashes it comes out of the routine completely on an all or nothing concept.

Taking the above scenario into account I can confirm these physical switches WeMo, TP, ST and Xiaomi came over when ticked.

I can also confirm that these ST Smartapp based devices also came over when ticked
Rooms Manager , trend setter , IKEA Tradfri, Harmony and Hue.

The ones that have failed to come over just happened to have been in my initial test case (the light was beside me for testing in Housepanel) are coming in via a ST App Domoticz API interface, created by Martin. Tagging @Dudz40, he may know why those devices are not acting the same as the other ones.

I attempted to debug the groovey code, but I just couldn’t work out the syntax correctly. I was trying to capture the variables going through the loop, but kept failing :frowning:


(Edward Niedziejko) #448

Given that it is specific to a particular API, there’s a good chance that’s what causing the problem and not HousePanel. Is it possible that you’ve got a space in a number field somewhere? Since spaces are letters, and number format exception points to a non-number being in a number field, it’s something to look for.


(Martin Verbeek) #449

you can get this when an attribute is set with a wrong type. Since the code is getting capabilities and currentvalue of attribute states, might be worthwhile to look into…


(Darren) #450

@dudz40 If there is anything you need me to do on my end to test, just let me know.


(HousePanel Author) #451

Long awaited push of TIleEdit v3.2 is in GitHub under branch tileedit32

This has numerous mods to NIck’s version to allow it to work with multiple tile types.

Also squashed a few bugs.

This needs more testing before I will merge it into the master branch, but it should be good enough to give it a whirl and to provide feedback.


(Edward Niedziejko) #452

\o/ You’re a superstar. I’ll fire it up tomorrow probably, too late tonight to get too much into it.


(Biofects) #453

Sorry this is late,
I made a quick website to post stuff like this :grinning:
Biofects Home-Panel in Docker


#454

Not a problem as it’ll take me a while to ramp up on docker:thinking: I skimmed thru your instructions you’ve posted. Where did you get your docker container builds from? Or was it built from raspbian(I currently use that on my pi3)? Guess have to go search up docker containers to read up on…


(Chris Wilson) #455

Hi Ken,
This all seems to be working as it should. There are a few formatting issues it looks like needs to be worked out maybe. Otherwise I believe it is functioning well from my point of view.

image

example here lol - tile resizes but everything else attached stays the same size.


(HousePanel Author) #456

Yea - I didn’t bother resizing them because those ugly bars will go away soon when I get sliders to work, and they will be scaled. Sorry about that. And your little hue icon on top is missing. Should be a rainbow circle.


(Edward Niedziejko) #457

TileEdit3.2 seems neat so far. Gradients are on the Icon header, not the Tile one, which seems funny from a UI perspective. Clicking “invert” on the icon tile also inverts the background color and gradient direction. I feel like the background color and gradient should be separate from the icon selection, which would allow inversion of just the icon (black to white, for on/off states) without having to change the color and gradient.

Static colors are also transparent, and gradients are not… Not sure if this is intended.

Nick’s earlier screenshots showed the text of the tile without a header when header was removed, this doesn’t appear to be working currently.


(HousePanel Author) #458

Good feedback- I had to change a bunch of stuff to get the code to work with all tile types and be true wysiwyg so I probably broke a few things. Will keep testing and squashing bugs. Thanks for being great beta testers.


(Edward Niedziejko) #459

Another thing, in order to “set” the gradients, you have to select an icon, so it doesn’t work for Digital Clock or Routines as neither can have an icon set.


(HousePanel Author) #460

Actually any tile can have an icon by adding it in the default CSS tied to the div.clock.name for example. On my todo list is to make a blank graphic and use it on all text tiles to make editing easier. Until then you can do it manually in housepanel.css


(Edward Niedziejko) #461

There’s already a “toggle” button, but clicking the tile also “toggles” the state. I think the toggle button could be renamed and used instead for making the current setting active, instead of clicking on the icon in the icon selection field.