SmartThings Community

[RELEASE] Honeywell Evohome Integration

honeywell
thermostat
climatecontrol
smartapp_hvac
dth_hvac

(Paul Ockenden) #166

No longer working for me, either. Like Tom says, it’s worked well for a long time, and much better than the official integration. I’ve been using a test version, with Hot Water control too.

Any ideas David?


(Dean Aaron Roberts) #167

Same as some of the others above - mine’s stopped working.


(Fred) #168

How did you uninstall it? When I try via the app I get an error and via the IDE it says the SmartApp is being used by other users.


#169

You have to remove the zones from all automations. Open each zone and switch to SmartApps tab, there you’ll see where each zone is used.
It’s a rubbish user interface :frowning:


(Fred) #170

Right, thanks for that. So I managed to remove the SmartApp with your instructions and then I also deleted the DTH and SmartApp from the IDE. So completely starting again. I then recreated the DTH and SmartApp, provided my evohome credentials and my zones are now updating again in ST. I don’t really use the SmartApp to control my evohome but I was using webcore to send me notifications of when the heating turns on and off so I now have that working again…in case anyone else is interested.


#171

Interesting. I’ve done the same, copied code from GitHub and zones are still not updating. I have no errors in log.


(Fred) #172

Did you completely remove the SmartApp and dth before adding them in again?


#173

Yes I removed everything and recreated all from GitHub.


(Bryn) #174

Hi All. Ive never managed go get this working! I can ‘see’ my heating in ST but all buttons greyd out and i have no control or anything. Can anyone point me in the right direction. Im a total newby to all this and trying to work it all out!!
Thanks in advance


(Kevin [Yorkshire UK]) #175

It’s sad when a developer abandons his project, and users. Even worse when ST abandons/ neglects their official version too.


(paulhorti@hotmail.com) #176

After it stopped working for me, i’ve just uninstalled it and then reinstalled it from github and it now seems to be working OK.


#177

hmmm. reinstalled from github and seeing temps but with a “?” after them and it won’t change mode or setpoint. in loggin get this error

2:09:26 AM: error Master Heating Zone (Evohome): setHeatingSetpoint(): Error: Unable to set heating setpoint.
f32f201b-dba0-4807-86cd-94562c7ecb48 12:09:26 AM: error Evohome (Connect): setHeatingSetpoint(): Error: groovyx.net.http.HttpResponseException: Bad Request
f32f201b-dba0-4807-86cd-94562c7ecb48 12:09:26 AM: info Evohome (Connect): setHeatingSetpoint(): Zone ID: null, Setpoint: 20.5, Until: 2017-11-06T06:00:00Z

looks like maybe isn’t passing a zoneID so can’t do it?

Anyone else got mode or setpoints working? Anyone out there help? this is killing loads of my automations!

@zcapr17 - still no response?

Thanks,
Tom


(Bill) #178

I have the same. All stopped working some time in the last 3-6 weeks. “. No recent activity” for any of my zones, all the “current” temperatures appear trapped in time from when it was last working and I can’t change the setpoints anymore. :weary:


(paulhorti@hotmail.com) #179

Just rechecked and I can see that all the zones are showing the correct temp, schedule etc. but it fails when trying to update (http request failure). As said previously, the debug shows the zoneid to be null which would explain the request failure… Now just need to find out why.


(Byteguy) #180

I also have the same problem, it was working a few weeks ago but recently all the displayed temperatures just froze and none of the buttons work. I’ve tried completely removing everything are reinstalling and it still doesn’t work. It does find all the heating zones, about 10 of them and name them correctly but never updates the display or show any activity in “Recently”. watching the debug log no obvious errors and it does seem to be reading values eg set points and temperature from evehome but those values do not appear on the Smartthings panel.


(paulhorti@hotmail.com) #181

It’s back up and working again for me. What I did was (apologies to those who know all/ most of this or have already tried this):
Uninstall the APP/ Device Handler

  1. Went through each device on the Smartthings App and ensured that there was no SmartApps linked to them apart from the Evohome SmartApp itself - I had webCoRE pistons linked to them so I paused the pistons and removed all the evohome devices
    from webCoRE
  2. Removed the Evohome SmartApp via the Smartthings App
  3. Uninstall the SmartApp in the IDE. Do it via the My Locations tab, choose smartapps (under Installed SmartApps), click on Edit under Home banner and then click on Uninstall.
  4. Delete the SmartApp in the IDE - go SmartApps, chose the evohome smartapp, click on App Settings and then Delete.
  5. Delete the Device Handler in the IDE - go My Device Handlers, chose the evohome device handler, click on Device Type Settings and then Delete.

Reinstall

  1. Copy the source code from GitHub (as per the original instructions )
  2. Install the App in the Smartthings App (as per original instructions ) and ensure that Enable debug logging

review the log

  1. In the IDE, choose live logging
  2. In the Smartthings App, try to change a setpoint.

For me, when I tried to change a setpoint, I always got a ‘Evohome (Connect): setHeatingSetpoint(): Error: groovyx.net.http.HttpResponseException: Bad Request’ error. This was preceded by a 'setHeatingSetpoint(): Zone ID: null, Setpoint: nn.n, ’ error.
The error implies that the device handler has lost the zone id and as this is used as part of the http request it will always fail. It’s a bit strange as the device id should be passed to the device when it is originally created. You can see the device ids in other debug messages e.g. updateChildDevice(): Updating Device with DNI: Evohome.1313453.1435353.1345345.12345678 … The last number is the device id.

reinitialise the device handlers
The solution to this (for me) was to get the SmartApp to resend the device id to the device handler. Fortunately you can do this going into the SmartApp and changing a setting (I changed the polling period) which causes a refresh of the data. It now works, I can change the setpoint via the Device tile in the Smartthings App, via a piston or via an App that I wrote.

Hope that will help someone.
Paul


(Bill) #182

I’m up and running again. Phew!
Thanks for the detailed uninstall instructions Paul.
I’d not fully deleted the device handler and think that was preventing me from a full clean reinstall.

I love having the heating shut down and start up depending on when the family leave or arrive.

I only spotted it had stopped working because I was using one radiator thermostat’s temperature readings to control another device and that had stopped working.

So pleased this is working again. Ironically echo/Alexa and Honeywell evohome intergration has been officially delivered by Honeywell. Shame they never completed an official integration for Smartthings


(Byteguy) #183

Odd I’ve tried uninstalling as above and reinstalling but no joy, it’s still not working for me. I’m in the UK if that makes any difference.


(Bill) #184

I’m in the UK. I thought I’d uninstalled and reinstalled and still no joy, Turned out I hadn’t followed the full Delete instructions to delete the device handler and smart app from within the IDE. Finding the delete option wasn’t completely obvious tbh. Once I did that and fully published both sets of code for Device Handler and Smartapp from a truly blank start, it all worked.


(Byteguy) #185

Hey good call :smiley: I’ve uninstalled yet again but making sure I did do every step, and low and behold its now working. Cheers